archivers/lz4: Remove cross-compilation patch; make different target.

The `all' target apparently includes things that aren't necessary for
the build products we expect.  Just use an empty target so that make
selects the first one in the makefile, which according to
https://github.com/lz4/lz4/issues/1240 is the reasonable choice here.

No change to the build products that are installed -- this just makes
lz4 build fewer things.
This commit is contained in:
riastradh 2023-06-15 10:03:34 +00:00
parent 0a131c503f
commit fa9dcc23b7
3 changed files with 3 additions and 26 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.26 2023/06/14 11:07:42 riastradh Exp $
# $NetBSD: Makefile,v 1.27 2023/06/15 10:03:34 riastradh Exp $
DISTNAME= lz4-1.9.4
CATEGORIES= archivers
@ -13,15 +13,10 @@ LICENSE= 2-clause-bsd
USE_LANGUAGES= c99 c++
USE_TOOLS+= gmake
PKGCONFIG_OVERRIDE+= lib/liblz4.pc.in
BUILD_TARGET= # empty
TEST_TARGET= test
# Needed for nanosleep() on Solaris 10, PR pkg/56226
LDFLAGS.SunOS+= -lrt
.include "../../mk/bsd.prefs.mk"
.if ${USE_CROSS_COMPILE:U:tl} == "yes"
MAKE_FLAGS+= CXX_FOR_BUILD=${NATIVE_CXX:Q}
.endif
.include "../../mk/bsd.pkg.mk"

View file

@ -1,9 +1,8 @@
$NetBSD: distinfo,v 1.24 2023/06/14 11:07:42 riastradh Exp $
$NetBSD: distinfo,v 1.25 2023/06/15 10:03:34 riastradh Exp $
BLAKE2s (lz4-1.9.4.tar.gz) = 47eac8d4a549b2ab125e6b44d9c0acd1ed2c4d0e86054ecacc5f9704a0d4c208
SHA512 (lz4-1.9.4.tar.gz) = 043a9acb2417624019d73db140d83b80f1d7c43a6fd5be839193d68df8fd0b3f610d7ed4d628c2a9184f7cde9a0fd1ba9d075d8251298e3eb4b3a77f52736684
Size (lz4-1.9.4.tar.gz) = 354063 bytes
SHA1 (patch-Makefile.inc) = 7f27fb9d4cde9c14623c8fce167990bec0332161
SHA1 (patch-contrib_gen__manual_Makefile) = c29514de7920f484e4b00b8fd79ce4d8d2e80428
SHA1 (patch-lib_Makefile) = 64441f91217cf5832f122ed32a31007b4a8dc5f4
SHA1 (patch-programs_Makefile) = bf3a8b296bfac8407c3e233c41fa037ba989876c

View file

@ -1,17 +0,0 @@
$NetBSD: patch-contrib_gen__manual_Makefile,v 1.1 2023/06/14 11:07:42 riastradh Exp $
Handle cross-compilation.
--- contrib/gen_manual/Makefile.orig 2022-08-15 22:45:31.000000000 +0000
+++ contrib/gen_manual/Makefile
@@ -56,8 +56,9 @@ endif
.PHONY: default
default: gen_manual
+CXX_FOR_BUILD = $(CXX)
gen_manual: gen_manual.cpp
- $(CXX) $(FLAGS) $^ -o $@$(EXT)
+ $(CXX_FOR_BUILD) $(FLAGS) $^ -o $@$(EXT)
$(LZ4MANUAL) : gen_manual $(LZ4API)
echo "Update lz4 manual in /doc"