Drop forward declaration, the real one is already in place.

This commit is contained in:
joerg 2014-08-13 22:33:44 +00:00
parent eb41812b6b
commit fad30cc9ff
2 changed files with 10 additions and 8 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.158 2014/07/25 14:21:18 tron Exp $
$NetBSD: distinfo,v 1.159 2014/08/13 22:33:44 joerg Exp $
SHA1 (firefox-31.0.source.tar.bz2) = a6c3e25ee3aeb7da42db2aaeb50a385d63532beb
RMD160 (firefox-31.0.source.tar.bz2) = 8512ed164920c9fdad492ba2b47b46aae4894564
@ -33,7 +33,7 @@ SHA1 (patch-config_system-headers) = c586c07d96ba3bd6ac35247ed50eab0978ccc949
SHA1 (patch-config_system__wrappers_unwind.h) = b3bdac0710179b9c8f8eabd824216d0114504491
SHA1 (patch-content_base_src_moz.build) = fc2660dcc82f11c89d6d5a5772f27c9827f58f44
SHA1 (patch-content_media_AudioStream.cpp) = 70021dfd1cc86e8999f144b49a23bfb27dd24157
SHA1 (patch-content_media_AudioStream.h) = 5cda5329db7bef4c45f3a05a33a5ee7043ec3c2e
SHA1 (patch-content_media_AudioStream.h) = 11cd8649f35c001fa0bf9e0f6119e49bd41ab9b4
SHA1 (patch-content_media_Makefile.in) = 54c8c5e41eb36bae0ce544360ded9f75ba3acc13
SHA1 (patch-content_media_fmp4_demuxer_bit_reader.cc) = 6d87cd7231e61a12396d15dd2fa3d1a51051e8ee
SHA1 (patch-content_media_gstreamer_GStreamerAllocator.cpp) = 524a669e411189926e142912b6d94d3d8dbdb0eb

View file

@ -1,4 +1,4 @@
$NetBSD: patch-content_media_AudioStream.h,v 1.4 2014/07/24 14:57:12 ryoon Exp $
$NetBSD: patch-content_media_AudioStream.h,v 1.5 2014/08/13 22:33:44 joerg Exp $
--- content/media/AudioStream.h.orig 2014-07-17 01:45:09.000000000 +0000
+++ content/media/AudioStream.h
@ -10,12 +10,14 @@ $NetBSD: patch-content_media_AudioStream.h,v 1.4 2014/07/24 14:57:12 ryoon Exp $
template <>
class nsAutoRefTraits<cubeb_stream> : public nsPointerRefTraits<cubeb_stream>
@@ -26,7 +27,7 @@ public:
@@ -25,10 +26,6 @@ public:
static void Release(cubeb_stream* aStream) { cubeb_stream_destroy(aStream); }
};
namespace soundtouch {
-namespace soundtouch {
-class SoundTouch;
+class MOZ_IMPORT_API SoundTouch;
}
-}
-
namespace mozilla {
class AudioStream;