Initial import of OpenOffice.org 3.0.1 package from pre-build binaries
provided by openoffice.org. Release notes available under: http://development.openoffice.org/releases/3.0.1.html http://development.openoffice.org/releases/3.0.0.html
This commit is contained in:
parent
01b2dc3726
commit
fad663194f
9 changed files with 184 additions and 0 deletions
15
misc/openoffice3-bin/DEINSTALL
Normal file
15
misc/openoffice3-bin/DEINSTALL
Normal file
|
@ -0,0 +1,15 @@
|
|||
# $NetBSD: DEINSTALL,v 1.1.1.1 2009/01/31 22:05:53 bad Exp $
|
||||
#
|
||||
# This file contains the contents of the OOo rpm pre-uninstall,
|
||||
# post-uninstall scripts.
|
||||
|
||||
PRODUCTINSTALLLOCATION=${PKG_PREFIX}/openoffice.org@VER@
|
||||
|
||||
case ${STAGE} in
|
||||
DEINSTALL)
|
||||
if [ -h $PRODUCTINSTALLLOCATION/program/libfreetype.so.6 ]
|
||||
then
|
||||
${RM} $PRODUCTINSTALLLOCATION/program/libfreetype.so.6 >/dev/null 2>&1
|
||||
fi
|
||||
;;
|
||||
esac
|
14
misc/openoffice3-bin/DESCR
Normal file
14
misc/openoffice3-bin/DESCR
Normal file
|
@ -0,0 +1,14 @@
|
|||
OpenOffice.org is an Open Source, community-developed, multi-platform office
|
||||
productivity suite. It includes the key desktop applications, such as a
|
||||
word processor, spreadsheet, presentation manager, and drawing program,
|
||||
with a user interface and feature set similar to other office suites.
|
||||
|
||||
Components include:
|
||||
* A universal word processing application for creating business
|
||||
letters, extensive text documents, professional layouts, and HTML
|
||||
documents.
|
||||
* A sophisticated application for performing advanced spreadsheet
|
||||
functions, such as analyzing figures, creating lists, and viewing data.
|
||||
* A tool for creating effective eye-catching presentations.
|
||||
* A vector-oriented draw module that enables the creation of 3D
|
||||
illustrations.
|
18
misc/openoffice3-bin/INSTALL
Normal file
18
misc/openoffice3-bin/INSTALL
Normal file
|
@ -0,0 +1,18 @@
|
|||
# $NetBSD: INSTALL,v 1.1.1.1 2009/01/31 22:05:53 bad Exp $
|
||||
#
|
||||
# This file contains the contents of the OOo rpm pre-install, post-install
|
||||
# scripts.
|
||||
|
||||
PRODUCTINSTALLLOCATION=${PKG_PREFIX}/openoffice.org@VER@
|
||||
|
||||
case ${STAGE} in
|
||||
POST-INSTALL)
|
||||
if [ ! -f $PRODUCTINSTALLLOCATION/program/libfreetype.so.6 ]
|
||||
then
|
||||
if [ -f $PRODUCTINSTALLLOCATION/program/filter/libfreetype.so.6 ]
|
||||
then
|
||||
${LN} -s $PRODUCTINSTALLLOCATION/program/filter/libfreetype.so.6 $PRODUCTINSTALLLOCATION/program/libfreetype.so.6 >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
||||
;;
|
||||
esac
|
78
misc/openoffice3-bin/Makefile
Normal file
78
misc/openoffice3-bin/Makefile
Normal file
|
@ -0,0 +1,78 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2009/01/31 22:05:53 bad Exp $
|
||||
|
||||
DISTNAME= openoffice3-bin # overridden below
|
||||
PKGNAME= openoffice3-bin-${OO_RELEASE}
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ${MASTER_SITE_OPENOFFICE:=stable/${OO_RELEASE}/}
|
||||
|
||||
MAINTAINER= bad@NetBSD.org
|
||||
HOMEPAGE= http://www.openoffice.org/
|
||||
COMMENT= Integrated office productivity suite (binary pkg)
|
||||
|
||||
CONFLICTS+= staroffice-[0-9]*
|
||||
CONFLICTS+= openoffice-[0-9]*
|
||||
CONFLICTS+= openoffice-bin-[0-9]*
|
||||
CONFLICTS+= openoffice2-bin-[0-9]*
|
||||
CONFLICTS+= openoffice2-[0-9]*
|
||||
CONFLICTS+= openoffice3-[0-9]*
|
||||
CONFLICTS+= openoffice-linux-[0-9]*
|
||||
|
||||
OO_VER= 3
|
||||
OO_RELEASE= 3.0.1
|
||||
PLIST_SUBST+= VER=${OO_VER:Q}
|
||||
MESSAGE_SUBST+= VER=${OO_VER:Q}
|
||||
FILES_SUBST+= VER=${OO_VER:Q}
|
||||
|
||||
TEMP?= ${WRKSRC}
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
BUILD_DIRS= # empty
|
||||
|
||||
PLIST_SRC= ${PKGDIR}/PLIST.proglinks
|
||||
PLIST_SRC+= ${WRKDIR}/PLIST
|
||||
|
||||
EMUL_PLATFORMS= linux-i386
|
||||
#EMUL_PLATFORMS+= solaris-i386 solaris-sparc
|
||||
EMUL_MODULES.linux= compat freetype2 x11
|
||||
EMUL_REQD= suse>=10.0
|
||||
|
||||
EMUL_PKG_FMT= rpm
|
||||
RPMFILES= ${WRKSRC}/RPMS/*.rpm
|
||||
RPM2PKG_PREFIX= ${PREFIX}
|
||||
RPM2PKG_SUBPREFIX= # empty
|
||||
RPM2PKG_STAGE= do-install
|
||||
RUN_LDCONFIG= no
|
||||
|
||||
USE_TOOLS+= patch
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${EMUL_PLATFORM} == "linux-i386"
|
||||
DISTNAME= OOo_${OO_RELEASE}_LinuxIntel_install_en-US
|
||||
WRKSRC= ${WRKDIR}/OOO300_m15_native_packed-1_en-US.9379
|
||||
.elif ${EMUL_PLATFORM} == "solaris-i386"
|
||||
DISTNAME= OOo_${OO_RELEASE}_Solarisx86_install_en-US
|
||||
WRKSRC= ${WRKDIR}/OOO300_m15_native_packed-1_en-US.9379/packages
|
||||
.elif ${EMUL_PLATFORM} == "solaris-sparc"
|
||||
DISTNAME= OOo_${OO_RELEASE}_SolarisSparc_install_en-US
|
||||
WRKSRC= ${WRKDIR}/OOO300_m15_native_packed-1_en-US.9379/packages
|
||||
.endif
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
do-install:
|
||||
${PATCH} -d ${PREFIX}/openoffice.org${OO_VER}/program < ${FILESDIR}/soffice-patch
|
||||
uniq ${RPM2PKG_PLIST} > ${WRKDIR}/PLIST
|
||||
.if defined(PKG_JVM) && !empty(PKG_JVM)
|
||||
${RM} -f ${PREFIX}/bin/soffice
|
||||
${SED} -e "s|@@PREFIX@@|${PREFIX}|g" -e "s|@@OO_VER@@|${OO_VER}|g" \
|
||||
-e "s|@@JAVA_HOME@@|${PKG_JAVA_HOME}|g" \
|
||||
< ${FILESDIR}/soffice > ${PREFIX}/bin/soffice
|
||||
${CHMOD} +x ${PREFIX}/bin/soffice
|
||||
.else
|
||||
${LN} -sf ../openoffice.org${OO_VER}/program/soffice ${PREFIX}/bin/soffice
|
||||
.endif
|
||||
.for i in scalc sdraw simpress smath spadmin swriter
|
||||
${LN} -sf ../openoffice.org${OO_VER}/program/${i} ${PREFIX}/bin/${i}
|
||||
.endfor
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
8
misc/openoffice3-bin/PLIST.proglinks
Normal file
8
misc/openoffice3-bin/PLIST.proglinks
Normal file
|
@ -0,0 +1,8 @@
|
|||
@comment $NetBSD: PLIST.proglinks,v 1.1.1.1 2009/01/31 22:05:53 bad Exp $
|
||||
bin/scalc
|
||||
bin/sdraw
|
||||
bin/simpress
|
||||
bin/smath
|
||||
bin/soffice
|
||||
bin/spadmin
|
||||
bin/swriter
|
5
misc/openoffice3-bin/distinfo
Normal file
5
misc/openoffice3-bin/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2009/01/31 22:05:53 bad Exp $
|
||||
|
||||
SHA1 (OOo_3.0.1_LinuxIntel_install_en-US.tar.gz) = 6d3754ccb27e2a4b58635bc37e002e76f19bb4c7
|
||||
RMD160 (OOo_3.0.1_LinuxIntel_install_en-US.tar.gz) = fbf71e7192934472b1e2e477dd86f1471751c7fe
|
||||
Size (OOo_3.0.1_LinuxIntel_install_en-US.tar.gz) = 155910588 bytes
|
17
misc/openoffice3-bin/files/soffice
Normal file
17
misc/openoffice3-bin/files/soffice
Normal file
|
@ -0,0 +1,17 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $NetBSD: soffice,v 1.1.1.1 2009/01/31 22:05:53 bad Exp $
|
||||
#
|
||||
SOINST=@@PREFIX@@/openoffice.org@@OO_VER@@
|
||||
|
||||
# make sure we can find `whoami` on solaris
|
||||
PATH=${PATH}:/usr/ucb
|
||||
|
||||
# add the chosen java directory to $PATH to allow OOo to
|
||||
# automatically find it
|
||||
PATH=${PATH}:@@JAVA_HOME@@
|
||||
|
||||
# default data seg size is too small for java
|
||||
ulimit -d `ulimit -H -d`
|
||||
|
||||
exec ${SOINST}/program/soffice "$@"
|
17
misc/openoffice3-bin/files/soffice-patch
Normal file
17
misc/openoffice3-bin/files/soffice-patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
#
|
||||
# $NetBSD: soffice-patch,v 1.1.1.1 2009/01/31 22:05:53 bad Exp $
|
||||
#
|
||||
|
||||
--- soffice.orig 2009-01-18 23:49:18.000000000 +0100
|
||||
+++ soffice 2009-01-19 00:10:22.000000000 +0100
|
||||
@@ -73,6 +73,10 @@
|
||||
esac
|
||||
done
|
||||
|
||||
+# Set LD_LIBRARY_PATH so that javaldx finds libuno_sal.so.3:
|
||||
+LD_LIBRARY_PATH=$sd_prog/../basis-link/program:$sd_prog/../basis-link/../ure/lib${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}
|
||||
+export LD_LIBRARY_PATH
|
||||
+
|
||||
# extend the ld_library_path for java: javaldx checks the sofficerc for us
|
||||
if [ -x "$sd_prog/../basis-link/ure-link/bin/javaldx" ] ; then
|
||||
my_path=`"$sd_prog/../basis-link/ure-link/bin/javaldx" $BOOTSTRAPVARS \
|
12
misc/openoffice3-bin/options.mk
Normal file
12
misc/openoffice3-bin/options.mk
Normal file
|
@ -0,0 +1,12 @@
|
|||
# $NetBSD: options.mk,v 1.1.1.1 2009/01/31 22:05:53 bad Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.openoffice-bin
|
||||
PKG_SUPPORTED_OPTIONS= java
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mjava)
|
||||
PKG_JVMS_ACCEPTED= blackdown-jdk13 sun-jdk13 sun-jdk14 sun-jdk15
|
||||
USE_JAVA= run
|
||||
.include "../../mk/java-vm.mk"
|
||||
.endif
|
Loading…
Reference in a new issue