security/zxcvbn-c: import zxcvbn-c-2.5

zxcvbn-c is a C/C++ implementation of the zxcvbn password strength
estimation.

The code is intended to be included as part of the source of a
C/C++ program. Like the original this code is for character sets
which use single byte characters primarily in the code range 0x20
to 0x7E.
This commit is contained in:
ryoon 2024-02-11 21:45:44 +00:00
parent c83dd49b15
commit fadfeac398
6 changed files with 72 additions and 0 deletions

7
security/zxcvbn-c/DESCR Normal file
View File

@ -0,0 +1,7 @@
zxcvbn-c is a C/C++ implementation of the zxcvbn password strength
estimation.
The code is intended to be included as part of the source of a
C/C++ program. Like the original this code is for character sets
which use single byte characters primarily in the code range 0x20
to 0x7E.

View File

@ -0,0 +1,21 @@
# $NetBSD: Makefile,v 1.1 2024/02/11 21:45:44 ryoon Exp $
DISTNAME= zxcvbn-c-2.5
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GITHUB:=tsyrogit/}
GITHUB_PROJECT= zxcvbn-c
GITHUB_TAG= v${PKGVERSION_NOREV}
MAINTAINER= ryoon@NetBSD.org
HOMEPAGE= https://github.com/tsyrogit/zxcvbn-c/
COMMENT= Password strength estimator
LICENSE= mit
USE_LANGUAGES= c c++
USE_CXX_FEATURES= c++11
USE_TOOLS+= gmake
MAKE_FILE= makefile
.include "../../mk/bsd.pkg.mk"

5
security/zxcvbn-c/PLIST Normal file
View File

@ -0,0 +1,5 @@
@comment $NetBSD: PLIST,v 1.1 2024/02/11 21:45:44 ryoon Exp $
include/zxcvbn.h
lib/libzxcvbn.so
lib/libzxcvbn.so.0
lib/libzxcvbn.so.0.0.0

View File

@ -0,0 +1,12 @@
# $NetBSD: buildlink3.mk,v 1.1 2024/02/11 21:45:44 ryoon Exp $
BUILDLINK_TREE+= zxcvbn-c
.if !defined(ZXCVBN_C_BUILDLINK3_MK)
ZXCVBN_C_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.zxcvbn-c+= zxcvbn-c>=2.5
BUILDLINK_PKGSRCDIR.zxcvbn-c?= ../../security/zxcvbn-c
.endif # ZXCVBN_C_BUILDLINK3_MK
BUILDLINK_TREE+= -zxcvbn-c

View File

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2024/02/11 21:45:44 ryoon Exp $
BLAKE2s (zxcvbn-c-2.5.tar.gz) = 6e2e43801bd63da217ccbb03c48edcdf05a712a22e6c4a1b0561e295d8ec8d01
SHA512 (zxcvbn-c-2.5.tar.gz) = d7199b3cc36cd0e401bd8f857132425908307aefcdb1bb635ee81c34cf71ccbcdf0fe36a336a55da1281692b508881b54773afa41379a448863095f4abd5c0e8
Size (zxcvbn-c-2.5.tar.gz) = 1404434 bytes
SHA1 (patch-makefile) = c5b863a4a64f83ad361353e000068ead98142065

View File

@ -0,0 +1,21 @@
$NetBSD: patch-makefile,v 1.1 2024/02/11 21:45:44 ryoon Exp $
* Add install target.
--- makefile.orig 2024-02-11 21:40:14.792287908 +0000
+++ makefile
@@ -17,6 +17,14 @@ WORDS = words-eng_wiki.txt words-female.
all: test-file test-inline test-c++inline test-c++file test-shlib test-statlib test-internals
+install: ${TARGET_LIB}
+ mkdir ${DESTDIR}${PREFIX}/lib
+ mkdir ${DESTDIR}${PREFIX}/include
+ install ${TARGET_LIB} ${DESTDIR}${PREFIX}/lib
+ cd $${DESTDIR}${PREFIX}/lib && ln -sf ${TARGET_LIB} ${SONAME}
+ cd $${DESTDIR}${PREFIX}/lib && ln -sf ${TARGET_LIB} libzxcvbn.so
+ install zxcvbn.h ${DESTDIR}${PREFIX}/include
+
test-shlib: test.c $(TARGET_LIB)
if [ ! -e libzxcvbn.so ]; then ln -s $(TARGET_LIB) libzxcvbn.so; fi
$(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $< -L. $(LDFLAGS) -lzxcvbn -lm