libabw: Update to 0.1.3

libabw 0.1.3

- Fix a memory access error found by oss-fuzz.
- Configure with --disable-werror by default.
- Disable expanding entities by XML parser as a vulnerability
  prevention measure. Abiword-saved documents do not contain entities,
  so there is no difference in behavior.

libabw 0.1.2

- Fix several issues identified by Coverity.
- Parse paragraph and cell borders.
- Improve parsing of lists.
- Fix build with boost >= 1.59.
- Make the output of abw2* --help more compatible with help2man.
- Fix various problems when parsing broken files found by oss-fuzz.
- Require C++11 for build.
- Parse fields. (tdf#74466)
- Parse floating (not inline) images. (tdf#74463)
- Parse text boxes.
- Drop outdated MSVC project files.
- Set minimal width/height of inline images (which usually do not have
  dimensions set in the file) to 1 inch. (tdf#74462)
This commit is contained in:
nia 2020-03-25 10:56:09 +00:00
parent 92bb3551c8
commit fb1ed6dd76
3 changed files with 11 additions and 27 deletions

View file

@ -1,10 +1,9 @@
# $NetBSD: Makefile,v 1.29 2020/01/26 17:30:51 rillig Exp $
# $NetBSD: Makefile,v 1.30 2020/03/25 10:56:09 nia Exp $
DISTNAME= libabw-0.1.1
PKGREVISION= 17
DISTNAME= libabw-0.1.3
CATEGORIES= converters
MASTER_SITES= http://dev-www.libreoffice.org/src/
EXTRACT_SUFX= .tar.bz2
EXTRACT_SUFX= .tar.xz
MAINTAINER= ryoon@NetBSD.org
HOMEPAGE= https://dev-www.libreoffice.org/src/
@ -18,12 +17,13 @@ USE_LIBTOOL= yes
USE_TOOLS+= perl:build pkg-config
USE_LANGUAGES= c c++
# C++11
GCC_REQD+= 4.7
CONFIGURE_ARGS+= --without-docs
PKGCONFIG_OVERRIDE+= libabw.pc.in
BUILDLINK_TRANSFORM+= rm:-Werror
.include "../../converters/libwpd/buildlink3.mk"
.include "../../converters/librevenge/buildlink3.mk"
.include "../../devel/boost-libs/buildlink3.mk"

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.5 2015/11/03 01:43:49 agc Exp $
$NetBSD: distinfo,v 1.6 2020/03/25 10:56:09 nia Exp $
SHA1 (libabw-0.1.1.tar.bz2) = d4bc4d7d67ccc815a4f9c6fa54077f5fdb82a57f
RMD160 (libabw-0.1.1.tar.bz2) = 05cd7138c9af02a35ab1185f6beda3e6797ed6f2
SHA512 (libabw-0.1.1.tar.bz2) = 0635be4da789107b3359c5f704870f2c42ff74e9b6030a89800083b444190558da475c8e544de93edbe903f0e89b93dfab91064dcc4e3ff482efb476ed46560e
Size (libabw-0.1.1.tar.bz2) = 369311 bytes
SHA1 (patch-configure) = 02896a3366f5fc13b4267fdbc92950a190b146d0
SHA1 (libabw-0.1.3.tar.xz) = d90dceea7c1a04ad4324f5ee286f3eaa9129bdbd
RMD160 (libabw-0.1.3.tar.xz) = 3dc267391c6253496767177f8a54d45aa079cf77
SHA512 (libabw-0.1.3.tar.xz) = 0d2646e1bad1e11b3da43714ac5931fc67ffdbc4e7a25a44ef5b6e6a41de1e0ae14596b4a87cceb07bf56dbbe9344622b3d60afcb054ee0ab8577ca8e9b5c289
Size (libabw-0.1.3.tar.xz) = 318808 bytes

View file

@ -1,15 +0,0 @@
$NetBSD: patch-configure,v 1.1 2014/12/30 14:35:46 wiz Exp $
Fix unportable test(1) comparison operator.
--- configure.orig 2014-12-20 13:23:18.000000000 +0000
+++ configure
@@ -16628,7 +16628,7 @@ else
fi
-if test $platform_win32 == yes; then :
+if test $platform_win32 = yes; then :
else