NetBSD extended attribute support, from upstream

This commit is contained in:
manu 2015-09-14 14:00:01 +00:00
parent 453a8e08a9
commit fb4c9a3498
5 changed files with 73 additions and 3 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.99 2015/06/12 10:50:52 wiz Exp $
# $NetBSD: Makefile,v 1.100 2015/09/14 14:00:01 manu Exp $
DISTNAME= rsync-3.1.1
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= net
MASTER_SITES= http://rsync.samba.org/ftp/rsync/ \
http://rsync.samba.org/ftp/rsync/old-versions/ \

View file

@ -1,6 +1,9 @@
$NetBSD: distinfo,v 1.40 2014/07/22 09:47:57 wiz Exp $
$NetBSD: distinfo,v 1.41 2015/09/14 14:00:01 manu Exp $
SHA1 (rsync-3.1.1.tar.gz) = c84faba04f721d393feccfa0476bfeed9b5b5250
RMD160 (rsync-3.1.1.tar.gz) = de7ad955cb05d481a963aa30423790f3d82efe7b
Size (rsync-3.1.1.tar.gz) = 890124 bytes
SHA1 (patch-ab) = 98aa07a50314e3309b48f803d6febb1138eae1f2
SHA1 (patch-config.h.in) = 81c927bc687a0194e1a227e6ff02181d638498bd
SHA1 (patch-configure.ac) = 1df4fd9a67d08790eb7d433eadbc9b5590ba1257
SHA1 (patch-configure.sh) = 49d8ddea4669d14ba77625d33255df0072f5c3e4

View file

@ -0,0 +1,17 @@
$NetBSD: patch-config.h.in,v 1.1 2015/09/14 14:00:01 manu Exp $
NetBSD extended attribute support, from upstream
--- config.h.in.orig 2015-09-03 03:45:23.000000000 +0200
+++ config.h.in 2015-09-03 03:45:36.000000000 +0200
@@ -236,9 +236,9 @@
/* Define to 1 if you have the <linux/falloc.h> header file. */
#undef HAVE_LINUX_FALLOC_H
-/* True if you have Linux xattrs */
+/* True if you have Linux xattrs (or equivalent) */
#undef HAVE_LINUX_XATTRS
/* Define to 1 if you have the `locale_charset' function. */
#undef HAVE_LOCALE_CHARSET

View file

@ -0,0 +1,33 @@
$NetBSD: patch-configure.ac,v 1.1 2015/09/14 14:00:01 manu Exp $
NetBSD extended attribute support, from upstream
From 1983198097f57cb9c2eb44ae51cbf8c2cabccbe4 Mon Sep 17 00:00:00 2001
From: Wayne Davison <wayned@samba.org>
Date: Wed, 2 Sep 2015 12:20:50 -0700
Subject: [PATCH] Add support for netbsd in xattrs case. Closes bug-suggestion
11484.
---
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git configure.ac configure.ac
index 3aca2a1..0478ba8 100644
--- configure.ac
+++ configure.ac
@@ -1022,9 +1022,9 @@ if test x"$enable_xattr_support" = x"no"; then
AC_MSG_RESULT(no)
else
case "$host_os" in
- *linux*)
+ *linux*|*netbsd*)
AC_MSG_RESULT(Using Linux xattrs)
- AC_DEFINE(HAVE_LINUX_XATTRS, 1, [True if you have Linux xattrs])
+ AC_DEFINE(HAVE_LINUX_XATTRS, 1, [True if you have Linux xattrs (or equivalent)])
AC_DEFINE(SUPPORT_XATTRS, 1)
AC_DEFINE(NO_SYMLINK_USER_XATTRS, 1, [True if symlinks do not support user xattrs])
AC_CHECK_LIB(attr,getxattr)
--
2.3.2

View file

@ -0,0 +1,17 @@
$NetBSD: patch-configure.sh,v 1.1 2015/09/14 14:00:01 manu Exp $
NetBSD extended attribute support, from upstream
--- configure.sh.orig 2015-09-03 03:42:33.000000000 +0200
+++ configure.sh 2015-09-03 03:44:27.000000000 +0200
@@ -8867,9 +8867,9 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
$as_echo "no" >&6; }
else
case "$host_os" in
- *linux*)
+ *linux*|*netbsd*)
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: Using Linux xattrs" >&5
$as_echo "Using Linux xattrs" >&6; }
$as_echo "#define HAVE_LINUX_XATTRS 1" >>confdefs.h