Update to 0.07

Upstream changes:
0.07   2022-12-14 19:00:00
     - Fix compilation issues with fmul name clash
This commit is contained in:
wen 2023-10-09 11:19:10 +00:00
parent e0a03e4977
commit fb6249e904
4 changed files with 6 additions and 37 deletions

View File

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.8 2023/07/06 09:41:21 wiz Exp $
# $NetBSD: Makefile,v 1.9 2023/10/09 11:19:10 wen Exp $
DISTNAME= Crypt-Curve25519-0.06
DISTNAME= Crypt-Curve25519-0.07
PKGNAME= p5-${DISTNAME}
PKGREVISION= 6
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Crypt/}

View File

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.4 2021/10/26 11:17:25 nia Exp $
$NetBSD: distinfo,v 1.5 2023/10/09 11:19:10 wen Exp $
BLAKE2s (Crypt-Curve25519-0.06.tar.gz) = 72d76f21f8d9638976018d1cccc8cca72dff516d5309a7db903bae85cca0fbad
SHA512 (Crypt-Curve25519-0.06.tar.gz) = e5d351c36c9f60e1b55f45bf9fa871fddf949bd5c0a20b4d065e1eb2d4e24ba43807289591eda854fca28b5909fd6af1b0fc9ede63efbeeaf6e011e7382a4e1d
Size (Crypt-Curve25519-0.06.tar.gz) = 27835 bytes
BLAKE2s (Crypt-Curve25519-0.07.tar.gz) = ca2563d2fa3290b5e1377443b998155c02a82fc75f5f97bfd223e1d91cf0b4b0
SHA512 (Crypt-Curve25519-0.07.tar.gz) = 8b7107c3d96239974836f99d8e6d0603b8006ec1b3c80a8364b82259d9f79938d77b0b5bac8c1e2b14147bc2c86e39e27b79cfe0f316dfd4e9518aab313e5103
Size (Crypt-Curve25519-0.07.tar.gz) = 16216 bytes
SHA1 (patch-curve25519-donna-c64.c) = bc15215560043b3f88016677c8f5d85b483a0b64
SHA1 (patch-curve25519-donna.c) = d6a7a9f03ff64f0f9fe0e0d5ee36d4974b1c021c

View File

@ -1,15 +0,0 @@
$NetBSD: patch-curve25519-donna-c64.c,v 1.1 2020/03/22 13:15:14 tnn Exp $
/usr/include/x86_64-linux-gnu/bits/mathcalls-narrow.h:30:20: note: previous declaration of 'fmul' was here
30 | __MATHCALL_NARROW (__MATHCALL_NAME (mul), __MATHCALL_REDIR_NAME (mul), 2);
--- curve25519-donna-c64.c.orig 2017-04-05 23:25:50.000000000 +0000
+++ curve25519-donna-c64.c
@@ -95,6 +95,7 @@ fscalar_product(felem output, const fele
* Assumes that in[i] < 2**55 and likewise for in2.
* On return, output[i] < 2**52
*/
+#define fmul my_fmul
static inline void force_inline
fmul(felem output, const felem in2, const felem in) {
uint128_t t[5];

View File

@ -1,15 +0,0 @@
$NetBSD: patch-curve25519-donna.c,v 1.1 2020/03/22 13:15:14 tnn Exp $
/usr/include/x86_64-linux-gnu/bits/mathcalls-narrow.h:30:20: note: previous declaration of 'fmul' was here
30 | __MATHCALL_NARROW (__MATHCALL_NAME (mul), __MATHCALL_REDIR_NAME (mul), 2);
--- curve25519-donna.c.orig 2017-04-05 23:25:50.000000000 +0000
+++ curve25519-donna.c
@@ -324,6 +324,7 @@ static void freduce_coefficients(limb *o
* output must be distinct to both inputs. The output is reduced degree and
* reduced coefficient.
*/
+#define fmul my_fmul
static void
fmul(limb *output, const limb *in, const limb *in2) {
limb t[19];