Package DeforaOS libSystem 0.2.1

It is essentially a bugfix and maintenance release, with:
- portability fix (SunOS)
- additional tests (Config)
- API addition (String)
- quiet mode for configctl(1)
- support for compiling in a separate directory (OBJDIR)
This commit is contained in:
khorben 2015-05-20 23:08:37 +00:00
parent af0fee4c1c
commit fb8d57fb62
5 changed files with 23 additions and 45 deletions

View file

@ -1,11 +1,10 @@
# $NetBSD: Makefile,v 1.9 2014/10/03 16:51:00 khorben Exp $ # $NetBSD: Makefile,v 1.10 2015/05/20 23:08:37 khorben Exp $
# #
DISTNAME= libSystem-0.2.0 DISTNAME= libSystem-0.2.1
PKGNAME= deforaos-libsystem-0.2.0 PKGNAME= deforaos-libsystem-0.2.1
PKGREVISION= 1
CATEGORIES= devel CATEGORIES= devel
MASTER_SITES= http://www.defora.org/os/download/download/4330/ MASTER_SITES= http://www.defora.org/os/download/download/4351/
MAINTAINER= khorben@defora.org MAINTAINER= khorben@defora.org
HOMEPAGE= http://www.defora.org/ HOMEPAGE= http://www.defora.org/

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.5 2014/09/23 12:06:49 jperkin Exp $ $NetBSD: distinfo,v 1.6 2015/05/20 23:08:37 khorben Exp $
SHA1 (libSystem-0.2.0.tar.gz) = c264070ff4034fbdc97aae3f7e694f84e7898365 SHA1 (libSystem-0.2.1.tar.gz) = a99a1a5aa5aa0c5516725263cb937a30186ee5db
RMD160 (libSystem-0.2.0.tar.gz) = 8159d1baee58cff3a4adf5f514a1d5c2f45aedbe RMD160 (libSystem-0.2.1.tar.gz) = 635dfe01c777238dd60aa771bab75ef05f4d6795
Size (libSystem-0.2.0.tar.gz) = 60538 bytes Size (libSystem-0.2.1.tar.gz) = 63274 bytes
SHA1 (patch-data_pkgconfig.sh) = 7c40652087c604cff593a320e97259c453633c74 SHA1 (patch-src_Makefile) = 98c22cc28de9bff4517c4880711a70741f5b18f2
SHA1 (patch-src_Makefile) = 564623fdf246a4dc3a33bb265b6d6069bca58e29 SHA1 (patch-tests_tests.sh) = b28b5557303cec42c1b24a6c5328fbca9b763366
SHA1 (patch-tests_tests.sh) = 189b91d02ae0a83ff8e881a93b70984045456948

View file

@ -1,20 +0,0 @@
$NetBSD: patch-data_pkgconfig.sh,v 1.2 2014/09/16 19:25:51 khorben Exp $
Use correct rpath flag on SunOS.
--- data/pkgconfig.sh.orig 2014-04-23 15:37:45.000000000 +0000
+++ data/pkgconfig.sh
@@ -129,9 +129,12 @@ while [ $# -gt 0 ]; do
if [ "$PREFIX" != "/usr" ]; then
RPATH="-Wl,-rpath-link,\${libdir} -Wl,-rpath,\${libdir}"
case $(uname -s) in
- Darwin|SunOS)
+ Darwin)
RPATH="-Wl,-rpath,\${libdir}"
;;
+ SunOS)
+ RPATH="-Wl,-R\${libdir}"
+ ;;
esac
fi

View file

@ -1,13 +1,13 @@
$NetBSD: patch-src_Makefile,v 1.1 2014/09/23 12:06:49 jperkin Exp $ $NetBSD: patch-src_Makefile,v 1.2 2015/05/20 23:08:37 khorben Exp $
Do not try to build targets that are created by existing targets, causes Do not try to build targets that are created by existing targets, causes
problems with parallel builds and is unnecessary. problems with parallel builds and is unnecessary.
--- src/Makefile.orig 2014-09-14 17:53:40.000000000 +0000 --- src/Makefile.orig 2015-05-10 22:19:30.000000000 +0000
+++ src/Makefile +++ src/Makefile
@@ -1,4 +1,4 @@ @@ -1,4 +1,4 @@
-TARGETS = libSystem.a libSystem.so.0.0 libSystem.so.0 libSystem.so -TARGETS = $(OBJDIR)libSystem.a $(OBJDIR)libSystem.so.0.0 $(OBJDIR)libSystem.so.0 $(OBJDIR)libSystem.so
+TARGETS = libSystem.a libSystem.so.0.0 +TARGETS = $(OBJDIR)libSystem.a $(OBJDIR)libSystem.so.0.0
OBJDIR =
PREFIX = /usr/local PREFIX = /usr/local
DESTDIR = DESTDIR =
LIBDIR = $(PREFIX)/lib

View file

@ -1,20 +1,20 @@
$NetBSD: patch-tests_tests.sh,v 1.2 2014/09/23 12:06:49 jperkin Exp $ $NetBSD: patch-tests_tests.sh,v 1.3 2015/05/20 23:08:37 khorben Exp $
Avoid building the (experimental) Python binding. Avoid building the (experimental) Python binding.
Use LD_LIBRARY_PATH to find pre-installed libraries. Use LD_LIBRARY_PATH to find pre-installed libraries.
--- tests/tests.sh.orig 2014-08-29 19:23:48.000000000 +0000 --- tests/tests.sh.orig 2015-05-10 22:00:47.000000000 +0000
+++ tests/tests.sh +++ tests/tests.sh
@@ -50,7 +50,7 @@ @@ -42,7 +42,7 @@ _run()
echo -n "$test:" 1>&2 echo -n "$test:" 1>&2
(echo (echo
echo "Testing: ./$test" "$@" echo "Testing: $test" "$@"
- "./$test" "$@") >> "$target" 2>&1 - "$OBJDIR$test" "$@") 2>&1
+ env LD_LIBRARY_PATH=../src "./$test" "$@") >> "$target" 2>&1 + env LD_LIBRARY_PATH="../src" "$OBJDIR$test" "$@") 2>&1
res=$? res=$?
if [ $res -ne 0 ]; then if [ $res -ne 0 ]; then
echo " FAIL" 1>&2 echo "Test: $test$sep$@: FAIL (error $res)"
@@ -103,7 +103,7 @@ _test "includes" @@ -105,7 +105,7 @@ _test "includes"
_test "string" _test "string"
_test "variable" _test "variable"
echo "Expected failures:" 1>&2 echo "Expected failures:" 1>&2