Makefile patches to fix dud permissions/interpreters. From Klaus Heinz

in discussion of PR 29425. While here, add a one-line patch to fix an
obvious bug detected by gcc while I was test-building.
PKGREVISION++.
This commit is contained in:
dholland 2008-10-26 22:48:43 +00:00
parent b7b2ed0b9e
commit fbc89a50cf
3 changed files with 21 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.14 2008/02/29 20:53:02 jlam Exp $
# $NetBSD: Makefile,v 1.15 2008/10/26 22:48:43 dholland Exp $
#
DISTNAME= netmaj-2.0.7
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= games
MASTER_SITES= http://www.sfc.wide.ad.jp/~kusune/netmaj/files/
@ -18,12 +18,14 @@ HAS_CONFIGURE= yes
CONFIGURE_ENV+= OPSYS=${OPSYS:Q}
CONFIGURE_ENV+= CURSES_LIBS=${BUILDLINK_LDADD.ncursesw:Q}
INSTALL_MAKE_FLAGS+= PERL=${PERL5:Q}
INSTALL_TARGET= install install-pf
DOCDIR= ${PREFIX}/share/doc/netmaj
pre-configure:
cp ${FILESDIR}/configure.sh ${WRKSRC}/configure
chmod +x ${WRKSRC}/configure
chmod -x ${WRKSRC}/auto.pf
post-install:
${INSTALL_DATA_DIR} ${DESTDIR}${DOCDIR}

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.8 2008/03/03 05:06:40 jlam Exp $
$NetBSD: distinfo,v 1.9 2008/10/26 22:48:43 dholland Exp $
SHA1 (netmaj-2.0.7.tar.gz) = 1363ea8ca42079fb444b25c605d264b5f083e260
RMD160 (netmaj-2.0.7.tar.gz) = 9d3fd68b7607b2c3064e9dd8310085818f32f93e
@ -10,3 +10,4 @@ SHA1 (patch-ai) = cd63f77bc8af0b6d2e3dc51ce260fc639bf48bb9
SHA1 (patch-aj) = a25f2e0f81c10121767dae99bd6c09be69467a13
SHA1 (patch-al) = 881d23913beedf4b3167b1fafd08210555cccd55
SHA1 (patch-am) = 61da0c1ac3e73553aba80638a45df9bbda61ffb7
SHA1 (patch-an) = 6f1ddbdbe0065518e166af9c23565579d19965e8

View file

@ -0,0 +1,15 @@
$NetBSD: patch-an,v 1.1 2008/10/26 22:48:43 dholland Exp $
Fix obvious bug detected by gcc.
--- pf.c~ 1996-07-31 04:06:10.000000000 -0400
+++ pf.c 2008-10-26 18:40:32.000000000 -0400
@@ -94,7 +94,7 @@ pf_init(gp,file,prog) global_t *gp; char
}
if (!pf) {
strcpy(personal_file,prog);
- if (p=rindex(personal_file,"/")) {
+ if (p=rindex(personal_file,'/')) {
p[1] = 0;
} else {
personal_file[0] = 0;