Add patch from upstream via debian that avoids using the
withdrawn-in-2.90 gpsd interface. Restore dependency on gpsd.
This commit is contained in:
parent
5f39df292a
commit
fc270fd2e3
3 changed files with 23 additions and 9 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.7 2009/12/27 16:43:56 gdt Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2009/12/28 19:36:15 gdt Exp $
|
||||
#
|
||||
|
||||
DISTNAME= viking-0.9.9
|
||||
PKGREVISION= 2
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= geography
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=viking/}
|
||||
|
||||
|
@ -14,8 +14,8 @@ PKG_DESTDIR_SUPPORT= user-destdir
|
|||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
# gpsd withdrew an interface viking still uses
|
||||
CONFIGURE_ARGS+= --disable-realtime-gps-tracking
|
||||
# Perhaps optionize use of gpsd (remove bl3, add this).
|
||||
# CONFIGURE_ARGS+= --disable-realtime-gps-tracking
|
||||
|
||||
DEPENDS+= gpsbabel-[0-9]*:../../geography/gpsbabel
|
||||
REPLACE_PERL= viking-remote
|
||||
|
@ -24,10 +24,7 @@ USE_TOOLS+= gmake intltool msgfmt pkg-config
|
|||
|
||||
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
# viking uses an interface withdrawn in gpsd 2.90. Locally revert
|
||||
# gpsd or fix viking upstream. gdt, 20091227
|
||||
# https://sourceforge.net/tracker/?func=detail&aid=2921899&group_id=83870&atid=570954
|
||||
#.include "../../geography/gpsd/buildlink3.mk"
|
||||
.include "../../geography/gpsd/buildlink3.mk"
|
||||
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
||||
.include "../../lang/perl5/buildlink3.mk"
|
||||
.include "../../www/curl/buildlink3.mk"
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2009/10/16 16:02:01 jkunz Exp $
|
||||
$NetBSD: distinfo,v 1.3 2009/12/28 19:36:15 gdt Exp $
|
||||
|
||||
SHA1 (viking-0.9.9.tar.gz) = ce3d66ea117e3e179c98477f4fd5c9cf2828c73e
|
||||
RMD160 (viking-0.9.9.tar.gz) = 5829b909f74c78b5483ae787e6d420909ce4dba2
|
||||
Size (viking-0.9.9.tar.gz) = 774111 bytes
|
||||
SHA1 (patch-aa) = 24dba675c4aeacef6541f474edd90b7457d98d02
|
||||
SHA1 (patch-ab) = e48a04ef8d9218b54ff467292d244a0602aeb74e
|
||||
|
|
16
geography/viking/patches/patch-ab
Normal file
16
geography/viking/patches/patch-ab
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ab,v 1.1 2009/12/28 19:36:15 gdt Exp $
|
||||
|
||||
# https://sourceforge.net/tracker/?func=detail&aid=2921899&group_id=83870&atid=570954
|
||||
# patch taken from debian at http://git.debian.org/?p=collab-maint/viking.git;a=blob;f=debian/patches/libgps-2.90-fix;h=e23540bf533043ff26c7e0efeea0ea0f1807166f;hb=5af131f5622da98d640ed9b9f699b0b7fa6b3b83
|
||||
|
||||
--- src/vikgpslayer.c.orig 2009-09-09 20:16:18.000000000 +0000
|
||||
+++ src/vikgpslayer.c
|
||||
@@ -1317,7 +1317,7 @@ static gboolean rt_gpsd_try_connect(gpoi
|
||||
vgl->realtime_io_channel = g_io_channel_unix_new(vgl->vgpsd->gpsd.gps_fd);
|
||||
vgl->realtime_io_watch_id = g_io_add_watch( vgl->realtime_io_channel,
|
||||
G_IO_IN | G_IO_ERR | G_IO_HUP, gpsd_data_available, vgl);
|
||||
- gps_query(&vgl->vgpsd->gpsd, "w+x");
|
||||
+ gps_stream(&vgl->vgpsd->gpsd, WATCH_ENABLE, NULL);
|
||||
return FALSE; /* no longer called by timeout */
|
||||
}
|
||||
|
Loading…
Reference in a new issue