Update ipv6calc to 0.61.0. Changes:
- add support for Teredo addresses - add new shortcut options: --in|-I --out|-O --action|-A --printcompressed|-C --printuncompressed|-U --printfulluncompressed|-F - update copyright range - add new option: -p <path to IP2Location database> - add support for IP2Location - add support for GeoIP (GeoIP-1.3.17)
This commit is contained in:
parent
1824b4604d
commit
fc3ef68c58
7 changed files with 8 additions and 191 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: CHANGES-2006,v 1.1145 2006/08/28 21:58:18 jmmv Exp $
|
||||
$NetBSD: CHANGES-2006,v 1.1146 2006/08/28 22:03:32 hubertf Exp $
|
||||
|
||||
Changes to the packages collection and infrastructure in 2006:
|
||||
|
||||
|
@ -4112,3 +4112,4 @@ Changes to the packages collection and infrastructure in 2006:
|
|||
Updated sysutils/cdrtools to 2.01nb4 [dsainty 2006-08-28]
|
||||
Updated net/bind9 to 9.3.2nb1 [seb 2006-08-28]
|
||||
Added multimedia/gst-plugins0.10-xvid version 0.10.3 [jmmv 2006-08-28]
|
||||
Updated ipv6calc to 0.61.0 [hubertf 2006-08-29]
|
||||
|
|
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.31 2006/07/27 00:09:06 hubertf Exp $
|
||||
# $NetBSD: Makefile,v 1.32 2006/08/28 22:02:51 hubertf Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ipv6calc-0.50
|
||||
PKGREVISION= 1
|
||||
DISTNAME= ipv6calc-0.61.0
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/
|
||||
|
||||
|
|
|
@ -1,9 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.13 2005/11/08 21:50:15 hubertf Exp $
|
||||
$NetBSD: distinfo,v 1.14 2006/08/28 22:02:51 hubertf Exp $
|
||||
|
||||
SHA1 (ipv6calc-0.50.tar.gz) = 06610ce8d02ae82388ead4af644d1be85d4aa689
|
||||
RMD160 (ipv6calc-0.50.tar.gz) = 9e62afae35d26ae2ed6f398623cd3bf7e62479ed
|
||||
Size (ipv6calc-0.50.tar.gz) = 503695 bytes
|
||||
SHA1 (patch-aa) = 8709f2dc352e490980174e4c51c2d1238300437b
|
||||
SHA1 (patch-ab) = 89faf0a4c36436d3cafca49c7ffbdce0d090daab
|
||||
SHA1 (patch-ac) = 2ee60ab9d96346b413b2903d1e93df759a8a3cc1
|
||||
SHA1 (patch-ad) = 743ee3db6ca7159f8f2db9c1b9032e3771a311f2
|
||||
SHA1 (ipv6calc-0.61.0.tar.gz) = c31b03a102ef62edccffb3eb5c042b616ef0cf2c
|
||||
RMD160 (ipv6calc-0.61.0.tar.gz) = dc5a8e76cd49a813e5205430f11b41f60591cd30
|
||||
Size (ipv6calc-0.61.0.tar.gz) = 545036 bytes
|
||||
|
|
|
@ -1,128 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.9 2005/11/08 21:50:15 hubertf Exp $
|
||||
|
||||
--- Makefile.in.orig 2005-09-15 19:29:19.000000000 +0200
|
||||
+++ Makefile.in
|
||||
@@ -29,17 +29,17 @@ ipv6logstats: getopt-make lib-make ipv6l
|
||||
ipv6calc: getopt-make lib-make ipv6calc-make ipv6calcweb-make
|
||||
|
||||
distclean:
|
||||
- make clean
|
||||
+ ${MAKE} clean
|
||||
rm -f config.cache config.status config.log
|
||||
for dir in ipv6logconv ipv6logstats ipv6calcweb ipv6calc man lib md5 getopt databases/ieee-oui databases/ipv4-assignment databases/ipv6-assignment; do \
|
||||
ocwd=`pwd`; \
|
||||
cd $$dir; \
|
||||
- make $@ ; \
|
||||
+ ${MAKE} $@ ; \
|
||||
cd $$ocwd ; \
|
||||
done
|
||||
|
||||
autoclean:
|
||||
- make distclean
|
||||
+ ${MAKE} distclean
|
||||
rm -f Makefile
|
||||
rm -f version.h
|
||||
rm -f contrib/ipv6calc.spec
|
||||
@@ -47,7 +47,7 @@ autoclean:
|
||||
for dir in ipv6logconv ipv6logstats ipv6calcweb ipv6calc man lib md5 getopt; do \
|
||||
ocwd=`pwd`; \
|
||||
cd $$dir; \
|
||||
- make $@ ; \
|
||||
+ ${MAKE} $@ ; \
|
||||
cd $$ocwd ; \
|
||||
done
|
||||
|
||||
@@ -55,60 +55,60 @@ clean:
|
||||
for dir in ipv6logconv ipv6logstats ipv6calcweb ipv6calc man lib md5 getopt; do \
|
||||
ocwd=`pwd`; \
|
||||
cd $$dir; \
|
||||
- make $@ ; \
|
||||
+ ${MAKE} $@ ; \
|
||||
cd $$ocwd ; \
|
||||
done
|
||||
|
||||
install:
|
||||
- make test
|
||||
- make installonly
|
||||
+ ${MAKE} test
|
||||
+ ${MAKE} installonly
|
||||
|
||||
installonly:
|
||||
for dir in ipv6logconv ipv6logstats ipv6calcweb ipv6calc man lib md5 getopt; do \
|
||||
ocwd=`pwd`; \
|
||||
cd $$dir; \
|
||||
- make install; \
|
||||
+ ${MAKE} install; \
|
||||
cd $$ocwd ; \
|
||||
done
|
||||
|
||||
getopt-make:
|
||||
- cd getopt && make
|
||||
+ cd getopt && ${MAKE}
|
||||
|
||||
md5-make:
|
||||
- cd md5 && make
|
||||
+ cd md5 && ${MAKE}
|
||||
|
||||
lib-make: md5-make db-ieee-oui-make db-ieee-iab-make db-ipv4-assignment-make db-ipv6-assignment-make
|
||||
- cd lib && make
|
||||
+ cd lib && ${MAKE}
|
||||
|
||||
ipv6logconv-make: lib-make
|
||||
- cd ipv6logconv && make
|
||||
+ cd ipv6logconv && ${MAKE}
|
||||
|
||||
ipv6logstats-make: lib-make
|
||||
- cd ipv6logstats && make
|
||||
+ cd ipv6logstats && ${MAKE}
|
||||
|
||||
ipv6calc-make: lib-make
|
||||
- cd ipv6calc && make
|
||||
+ cd ipv6calc && ${MAKE}
|
||||
|
||||
ipv6calcweb-make:
|
||||
- cd ipv6calcweb && make
|
||||
+ cd ipv6calcweb && ${MAKE}
|
||||
|
||||
db-ieee-oui-make:
|
||||
- cd databases/ieee-oui && make
|
||||
+ cd databases/ieee-oui && ${MAKE}
|
||||
|
||||
db-ieee-iab-make:
|
||||
- cd databases/ieee-iab && make
|
||||
+ cd databases/ieee-iab && ${MAKE}
|
||||
|
||||
db-ipv4-assignment-make:
|
||||
- cd databases/ipv4-assignment && make
|
||||
+ cd databases/ipv4-assignment && ${MAKE}
|
||||
|
||||
db-ipv6-assignment-make:
|
||||
- cd databases/ipv6-assignment && make
|
||||
+ cd databases/ipv6-assignment && ${MAKE}
|
||||
|
||||
update:
|
||||
for dir in databases/ieee-oui databases/ieee-iab databases/ipv4-assignment databases/ipv6-assignment; do \
|
||||
ocwd=`pwd`; \
|
||||
cd $$dir; \
|
||||
- make $@ ; \
|
||||
+ ${MAKE} $@ ; \
|
||||
cd $$ocwd ; \
|
||||
done
|
||||
|
||||
@@ -116,7 +116,7 @@ static: ipv6logconv-make ipv6logstats-m
|
||||
for dir in ipv6logconv ipv6logstats ipv6calc; do \
|
||||
ocwd=`pwd`; \
|
||||
cd $$dir; \
|
||||
- make $@ ; \
|
||||
+ ${MAKE} $@ ; \
|
||||
cd $$ocwd ; \
|
||||
done
|
||||
|
||||
@@ -124,6 +124,6 @@ test:
|
||||
for dir in ipv6logconv ipv6logstats ipv6calcweb ipv6calc man lib; do \
|
||||
ocwd=`pwd`; \
|
||||
cd $$dir; \
|
||||
- make $@ ; \
|
||||
+ ${MAKE} $@ ; \
|
||||
cd $$ocwd ; \
|
||||
done
|
|
@ -1,21 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.3 2005/11/08 21:50:15 hubertf Exp $
|
||||
|
||||
--- ipv6calc/Makefile.in.orig 2005-09-15 19:29:19.000000000 +0200
|
||||
+++ ipv6calc/Makefile.in
|
||||
@@ -1,2 +1,9 @@
|
||||
+### HACK ATTACK --- FIXME, PETER!!! - HF ###
|
||||
+prefix= @prefix@
|
||||
+exec_prefix = @exec_prefix@
|
||||
+### HACK ATTACK --- FIXME, PETER!!! - HF ###
|
||||
+
|
||||
+
|
||||
+
|
||||
# Project : ipv6calc/ipv6calc
|
||||
# File : Makefile[.in]
|
||||
@@ -36,5 +43,5 @@ libipv6calc.a:
|
||||
|
||||
ipv6calc: $(OBJS) libipv6calc.a ../lib/ipv6calcoptions.h
|
||||
- $(CC) -o ipv6calc $(OBJS) $(GETOBJS) -lipv6calc -L../lib/
|
||||
+ $(CC) -o ipv6calc $(OBJS) $(GETOBJS) -lipv6calc -L../lib/ $(LDFLAGS)
|
||||
|
||||
static: ipv6calc
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1 2005/11/08 21:50:15 hubertf Exp $
|
||||
|
||||
--- ipv6logstats/Makefile.in.orig 2005-09-15 19:35:02.000000000 +0200
|
||||
+++ ipv6logstats/Makefile.in
|
||||
@@ -1,2 +1,10 @@
|
||||
+### HACK ATTACK --- FIXME, PETER!!! - HF ###
|
||||
+prefix= @prefix@
|
||||
+exec_prefix = @exec_prefix@
|
||||
+### HACK ATTACK --- FIXME, PETER!!! - HF ###
|
||||
+
|
||||
+
|
||||
+
|
||||
+
|
||||
# Project : ipv6calc/ipv6logstats
|
||||
# File : Makefile
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1 2005/11/08 21:50:15 hubertf Exp $
|
||||
|
||||
--- ipv6logconv/Makefile.in.orig 2005-09-15 19:35:02.000000000 +0200
|
||||
+++ ipv6logconv/Makefile.in
|
||||
@@ -1,2 +1,10 @@
|
||||
+### HACK ATTACK --- FIXME, PETER!!! - HF ###
|
||||
+prefix= @prefix@
|
||||
+exec_prefix = @exec_prefix@
|
||||
+### HACK ATTACK --- FIXME, PETER!!! - HF ###
|
||||
+
|
||||
+
|
||||
+
|
||||
+
|
||||
# Project : ipv6calc/ipv6logconv
|
||||
# File : Makefile
|
Loading…
Reference in a new issue