fix errno usage.
This commit is contained in:
parent
6a6a3411e1
commit
fc4bea1942
2 changed files with 30 additions and 1 deletions
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.9 2005/07/28 10:25:14 adam Exp $
|
||||
$NetBSD: distinfo,v 1.10 2005/12/06 13:14:06 joerg Exp $
|
||||
|
||||
SHA1 (AfterStep-2.1.2.tar.bz2) = c367e7c73561ddf03b3725f80d2f39f50d2b45bd
|
||||
RMD160 (AfterStep-2.1.2.tar.bz2) = f891ded642b9190bd261f3e3f92cb595da2d785b
|
||||
Size (AfterStep-2.1.2.tar.bz2) = 5079333 bytes
|
||||
SHA1 (patch-aa) = c903ca64b609e4270ead1f1e03cb6ea962b294f8
|
||||
|
|
28
wm/afterstep/patches/patch-aa
Normal file
28
wm/afterstep/patches/patch-aa
Normal file
|
@ -0,0 +1,28 @@
|
|||
$NetBSD: patch-aa,v 1.5 2005/12/06 13:14:06 joerg Exp $
|
||||
|
||||
--- src/afterstep/module.c.orig 2005-12-06 12:58:56.000000000 +0000
|
||||
+++ src/afterstep/module.c
|
||||
@@ -33,6 +33,7 @@
|
||||
|
||||
#include <signal.h>
|
||||
#include <stdarg.h>
|
||||
+#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
#include <unistd.h>
|
||||
#include <sys/file.h>
|
||||
@@ -380,7 +381,6 @@ LOCAL_DEBUG_OUT( "deleting buffer %p sen
|
||||
int
|
||||
FlushQueue (module_t *module)
|
||||
{
|
||||
- extern int errno;
|
||||
int fd;
|
||||
register struct queue_buff_struct *curr;
|
||||
|
||||
@@ -471,7 +471,6 @@ FlushAllQueues()
|
||||
|
||||
|
||||
|
||||
-#include <sys/errno.h>
|
||||
static inline int
|
||||
PositiveWrite (unsigned int channel, send_data_type *ptr, int size)
|
||||
{
|
Loading…
Reference in a new issue