Split out amanda-plot from amanda-server so that one doesn't need X11
just to write backups to tape.
This commit is contained in:
parent
69876b341a
commit
fc50a01d05
9 changed files with 294 additions and 0 deletions
43
sysutils/amanda-plot/Makefile
Normal file
43
sysutils/amanda-plot/Makefile
Normal file
|
@ -0,0 +1,43 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 1999/09/06 18:11:22 bad Exp $
|
||||
# FreeBSD Id: Makefile,v 1.9 1997/03/08 05:00:11 gpalmer Exp
|
||||
#
|
||||
|
||||
DISTNAME= amanda-2.4.1p1
|
||||
PKGNAME= amanda-plot-2.4.1p1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ftp://ftp.cs.umd.edu/pub/amanda/
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
HOMEPAGE= http://www.amanda.org/
|
||||
|
||||
DEPENDS+= gnuplot-3.7:../../graphics/gnuplot
|
||||
DEPENDS+= amanda-server-2.4.1p1:../../sysutils/amanda-server
|
||||
|
||||
USE_X11= yes
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${OPSYS} == "NetBSD"
|
||||
AMANDA_GROUP= operator
|
||||
.elif ${OPSYS} == "SunOS"
|
||||
AMANDA_GROUP= sysadmin
|
||||
.endif
|
||||
|
||||
AMANDA_USER?= backup
|
||||
AMANDA_VAR?= /var/amanda
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV+= GNUPLOT="${LOCALBASE}/gnuplot"
|
||||
CONFIGURE_ARGS+= --with-user=${AMANDA_USER} \
|
||||
--with-group=${AMANDA_GROUP} \
|
||||
--with-owner=root \
|
||||
--with-mmap --with-amandahosts \
|
||||
--with-includes=${PREFIX}/include \
|
||||
--with-libraries=${PREFIX}/lib \
|
||||
--localstatedir=${AMANDA_VAR} \
|
||||
--with-gnutar-listdir=${AMANDA_VAR}/gnutar-lists \
|
||||
--with-dump-honor-nodump \
|
||||
--without-client
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
sysutils/amanda-plot/files/md5
Normal file
3
sysutils/amanda-plot/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 1999/09/06 18:11:23 bad Exp $
|
||||
|
||||
MD5 (amanda-2.4.1p1.tar.gz) = 13f34dc97c35f85f88e54ca25b2009ed
|
5
sysutils/amanda-plot/files/patch-sum
Normal file
5
sysutils/amanda-plot/files/patch-sum
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 1999/09/06 18:11:22 bad Exp $
|
||||
|
||||
MD5 (patch-aa) = 2c6f6d14adffe3ad55a9cec566a91125
|
||||
MD5 (patch-ac) = d90f584f5cee04ac92976bd0ea9161ae
|
||||
MD5 (patch-ad) = 80fc25c203a46151d70d29689e33186e
|
20
sysutils/amanda-plot/patches/patch-aa
Normal file
20
sysutils/amanda-plot/patches/patch-aa
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 1999/09/06 18:11:22 bad Exp $
|
||||
|
||||
--- configure.orig Sat Nov 21 18:12:59 1998
|
||||
+++ configure Sat Sep 4 03:35:27 1999
|
||||
@@ -4457,6 +4457,7 @@
|
||||
echo "$ac_t""no" 1>&6
|
||||
fi
|
||||
|
||||
+if false; then
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||
|
||||
@@ -4502,6 +4503,7 @@
|
||||
${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
|
||||
$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $host \
|
||||
|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
|
||||
+fi
|
||||
|
||||
# Redirect the config.log output again, so that the ltconfig log is not
|
||||
# clobbered by the next message.
|
16
sysutils/amanda-plot/patches/patch-ab
Normal file
16
sysutils/amanda-plot/patches/patch-ab
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 1999/09/06 18:11:22 bad Exp $
|
||||
|
||||
--- Makefile.in.orig Sat Nov 21 18:32:54 1998
|
||||
+++ Makefile.in Sat Sep 4 02:53:32 1999
|
||||
@@ -157,10 +157,7 @@
|
||||
AUTOCONF = @AUTOCONF@ --localdir=config
|
||||
|
||||
SUBDIRS=config \
|
||||
- common-src client-src tape-src \
|
||||
- server-src restore-src recover-src \
|
||||
- changer-src amplot man \
|
||||
- example
|
||||
+ amplot man
|
||||
|
||||
EXTRA_DIST = \
|
||||
COPYRIGHT \
|
19
sysutils/amanda-plot/patches/patch-ac
Normal file
19
sysutils/amanda-plot/patches/patch-ac
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 1999/09/06 18:11:22 bad Exp $
|
||||
|
||||
--- man/Makefile.in.orig Sat Nov 21 18:34:50 1998
|
||||
+++ man/Makefile.in Sat Sep 4 02:58:45 1999
|
||||
@@ -158,12 +158,8 @@
|
||||
|
||||
transform = s,x,x,;
|
||||
|
||||
-man_MANS = amadmin.8 amanda.8 amcheck.8 \
|
||||
- amcheckdb.8 amcleanup.8 amdump.8 \
|
||||
- amflush.8 amlabel.8 amoverview.8 \
|
||||
- amplot.8 amrecover.8 amrestore.8 \
|
||||
- amrmtape.8 amtape.8 amtoc.8 \
|
||||
- amverify.8 amstatus.8 amreport.8
|
||||
+man_MANS = \
|
||||
+ amplot.8
|
||||
|
||||
EXTRA_DIST = amplot.8 amrestore.8 amtape.8
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/config/mkinstalldirs
|
1
sysutils/amanda-plot/pkg/COMMENT
Normal file
1
sysutils/amanda-plot/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
Visualizes the behavior of Amanda, a network backup system.
|
180
sysutils/amanda-plot/pkg/DESCR
Normal file
180
sysutils/amanda-plot/pkg/DESCR
Normal file
|
@ -0,0 +1,180 @@
|
|||
Amanda, The Advanced Maryland Automatic Network Disk Archiver
|
||||
Copyright (c) 1991-1998 University of Maryland at College Park
|
||||
All Rights Reserved.
|
||||
|
||||
See the files COPYRIGHT, COPYRIGHT-REGEX and COPYRIGHT-APACHE for
|
||||
distribution conditions and official warranty disclaimer.
|
||||
|
||||
PLEASE NOTE: THIS SOFTWARE IS BEING MADE AVAILABLE ``AS-IS''. UMD is making
|
||||
this work available so that other people can use it. This software is in
|
||||
production use at our home site - the UMCP Department of Computer Science -
|
||||
but we make no warranties that it will work for you. Amanda development is
|
||||
unfunded - the development team maintains the code in their spare time. As a
|
||||
result, there is no support available other than users helping each other on
|
||||
the Amanda mailing lists. See below for information on the mailing lists.
|
||||
|
||||
|
||||
WHAT IS AMANDA?
|
||||
---------------
|
||||
|
||||
This is a release of Amanda, the Advanced Maryland Automatic
|
||||
Network Disk Archiver. Amanda is a backup system designed to archive many
|
||||
computers on a network to a single large-capacity tape drive.
|
||||
|
||||
Here are some features of Amanda:
|
||||
|
||||
* written in C, freely distributable.
|
||||
* built on top of standard backup software: Unix dump/restore, GNU Tar
|
||||
and others.
|
||||
* will back up multiple machines in parallel to a holding disk, blasting
|
||||
finished dumps one by one to tape as fast as we can write files to
|
||||
tape. For example, a ~2 Gb 8mm tape on a ~240K/s interface to a host
|
||||
with a large holding disk can be filled by Amanda in under 4 hours.
|
||||
* does simple tape management: will not overwrite the wrong tape.
|
||||
* supports tape changers via a generic interface. Easily customizable to
|
||||
any type of tape carousel, robot, or stacker that can be controlled via
|
||||
the unix command line.
|
||||
* supports Kerberos 4 security, including encrypted dumps. The Kerberos
|
||||
support is available as a separate add-on package, see the file
|
||||
KERBEROS.HOW-TO-GET on the ftp site, and the file docs/KERBEROS in this
|
||||
package, for more details.
|
||||
* for a restore, tells you what tapes you need, and finds the proper
|
||||
backup image on the tape for you.
|
||||
* recovers gracefully from errors, including down or hung machines.
|
||||
* reports results, including all errors in detail, in email.
|
||||
* will dynamically adjust backup schedule to keep within constraints: no
|
||||
more juggling by hand when adding disks and computers to network.
|
||||
* includes a pre-run checker program, that conducts sanity checks on both
|
||||
the tape server host and all the client hosts (in parallel), and will
|
||||
send an e-mail report of any problems that could cause the backups to
|
||||
fail.
|
||||
* can compress dumps before sending or after sending over the net, with
|
||||
either compress or gzip.
|
||||
* can optionally synchronize with external backups, for those large
|
||||
timesharing computers where you want to do full dumps when the system
|
||||
is down in single-user mode (since BSD dump is not reliable on active
|
||||
filesystems): Amanda will still do your daily dumps.
|
||||
* lots of other options; Amanda is very configurable.
|
||||
|
||||
|
||||
WHAT ARE THE SYSTEM REQUIREMENTS FOR AMANDA?
|
||||
--------------------------------------------
|
||||
|
||||
Amanda requires a host that is mostly idle during the time backups are
|
||||
done, with a large capacity tape drive (e.g. an EXABYTE, DAT or DLT tape).
|
||||
This becomes the "tape server host". All the computers you are going to dump
|
||||
are the "backup client hosts". The server host can also be a client host.
|
||||
|
||||
Amanda works best with one or more large "holding disk" partitions on the
|
||||
server host available to it for buffering dumps before writing to tape.
|
||||
The holding disk allows Amanda to run backups in parallel to the disk, only
|
||||
writing them to tape when the backup is finished. Note that the holding
|
||||
disk is not required: without it Amanda will run backups sequentially to
|
||||
the tape drive. Running it this way kills the great performance, but still
|
||||
allows you to take advantage of Amanda's other features.
|
||||
|
||||
As a rule of thumb, for best performance the holding disk should be larger
|
||||
than the dump output from your largest disk partitions. For example, if
|
||||
you are backing up some full gigabyte disks that compress down to 500 MB,
|
||||
then you'll want 500 MB on your holding disk. On the other hand, if those
|
||||
gigabyte drives are partitioned into 500 MB filesystems, they'll probably
|
||||
compress down to 250 MB and you'll only need that much on your holding
|
||||
disk. Amanda will perform better with larger holding disks.
|
||||
|
||||
Actually, Amanda will still work if you have full dumps that are larger
|
||||
than the holding disk: Amanda will send those dumps directly to tape one at
|
||||
a time. If you have many such dumps you will be limited by the dump speed
|
||||
of those machines.
|
||||
|
||||
Amanda does not yet support single backup images larger than a tape.
|
||||
|
||||
|
||||
WHAT SYSTEMS DOES AMANDA RUN ON?
|
||||
--------------------------------
|
||||
|
||||
Amanda should run on any modern Unix system that supports dump or GNU
|
||||
tar, has sockets and inetd, and either system V shared memory, or BSD
|
||||
mmap implemented.
|
||||
|
||||
In particular, Amanda 2.4.0 has been compiled, and the client side tested
|
||||
on the following systems:
|
||||
AIX 3.2 and 4.1
|
||||
BSDI BSD/OS 2.1 and 3.1
|
||||
DEC OSF/1 3.2 and 4.0
|
||||
FreeBSD 2.2.5
|
||||
IRIX 5.2 and 6.3
|
||||
Linux/GNU on x86, alpha and sparc
|
||||
NetBSD 1.0
|
||||
Nextstep 3 (*)
|
||||
SunOS 4.1.x (x >= 1) and 5.[56]
|
||||
Ultrix 4.2
|
||||
HP-UX 9.x and 10.x (x >= 01)
|
||||
|
||||
The Amanda 2.4.0 server side is known to run on all of the other
|
||||
machines except on those marked with an asterisk.
|
||||
|
||||
If you know of any system that is not listed here on which amanda
|
||||
builds successfully, either client&server or client-only, please
|
||||
report to amanda-hackers@amanda.org.
|
||||
|
||||
|
||||
WHERE DO I GET AMANDA?
|
||||
----------------------
|
||||
|
||||
There are several versions of Amanda. The latest version at the time
|
||||
of this writing is available at:
|
||||
|
||||
ftp://ftp.amanda.org/pub/amanda
|
||||
|
||||
|
||||
HOW DO I GET AMANDA UP AND RUNNING?
|
||||
-----------------------------------
|
||||
|
||||
Read the file docs/INSTALL. There are a variety of steps, from compiling
|
||||
Amanda to installing it on the tape server host and the client machines.
|
||||
docs/INSTALL contains general installation instructions.
|
||||
docs/SYSTEM.NOTES contains system-specific information.
|
||||
docs/FAQ contains answers to frequently asked questions.
|
||||
docs/KERBEROS explains installation under Kerberos 4.
|
||||
docs/TAPE.CHANGERS explains how to customize the changer interface.
|
||||
docs/WHATS.NEW details new features.
|
||||
|
||||
|
||||
WHO DO I TALK TO IF I HAVE A PROBLEM?
|
||||
-------------------------------------
|
||||
|
||||
Amanda is completely unsupported and made available as-is. However,
|
||||
you may be able to get useful information in the Amanda mailing lists:
|
||||
|
||||
==> To join a mailing list, DO NOT, EVER, send mail to that list. Send
|
||||
mail to <listname>-request@amanda.org, or amanda-lists@amanda.org,
|
||||
with the following line in the body of the message:
|
||||
subscribe <listname> <your-email-address>
|
||||
|
||||
|
||||
amanda-announce
|
||||
The amanda-announce mailing list is for important announcements
|
||||
related to the Amanda Network Backup Manager package, including new
|
||||
versions, contributions, and fixes. NOTE: the amanda-users list is
|
||||
itself on the amanda-announce distribution, so you only need to
|
||||
subscribe to one of the two lists, not both.
|
||||
To subscribe, send a message to amanda-announce-request@amanda.org.
|
||||
|
||||
amanda-users
|
||||
The amanda-users mailing list is for questions and general discussion
|
||||
about the Amanda Network Backup Manager. This package and related
|
||||
files are available via anonymous FTP from ftp.amanda.org in the
|
||||
pub/amanda directory. NOTE: the amanda-users list is itself on the
|
||||
amanda-announce distribution, so you only need to subscribe to one of
|
||||
the two lists, not both.
|
||||
To subscribe, send a message to amanda-users-request@amanda.org.
|
||||
|
||||
amanda-hackers
|
||||
The amanda-hackers mailing list is for discussion of the
|
||||
technical details of the Amanda package, including extensions,
|
||||
ports, bugs, fixes, and alpha testing of new versions.
|
||||
To subscribe, send a message to amanda-hackers-request@amanda.org.
|
||||
|
||||
|
||||
Share and Enjoy,
|
||||
The Amanda Development Team
|
7
sysutils/amanda-plot/pkg/PLIST
Normal file
7
sysutils/amanda-plot/pkg/PLIST
Normal file
|
@ -0,0 +1,7 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 1999/09/06 18:11:22 bad Exp $
|
||||
libexec/amcat.awk
|
||||
libexec/amplot.awk
|
||||
libexec/amplot.g
|
||||
libexec/amplot.gp
|
||||
man/man8/amplot.8
|
||||
sbin/amplot
|
Loading…
Reference in a new issue