Add companion patch to previous commit.
Fix build on NetBSD-current/i386 by papering over a build time assertion. (Probably due to 64-bit time_t.)
This commit is contained in:
parent
8d07a95da3
commit
fcb4c7a415
2 changed files with 17 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.45 2009/06/17 08:34:07 tnn Exp $
|
||||
$NetBSD: distinfo,v 1.46 2009/06/17 08:40:57 tnn Exp $
|
||||
|
||||
SHA1 (lftp-3.7.14.tar.bz2) = b36819aa9624057f1c9067867579c2ac509c72e7
|
||||
RMD160 (lftp-3.7.14.tar.bz2) = b6c7bfc5d33b607203afa6784c2db5ece6d2716b
|
||||
|
@ -9,3 +9,4 @@ SHA1 (patch-ac) = 32e1fba23d4d6bd0b06bacbe503cb9b39d2bf825
|
|||
SHA1 (patch-ad) = a8a335baf0c9a2a89c58c7395c879d2e8b0c4407
|
||||
SHA1 (patch-ae) = 3ee418b94cc1afb7b2db5bc550fd966d346368a4
|
||||
SHA1 (patch-af) = 69c414ab28cbdfb86e4981fb7eaa7985b8384838
|
||||
SHA1 (patch-ag) = 9eda126e106cee0cae6be691ad8bece921c9c0a9
|
||||
|
|
15
net/lftp/patches/patch-ag
Normal file
15
net/lftp/patches/patch-ag
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ag,v 1.1 2009/06/17 08:40:57 tnn Exp $
|
||||
|
||||
--- lib/mktime.c.orig 2009-01-16 08:58:41.000000000 +0100
|
||||
+++ lib/mktime.c
|
||||
@@ -165,8 +165,10 @@ ydhms_diff (long int year1, long int yda
|
||||
int year0, int yday0, int hour0, int min0, int sec0)
|
||||
{
|
||||
verify (C99_integer_division, -1 / 2 == 0);
|
||||
+/* This assertion fails on NetBSD-current/i386 due to 64-bit time_t
|
||||
verify (long_int_year_and_yday_are_wide_enough,
|
||||
INT_MAX <= LONG_MAX / 2 || TIME_T_MAX <= UINT_MAX);
|
||||
+*/
|
||||
|
||||
/* Compute intervening leap days correctly even if year is negative.
|
||||
Take care to avoid integer overflow here. */
|
Loading…
Reference in a new issue