TeXmacs: Upgrade to 1.99.11
Switch from qt4 to qt5. Switch to CMake. Add hacks to build with guile1.8. CHANGELOG ========= Several bug fixes (1.99.11). Repositories for Debian and Ubuntu (1.99.11). Many bug fixes (1.99.10). Redesigned web site (1.99.10). Extended Css stylability when exporting to Html (1.99.10). New TeXmacs videos on web site (1.99.10). Drag and drop for images (1.99.10). Unification of beamer and poster styles, work in progress (1.99.10). Automatic retrieval of artwork from texmacs.org (1.99.10). New background patterns and pictures (1.99.10). Experimental pattern effects (1.99.10). Experimental Sparkle support under MacOS (1.99.10). Experimental and partial support for Git as a versioning tool (1.99.10). Experimantal Graph plug-in for graphs drawn by various external tools (1.99.10). User interface for new features in educational styles (1.99.10). Many bug fixes (1.99.9). Similar spell checking widgets as for search and replace (1.99.9). Improved educational styles (1.99.9). Multiple choice lists (1.99.9). A unified Graph plugin for Graphviz, Asymptote (1.99.9). Import improvements from the FriCAS project (1.99.9). Fixes and documentation for the Sage plugin (1.99.9). Several bug fixes (1.99.8). Support of binary packages for various GNU/Linux distributions, constructed using Suse OpenBuild services (1.99.8). Several new algorithms for micro typography: roots, mathematical accents, etc. (1.99.7). New style for posters (1.99.7). Support for new ACM styles (1.99.7). Various bug fixes (1.99.7). New page breaker with better support for floating objects and footnotes (1.99.6). Improved native Pdf generation based on Hummus (1.99.6). Several new algorithms for micro typography: subscripts, superscripts, etc. (1.99.6). Improved support for TeX Gyre fonts (1.99.6). Various bug fixes (1.99.6).
This commit is contained in:
parent
3d92c13eca
commit
fcb4f50610
15 changed files with 692 additions and 377 deletions
|
@ -1,10 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.128 2019/08/11 13:20:53 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.129 2019/10/28 15:10:00 kamil Exp $
|
||||
#
|
||||
# changelog at http://www.texmacs.org/tmweb/about/changes.en.html
|
||||
|
||||
DISTNAME= TeXmacs-1.99.5-src
|
||||
DISTNAME= TeXmacs-1.99.11-src
|
||||
PKGNAME= ${DISTNAME:S/-src//}
|
||||
PKGREVISION= 14
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= ftp://ftp.texmacs.org/pub/TeXmacs/tmftp/source/
|
||||
MASTER_SITES+= http://www.texmacs.org/Download/ftp/tmftp/source/
|
||||
|
@ -15,81 +14,53 @@ COMMENT= GNU TeXmacs (free scientific text editor)
|
|||
|
||||
DEPENDS+= ps2pkm>=1.5:../../fonts/ps2pkm
|
||||
|
||||
BUILD_TARGET= TEXMACS
|
||||
#BUILD_TARGET= TEXMACS
|
||||
|
||||
USE_CMAKE= yes
|
||||
USE_TOOLS+= gmake perl:run pkg-config bash
|
||||
USE_LANGUAGES= c c++
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV+= ac_cv_path_RCC=${QTDIR}/bin/rcc
|
||||
# XXX workaround for bug in configure
|
||||
CONFIGURE_ARGS+= --datadir=${PREFIX}/share
|
||||
CONFIGURE_ARGS+= --with-qt=${QTDIR}
|
||||
BUILD_MAKE_FLAGS+= QT_QTDIR=${QTDIR}
|
||||
|
||||
# in 1.99.5 this fails with
|
||||
# ./configure: 4562: Syntax error: Bad substitution
|
||||
CONFIG_SHELL= ${BASH}
|
||||
|
||||
REPLACE_PYTHON= plugins/python/bin/tm_python
|
||||
REPLACE_PYTHON+= plugins/sage/bin/tm_sage
|
||||
REPLACE_PYTHON+= plugins/mathematica/bin/realpath.py
|
||||
|
||||
REPLACE_BASH+= plugins/dratex/bin/tm_dratex
|
||||
REPLACE_BASH+= plugins/eukleides/bin/tm_eukleides
|
||||
REPLACE_BASH+= plugins/eukleides/bin/tm_eukleides.old
|
||||
REPLACE_BASH+= plugins/mupad/bin/tm_mupad_help
|
||||
REPLACE_BASH+= plugins/texgraph/bin/tm_texgraph
|
||||
|
||||
REPLACE_PERL+= plugins/feynmf/bin/bbox_add.pl
|
||||
|
||||
SUBST_CLASSES+= init
|
||||
SUBST_STAGE.init= pre-configure
|
||||
SUBST_FILES.init= plugins/python/progs/init-python.scm
|
||||
SUBST_VARS.init= PYTHONBIN
|
||||
|
||||
REPLACE_SH+= plugins/asymptote/bin/tm_asy
|
||||
REPLACE_SH+= plugins/dratex/bin/tm_dratex
|
||||
REPLACE_SH+= plugins/eukleides/bin/tm_eukleides
|
||||
REPLACE_SH+= plugins/eukleides/bin/tm_eukleides.old
|
||||
REPLACE_SH+= plugins/gnuplot/bin/tm_gnuplot
|
||||
REPLACE_SH+= plugins/lisp/bin/tm_lisp
|
||||
REPLACE_SH+= plugins/lush/bin/tm_lush
|
||||
REPLACE_SH+= plugins/matlab/bin/tm_matlab
|
||||
REPLACE_SH+= plugins/maxima/bin/maxima_detect
|
||||
REPLACE_SH+= plugins/maxima/bin/tm_maxima
|
||||
REPLACE_SH+= plugins/mupad/bin/tm_mupad
|
||||
REPLACE_SH+= plugins/mupad/bin/tm_mupad_help
|
||||
REPLACE_SH+= plugins/octave/bin/tm_octave
|
||||
REPLACE_SH+= plugins/reduce/bin/tm_reduce
|
||||
REPLACE_SH+= plugins/texgraph/bin/tm_texgraph
|
||||
REPLACE_SH+= plugins/xypic/bin/tm_xypic
|
||||
REPLACE_SH+= misc/admin/sign_update
|
||||
REPLACE_SH+= misc/scripts/gs
|
||||
SUBST_CLASSES+= guile
|
||||
SUBST_STAGE.guile= pre-configure
|
||||
SUBST_FILES.guile= cmake/FindGuile.cmake
|
||||
SUBST_VARS.guile= PREFIX
|
||||
|
||||
REPLACE_PERL+= plugins/asymptote/bin/perl-tm_asy
|
||||
REPLACE_PERL+= plugins/asymptote/bin/tm_asy2
|
||||
REPLACE_PERL+= plugins/feynmf/bin/bbox_add.pl
|
||||
|
||||
SUBST_CLASSES+= linkpath
|
||||
SUBST_SED.linkpath+= -e "s,-lguile,-L${PREFIX}/guile/1.8/lib -lguile,g"
|
||||
SUBST_FILES.linkpath+= configure
|
||||
SUBST_MESSAGE.linkpath= Search for guile library in proper directory.
|
||||
SUBST_STAGE.linkpath= pre-configure
|
||||
|
||||
SUBST_CLASSES+= bash
|
||||
SUBST_CLASSES+= bash
|
||||
SUBST_SED.bash+= -e "s,/bin/bash,${PREFIX}/bin/bash,"
|
||||
SUBST_FILES.bash+= src/makefile.in src/Texmacs/Texmacs/texmacs.cpp Makefile.in
|
||||
SUBST_FILES.bash+= src/Texmacs/Texmacs/texmacs.cpp
|
||||
SUBST_MESSAGE.bash= Fixing hardcoded bash path.
|
||||
SUBST_STAGE.bash= pre-configure
|
||||
|
||||
pre-build:
|
||||
find ${WRKSRC} -name ._* -exec rm {} \;
|
||||
LDFLAGS+= ${COMPILER_RPATH_FLAG}${PREFIX}/guile/1.8/lib/
|
||||
|
||||
# do not install backup files
|
||||
# do not install cmake files
|
||||
post-install:
|
||||
${RM} ${DESTDIR}${PREFIX}/share/TeXmacs/plugins/python/progs/init-python.scm.orig
|
||||
${FIND} ${DESTDIR} -name cmake_install.cmake -type f | ${XARGS} ${RM} -f
|
||||
${FIND} ${DESTDIR} -name CMakeFiles -type d | ${XARGS} ${RM} -rf
|
||||
|
||||
.include "../../converters/libiconv/buildlink3.mk"
|
||||
.include "../../databases/shared-mime-info/mimedb.mk"
|
||||
.include "../../graphics/freetype2/buildlink3.mk"
|
||||
.include "../../graphics/gnome-icon-theme/buildlink3.mk"
|
||||
# as of 1.99.5
|
||||
# configure: error: TeXmacs is incompatible with Guile 2.
|
||||
#.include "../../lang/guile20/buildlink3.mk"
|
||||
.include "../../lang/guile/buildlink3.mk"
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../print/ghostscript/buildlink3.mk"
|
||||
.include "../../x11/qt4-tools/buildlink3.mk"
|
||||
.include "../../x11/qt5-qtbase/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,16 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.69 2017/08/25 20:03:03 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.70 2019/10/28 15:10:00 kamil Exp $
|
||||
|
||||
SHA1 (TeXmacs-1.99.5-src.tar.gz) = be6fdc39a094db6dc547490fa89a95876dbde002
|
||||
RMD160 (TeXmacs-1.99.5-src.tar.gz) = eba10c9be4549d61240290878af429d80ede933f
|
||||
SHA512 (TeXmacs-1.99.5-src.tar.gz) = a7d846fd8823e486cf724bfcbe04ae877dd64995d6131af59b49427a1178e36b52b9fcd9109783b9ae1e39c988ae9ed497b1540dce29645ebf2c4301ca7357a8
|
||||
Size (TeXmacs-1.99.5-src.tar.gz) = 25014543 bytes
|
||||
SHA1 (patch-aa) = 95b9e42fe1ff343e891fe299382c3647636eec99
|
||||
SHA1 (patch-ab) = a79814a9cdbf008ad08afa99822b707ab809599c
|
||||
SHA1 (patch-ac) = e54a636e6e8f789bbdb0fc5a252b4a43525de72d
|
||||
SHA1 (patch-ad) = 4a59f6e7b6f0225a5d74b1b500f9a6997ea78cb4
|
||||
SHA1 (patch-ae) = c313a19db160d9f1c0dc950a1eb465869cec777f
|
||||
SHA1 (patch-aj) = ed4d847ad8e7b12745b144e6790eab539cbc6bca
|
||||
SHA1 (patch-al) = f7deed3d692af322aebe1a4068dfd3bde9e87a0a
|
||||
SHA1 (patch-src_Plugins_Qt_QTMSockets.cpp) = 83a50c86d373301b092e1ffee1bd17650cc222c1
|
||||
SHA1 (patch-src_System_Link_socket__server.cpp) = dbc6b8e7012abf3f1833e44aedb7172de675b7e1
|
||||
SHA1 (patch-src_makefile.in) = 34dc509a9e2834e376a5989d8500f3e473d266f0
|
||||
SHA1 (TeXmacs-1.99.11-src.tar.gz) = 53abe8011df033005ffa3530f23501833afed440
|
||||
RMD160 (TeXmacs-1.99.11-src.tar.gz) = 25a17545389f06b4ac49899fc2c8554612708b48
|
||||
SHA512 (TeXmacs-1.99.11-src.tar.gz) = 3f3481834baeeee93afc2c2de1666297b8c02d7dc5223b00ee93120e175503c91bdcc3d9ff4d8df498033064b2e67b12ffd47af9e8b95ad5eee12b47ec076855
|
||||
Size (TeXmacs-1.99.11-src.tar.gz) = 32798336 bytes
|
||||
SHA1 (patch-cmake_FindGuile.cmake) = cb6085af098467d320ff65451df33bf552b2ddaa
|
||||
SHA1 (patch-misc_CMakeLists.txt) = 0534c9a1c66315d3189a4d6932ce56b3d7c2978a
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.6 2004/01/20 14:44:13 recht Exp $
|
||||
|
||||
--- Makefile.in.orig 2003-12-28 17:18:07.000000000 +0100
|
||||
+++ Makefile.in 2003-12-29 18:03:37.000000000 +0100
|
||||
@@ -166,10 +166,8 @@
|
||||
$(MKDIR) $(DESTDIR)$(mandir)/man1
|
||||
$(CP) misc/man/fig2ps.1 $(DESTDIR)$(mandir)/man1
|
||||
$(CP) misc/man/texmacs.1 $(DESTDIR)$(mandir)/man1
|
||||
- $(GZIP) $(DESTDIR)$(mandir)/man1/fig2ps.1
|
||||
- $(GZIP) $(DESTDIR)$(mandir)/man1/texmacs.1
|
||||
- $(CHMOD) go=rX $(DESTDIR)$(mandir)/man1/fig2ps.1.gz
|
||||
- $(CHMOD) go=rX $(DESTDIR)$(mandir)/man1/texmacs.1.gz
|
||||
+ $(CHMOD) go=rX $(DESTDIR)$(mandir)/man1/fig2ps.1
|
||||
+ $(CHMOD) go=rX $(DESTDIR)$(mandir)/man1/texmacs.1
|
||||
@echo installed TeXmacs manual pages in $(DESTDIR)$(mandir)
|
||||
@echo ----------------------------------------------------
|
||||
@echo TeXmacs has been successfully installed
|
|
@ -1,48 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.14 2016/09/16 09:42:25 wiz Exp $
|
||||
|
||||
--- configure.orig 2016-07-07 18:34:10.000000000 +0000
|
||||
+++ configure
|
||||
@@ -2898,7 +2898,7 @@ case $host_os in *\ *) host_os=`echo "$h
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking current Subversion revision number" >&5
|
||||
$as_echo_n "checking current Subversion revision number... " >&6; }
|
||||
SVNREV=`svnversion -n . 2>/dev/null`
|
||||
-SVNREV=${SVNREV/:/_}
|
||||
+#SVNREV=${SVNREV/:/_}
|
||||
if { test "$SVNREV" = "" || test "$SVNREV" = "exported" ; } ; then
|
||||
SVNREV=`cat $srcdir/SVNREV`
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $SVNREV" >&5
|
||||
@@ -5218,7 +5218,7 @@ $as_echo "#define OS_GNU_LINUX 1" >>conf
|
||||
CONFIG_CXXOPTIMIZE="-O3 -fexpensive-optimizations"
|
||||
CONFIG_OS=LINUX
|
||||
;;
|
||||
- i*86-*-freebsd* | x86_64-*-freebsd*)
|
||||
+ i*86-*-freebsd* | x86_64-*-freebsd* | *-*-netbsd)
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: final adjustments for an Intel or AMD GNU/BSD host" >&5
|
||||
$as_echo "final adjustments for an Intel or AMD GNU/BSD host" >&6; }
|
||||
|
||||
@@ -18545,8 +18545,6 @@ fi
|
||||
|
||||
fi
|
||||
;;
|
||||
- -Wl,*) { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Flag $LC_SCATTER_FLAGS_flag dropped for lib GUILE_TMP" >&5
|
||||
-$as_echo "$as_me: WARNING: Flag $LC_SCATTER_FLAGS_flag dropped for lib GUILE_TMP" >&2;};;
|
||||
-*)
|
||||
as_CACHEVAR=`$as_echo "ax_cv_check_cxxflags__$LC_SCATTER_FLAGS_flag" | $as_tr_sh`
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C++ compiler accepts $LC_SCATTER_FLAGS_flag" >&5
|
||||
@@ -20141,13 +20139,13 @@ $as_echo "#define GUILE_HEADER_18 1" >>c
|
||||
*) { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Strange guile header name lib$GUILE_LIB.h" >&5
|
||||
$as_echo "$as_me: WARNING: Strange guile header name lib$GUILE_LIB.h" >&2;} ;;
|
||||
esac
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for gh_scm2newstr in -lGuile" >&5
|
||||
-$as_echo_n "checking for gh_scm2newstr in -lGuile... " >&6; }
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for gh_scm2newstr in -lguile" >&5
|
||||
+$as_echo_n "checking for gh_scm2newstr in -lguile... " >&6; }
|
||||
if ${ac_cv_lib_Guile_gh_scm2newstr+:} false; then :
|
||||
$as_echo_n "(cached) " >&6
|
||||
else
|
||||
ac_check_lib_save_LIBS=$LIBS
|
||||
-LIBS="-lGuile -lintl -liconv $LIBS"
|
||||
+LIBS="-lguile -lintl -liconv $LIBS"
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.7 2015/08/05 13:09:17 ryoon Exp $
|
||||
|
||||
--- plugins/python/progs/init-python.scm.orig 2014-03-03 11:44:12.000000000 +0000
|
||||
+++ plugins/python/progs/init-python.scm
|
||||
@@ -31,7 +31,7 @@
|
||||
|
||||
(plugin-configure python
|
||||
(:winpath "Python2*" ".")
|
||||
- (:require (url-exists-in-path? "python"))
|
||||
+ (:require (url-exists-in-path? "@PYTHONBIN@"))
|
||||
(:require (url-exists-in-path? "tm_python"))
|
||||
(:launch ,(python-launcher))
|
||||
(:tab-completion #t)
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.5 2015/08/05 13:09:17 ryoon Exp $
|
||||
|
||||
--- src/System/Link/pipe_link.cpp.orig 2014-03-03 11:44:14.000000000 +0000
|
||||
+++ src/System/Link/pipe_link.cpp
|
||||
@@ -30,9 +30,6 @@
|
||||
#include <signal.h>
|
||||
#include <sys/wait.h>
|
||||
#endif
|
||||
-#ifndef __APPLE__
|
||||
-#include <malloc.h>
|
||||
-#endif
|
||||
|
||||
hashset<pointer> pipe_link_set;
|
||||
void pipe_callback (void *obj, void *info);
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.2 2005/07/27 17:32:13 drochner Exp $
|
||||
|
||||
--- ./src/System/Classes/timer.hpp.orig 2005-07-26 11:46:06.000000000 +0200
|
||||
+++ ./src/System/Classes/timer.hpp
|
||||
@@ -15,10 +15,7 @@
|
||||
#include "string.hpp"
|
||||
#include "tm_configure.hpp"
|
||||
|
||||
-#ifndef HAVE_TIME_T
|
||||
-#define HAVE_TIME_T
|
||||
-typedef long time_t;
|
||||
-#endif
|
||||
+#include <time.h>
|
||||
|
||||
#ifdef OS_SUN
|
||||
#include <sys/types.h>
|
|
@ -1,40 +0,0 @@
|
|||
$NetBSD: patch-aj,v 1.8 2016/07/16 21:13:22 wiz Exp $
|
||||
|
||||
--- plugins/r/src/tm_r.c.orig 2016-05-26 01:33:18.000000000 +0000
|
||||
+++ plugins/r/src/tm_r.c
|
||||
@@ -18,6 +18,7 @@
|
||||
#include <util.h>
|
||||
#endif
|
||||
|
||||
+#include <util.h>
|
||||
#include <utmp.h>
|
||||
#include <unistd.h>
|
||||
#include <termios.h>
|
||||
@@ -844,7 +845,11 @@ int main(int argc, char *argv[])
|
||||
char *TEXMACS_HOME_PATH, *TEXMACS_R, *TEXMACS_SEND_E, *TEXMACS_LIB, *HOME ;
|
||||
struct termios termi ;
|
||||
sigset_t sigmask, orig_sigmask;
|
||||
-
|
||||
+#if defined(__DragonFly__)
|
||||
+ sigset_t cur_sigmask;
|
||||
+ int select_retval;
|
||||
+#endif
|
||||
+
|
||||
struct stat stat_buf;
|
||||
|
||||
name = getenv("TEXMACS_R_SESSION") ;
|
||||
@@ -1007,7 +1012,14 @@ unsetenv( "DYLD_LIBRARY_PATH") ;
|
||||
|
||||
// We will wait till something happens using pselect.
|
||||
|
||||
+#if defined(__DragonFly__)
|
||||
+ sigprocmask(SIG_SETMASK, &orig_sigmask, &cur_sigmask);
|
||||
+ select_retval = select( subprocess+1, &rd, &wr, &er, NULL );
|
||||
+ sigprocmask(SIG_SETMASK, &cur_sigmask, NULL);
|
||||
+ if ( select_retval > 0) {
|
||||
+#else
|
||||
if( (pselect( subprocess+1, &rd, &wr, &er, NULL, &orig_sigmask )) > 0 ) {
|
||||
+#endif
|
||||
if( FD_ISSET( STDIN_FILENO, &er) ) exit(0) ;
|
||||
if( FD_ISSET( STDOUT_FILENO, &er) ) exit(0) ;
|
||||
if( FD_ISSET( subprocess, &er) ) exit(0) ;
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-al,v 1.1 2008/07/13 14:30:21 obache Exp $
|
||||
|
||||
--- plugins/shell/src/tm_shell.cpp.orig 2008-03-20 02:16:36.000000000 +0900
|
||||
+++ plugins/shell/src/tm_shell.cpp
|
||||
@@ -25,6 +25,9 @@
|
||||
#if HAVE_PTY_H
|
||||
#include <pty.h>
|
||||
#endif
|
||||
+#if defined(__DragonFly__) || defined(__FreeBSD__)
|
||||
+#include <libutil.h>
|
||||
+#endif
|
||||
#if HAVE_UTIL_H
|
||||
#include <util.h>
|
||||
#endif
|
21
editors/TeXmacs/patches/patch-cmake_FindGuile.cmake
Normal file
21
editors/TeXmacs/patches/patch-cmake_FindGuile.cmake
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-cmake_FindGuile.cmake,v 1.1 2019/10/28 15:10:00 kamil Exp $
|
||||
|
||||
Hack to set libguile library as find_library() does not work.
|
||||
|
||||
--- cmake/FindGuile.cmake.orig 2019-07-26 14:44:40.000000000 +0000
|
||||
+++ cmake/FindGuile.cmake
|
||||
@@ -64,7 +64,8 @@ IF(GUILECONFIG_EXECUTABLE)
|
||||
ENDIF(NOT _guile_flag_library_${i})
|
||||
ENDIF (i)
|
||||
ENDFOREACH(i)
|
||||
-
|
||||
+
|
||||
+ SET(_guile_libraries ${_guile_libraries} "@PREFIX@/guile/1.8/lib/libguile.so")
|
||||
|
||||
|
||||
SET(Guile_FOUND YES)
|
||||
@@ -89,4 +90,3 @@ ELSE(GUILECONFIG_EXECUTABLE)
|
||||
|
||||
|
||||
ENDIF(GUILECONFIG_EXECUTABLE)
|
||||
-
|
22
editors/TeXmacs/patches/patch-misc_CMakeLists.txt
Normal file
22
editors/TeXmacs/patches/patch-misc_CMakeLists.txt
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-misc_CMakeLists.txt,v 1.1 2019/10/28 15:10:00 kamil Exp $
|
||||
|
||||
Set proper man install dir.
|
||||
|
||||
--- misc/CMakeLists.txt.orig 2019-07-26 14:43:15.000000000 +0000
|
||||
+++ misc/CMakeLists.txt
|
||||
@@ -2,6 +2,8 @@ configure_file(scripts/texmacs.in ${TEXM
|
||||
configure_file(scripts/fig2ps.in ${TEXMACS_BINARY_DIR}/misc/scripts/fig2ps @ONLY)
|
||||
configure_file(man/texmacs.1.in ${TEXMACS_SOURCE_DIR}/misc/man/texmacs.1 @ONLY)
|
||||
|
||||
+include(GNUInstallDirs)
|
||||
+
|
||||
### share/man
|
||||
set(TOOLS "texmacs" "fig2ps")
|
||||
set(MAN_SECTION "1")
|
||||
@@ -16,5 +18,5 @@ foreach(TOOL ${TOOLS})
|
||||
VERBATIM
|
||||
)
|
||||
add_custom_target(${TOOL}.${MAN_SECTION} ALL DEPENDS ${TOOL_MANFILE_GZ})
|
||||
- install(FILES ${TOOL_MANFILE_GZ} DESTINATION share/man/man${MAN_SECTION})
|
||||
+ install(FILES ${TOOL_MANFILE_GZ} DESTINATION ${CMAKE_INSTALL_MANDIR}/man${MAN_SECTION})
|
||||
endforeach(TOOL)
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-src_Plugins_Qt_QTMSockets.cpp,v 1.1 2017/08/25 20:03:03 joerg Exp $
|
||||
|
||||
--- src/Plugins/Qt/QTMSockets.cpp.orig 2017-07-24 13:33:10.562028054 +0000
|
||||
+++ src/Plugins/Qt/QTMSockets.cpp
|
||||
@@ -19,6 +19,7 @@
|
||||
#include <unistd.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
+#include <sys/time.h>
|
||||
#include <netinet/in.h>
|
||||
#include <netdb.h>
|
||||
#include <stdint.h>
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-src_System_Link_socket__server.cpp,v 1.2 2016/07/16 21:13:22 wiz Exp $
|
||||
|
||||
--- src/System/Link/socket_server.cpp.orig 2015-12-16 16:15:03.000000000 +0000
|
||||
+++ src/System/Link/socket_server.cpp
|
||||
@@ -21,6 +21,8 @@
|
||||
#include <netinet/in.h>
|
||||
#include <arpa/inet.h>
|
||||
#include <sys/wait.h>
|
||||
+#include <sys/time.h>
|
||||
+#include <sys/select.h>
|
||||
#else
|
||||
namespace wsoc {
|
||||
#include <sys/types.h>
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-src_makefile.in,v 1.1 2016/09/16 09:42:25 wiz Exp $
|
||||
|
||||
--- src/makefile.in.orig 2016-09-16 09:21:53.122589456 +0000
|
||||
+++ src/makefile.in
|
||||
@@ -32,7 +32,7 @@ CPPFLAGS := @CPPFLAGS@
|
||||
CFLAGS := @CFLAGS@
|
||||
CXXFLAGS := @CXXDEBUG@ @CXXFLAGS@
|
||||
LDFLAGS := @LDFLAGS@
|
||||
-LIBS := @LIBS@
|
||||
+LIBS := -L${PREFIX}/guile/1.8/lib @LIBS@
|
||||
|
||||
AR = ar
|
||||
ARFLAGS = -r
|
Loading…
Reference in a new issue