py-cheroot: updated to 10.0.0

v10.0.0

- Cheroot now accepts a
  ``reuse_port`` parameter on the ``HTTPServer`` object.
  Subclasses overriding ``prepare_socket`` will no longer
  work and will need to adapt to the new interface.

v9.0.0

- Cheroot now requires Python
  3.6 or later. Python 3.5 and Python 2.7 are still supported
  by the :gh:`maint/8.x branch
  <cherrypy/cheroot/tree/maint/8.x>` and stabilizing
  bugfixes will be accepted to that branch.
This commit is contained in:
adam 2024-02-07 06:25:43 +00:00
parent 50a3ab1757
commit fcbdd5c5bd
4 changed files with 29 additions and 28 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.37 2023/11/07 22:38:08 wiz Exp $
# $NetBSD: Makefile,v 1.38 2024/02/07 06:25:43 adam Exp $
DISTNAME= cheroot-8.6.0
DISTNAME= cheroot-10.0.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_PYPI:=C/Cheroot/}
@ -10,28 +10,28 @@ HOMEPAGE= https://cherrypy.dev/
COMMENT= High-performance, pure-Python HTTP server used by CherryPy
LICENSE= modified-bsd
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools>=34.4:../../devel/py-setuptools
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools_scm>=7.0.0:../../devel/py-setuptools_scm
TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
DEPENDS+= ${PYPKGPREFIX}-jaraco.functools-[0-9]*:../../devel/py-jaraco.functools
DEPENDS+= ${PYPKGPREFIX}-more-itertools>=2.6:../../devel/py-more-itertools
DEPENDS+= ${PYPKGPREFIX}-six>=1.11.0:../../lang/py-six
TEST_DEPENDS+= ${PYPKGPREFIX}-coverage>=4.5.3:../../devel/py-coverage
TEST_DEPENDS+= ${PYPKGPREFIX}-coverage>=6.2:../../devel/py-coverage
TEST_DEPENDS+= ${PYPKGPREFIX}-jaraco.context-[0-9]*:../../devel/py-jaraco.context
TEST_DEPENDS+= ${PYPKGPREFIX}-jaraco.text>=3.1:../../textproc/py-jaraco.text
TEST_DEPENDS+= ${PYPKGPREFIX}-portend-[0-9]*:../../net/py-portend
TEST_DEPENDS+= ${PYPKGPREFIX}-requests-unixsocket-[0-9]*:../../devel/py-requests-unixsocket
TEST_DEPENDS+= ${PYPKGPREFIX}-requests-toolbelt-[0-9]*:../../devel/py-requests-toolbelt
TEST_DEPENDS+= ${PYPKGPREFIX}-test>=4.6.6:../../devel/py-test
TEST_DEPENDS+= ${PYPKGPREFIX}-test-cov>=2.12.0:../../devel/py-test-cov
TEST_DEPENDS+= ${PYPKGPREFIX}-test-mock>=1.10.4:../../devel/py-test-mock
TEST_DEPENDS+= ${PYPKGPREFIX}-test-forked>=1.2.0:../../devel/py-test-forked
TEST_DEPENDS+= ${PYPKGPREFIX}-test-mock>=1.11.0:../../devel/py-test-mock
TEST_DEPENDS+= ${PYPKGPREFIX}-test-rerunfailures-[0-9]*:../../devel/py-test-rerunfailures
TEST_DEPENDS+= ${PYPKGPREFIX}-test-sugar>=0.9.3:../../devel/py-test-sugar
TEST_DEPENDS+= ${PYPKGPREFIX}-test-watch>=4.2.0:../../devel/py-test-watch
TEST_DEPENDS+= ${PYPKGPREFIX}-test-xdist>=1.28.0:../../devel/py-test-xdist
TEST_DEPENDS+= ${PYPKGPREFIX}-trustme>=0.4.0:../../security/py-trustme
TEST_DEPENDS+= ${PYPKGPREFIX}-trustme>=0.4.0:../../security/py-trustme
USE_LANGUAGES= # none
USE_PKG_RESOURCES= yes
PYTHON_VERSIONS_INCOMPATIBLE= 27 38
post-install:
@ -39,9 +39,9 @@ post-install:
${MV} cheroot cheroot-${PYVERSSUFFIX} || ${TRUE}
do-test:
cd ${WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYVERSSUFFIX}
cd ${WRKSRC}/cheroot && ${SETENV} ${TEST_ENV} pytest-${PYVERSSUFFIX}
.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
PYTHON_VERSIONED_DEPENDENCIES+= OpenSSL:test
.include "../../lang/python/versioned_dependencies.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,11 +1,11 @@
@comment $NetBSD: PLIST,v 1.13 2022/11/06 18:21:11 adam Exp $
@comment $NetBSD: PLIST,v 1.14 2024/02/07 06:25:43 adam Exp $
bin/cheroot-${PYVERSSUFFIX}
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/entry_points.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE.md
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/${WHEEL_INFODIR}/entry_points.txt
${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
${PYSITELIB}/cheroot/__init__.py
${PYSITELIB}/cheroot/__init__.pyc
${PYSITELIB}/cheroot/__init__.pyi
@ -15,6 +15,7 @@ ${PYSITELIB}/cheroot/__main__.pyc
${PYSITELIB}/cheroot/__main__.pyo
${PYSITELIB}/cheroot/_compat.py
${PYSITELIB}/cheroot/_compat.pyc
${PYSITELIB}/cheroot/_compat.pyi
${PYSITELIB}/cheroot/_compat.pyo
${PYSITELIB}/cheroot/cli.py
${PYSITELIB}/cheroot/cli.pyc

View File

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.27 2022/11/06 18:21:11 adam Exp $
$NetBSD: distinfo,v 1.28 2024/02/07 06:25:43 adam Exp $
BLAKE2s (cheroot-8.6.0.tar.gz) = 89cc1e9a447b750d07b206c26e3d6e45fba4672bbdb9f6332d6f382abfa61ad6
SHA512 (cheroot-8.6.0.tar.gz) = 26e48c935fe32d4ce3cf6ae20b5b272416ca53bd8496527c2958ec2ebe87529c831f283ae900e13271b610e39531b682df0376935ecc3bcfcca11c299cd2a893
Size (cheroot-8.6.0.tar.gz) = 134779 bytes
SHA1 (patch-setup.cfg) = bb33ee596210affecd65cf665bd2335aee2ff2f0
BLAKE2s (cheroot-10.0.0.tar.gz) = 5db51660e39c7a8871974be9e096a0e6db94d5d86342fafdb6b2f0998c61e930
SHA512 (cheroot-10.0.0.tar.gz) = 02e32e52a596463cbb9874a800dbcdc5680dd7d9dfa95ca6e73c81f9248a488087c514ae70cdba94fe9df1f5d3ab1c68efcb720561cbeb7b667109fe5962f85b
Size (cheroot-10.0.0.tar.gz) = 148461 bytes
SHA1 (patch-setup.cfg) = 81504dc60b08f1cb5fc84b2e0341848b411179bc

View File

@ -1,10 +1,10 @@
$NetBSD: patch-setup.cfg,v 1.2 2022/11/06 18:21:11 adam Exp $
$NetBSD: patch-setup.cfg,v 1.3 2024/02/07 06:25:43 adam Exp $
setuptools_scm_git_archive is part of setuptools_scm as of 7.0.0.
--- setup.cfg.orig 2022-11-06 17:29:56.000000000 +0000
--- setup.cfg.orig 2023-05-20 13:33:03.848234000 +0000
+++ setup.cfg
@@ -55,8 +55,7 @@ python_requires = >=2.7,!=3.0.*,!=3.1.*,
@@ -54,8 +54,7 @@ python_requires = >=3.6
packages = find:
include_package_data = True
setup_requires =
@ -12,5 +12,5 @@ setuptools_scm_git_archive is part of setuptools_scm as of 7.0.0.
- setuptools_scm_git_archive>=1.0
+ setuptools_scm>=7.0.0
install_requires =
backports.functools_lru_cache; python_version < '3.3'
selectors2; python_version< '3.4'
importlib_metadata; python_version < '3.8'
more_itertools >= 2.6