Default arguments during method implementations are nonsense.

This commit is contained in:
joerg 2013-01-15 15:20:44 +00:00
parent e0355d35b1
commit fcdc295f37
2 changed files with 15 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.41 2012/06/25 11:21:34 joerg Exp $
$NetBSD: distinfo,v 1.42 2013/01/15 15:20:44 joerg Exp $
SHA1 (kdevelop_3.5.5.orig.tar.gz) = a28c7e4e9b5a7244a5a7063593c9713178a54bcd
RMD160 (kdevelop_3.5.5.orig.tar.gz) = 5426fdff33ce32908141c098c8dfd5e4223c928a
@ -17,4 +17,5 @@ SHA1 (patch-languages_perl_perlparser.cpp) = 7269721f036ec82032390eda51fe3afaae9
SHA1 (patch-languages_perl_perlsupportpart.cpp) = 87128f0a2714368e41400dfa341a060d2b647d56
SHA1 (patch-languages_python_pythonsupportpart.cpp) = 2f9f6c3d96e9c02ba554fff9e3861ff47999c5c9
SHA1 (patch-languages_ruby_rubysupport__part.cpp) = c6c78b777ac6f4826ec490d496d6bcc70934edaf
SHA1 (patch-lib_cppparser_lexer.h) = d4d787360ab8ae65b687139ca2924401920e381d
SHA1 (patch-parts_tools_tools__part.cpp) = 0fb3510c498fc2a8844f0c2f8ef186b7697c32fe

View file

@ -0,0 +1,13 @@
$NetBSD: patch-lib_cppparser_lexer.h,v 1.1 2013/01/15 15:20:44 joerg Exp $
--- lib/cppparser/lexer.h.orig 2013-01-14 22:00:13.000000000 +0000
+++ lib/cppparser/lexer.h
@@ -346,7 +346,7 @@ private:
};
-inline Token::Token(const QString & text = "")
+inline Token::Token(const QString & text)
: m_type( -1 ),
m_position( 0 ),
m_length( 0 ),