Make it buildable on NetBSD/alpha

This commit is contained in:
martin 2015-01-09 15:10:51 +00:00
parent c3d92cc7cd
commit fd042fef76
2 changed files with 28 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.38 2014/11/19 13:49:35 wiz Exp $
$NetBSD: distinfo,v 1.39 2015/01/09 15:10:51 martin Exp $
SHA1 (libffi-3.2.1.tar.gz) = 280c265b789e041c02e5c97815793dfc283fb1e6
RMD160 (libffi-3.2.1.tar.gz) = 9b546a3d002380bec3f00d86fc47d730abf51dfd
@ -10,5 +10,6 @@ SHA1 (patch-ae) = 3d8cd3bcd834876f6e60ae519dca8c0b0ba0d4d1
SHA1 (patch-af) = 2c7ca79ef980a2561333bf79a18df1ecb0bbb9f7
SHA1 (patch-ag) = 6333317170f6e92f89db966315276dcd8e3484f2
SHA1 (patch-aj) = d130b2b20b94ca26c70dcc46614e36c6d0ac9153
SHA1 (patch-src_alpha_osf.S) = 3fa2aab1924bc445fa2f76835c3fd38e5a3898f9
SHA1 (patch-src_arm_sysv.S) = ea294af156566c6e6f63810358de89cba6213c4f
SHA1 (patch-src_m88k_elfbsd.S) = fae3e425dcff3e924ef195eab165f9bbc6ec4077

View file

@ -0,0 +1,26 @@
$NetBSD: patch-src_alpha_osf.S,v 1.1 2015/01/09 15:10:51 martin Exp $
Band-aid update of the alpha asm code to make it compile past the addition
of type complex. Someone with clue on the alpha ELF ABI should provide
real support for complex arguments.
--- src/alpha/osf.S.orig 2014-11-08 13:47:24.000000000 +0100
+++ src/alpha/osf.S 2014-12-26 13:02:32.000000000 +0100
@@ -279,6 +279,7 @@ $load_table:
.gprel32 $load_64 # FFI_TYPE_SINT64
.gprel32 $load_none # FFI_TYPE_STRUCT
.gprel32 $load_64 # FFI_TYPE_POINTER
+ .gprel32 $load_none # FFI_TYPE_COMPLEX
/* Assert that the table above is in sync with ffi.h. */
@@ -294,7 +295,8 @@ $load_table:
|| FFI_TYPE_SINT64 != 12 \
|| FFI_TYPE_STRUCT != 13 \
|| FFI_TYPE_POINTER != 14 \
- || FFI_TYPE_LAST != 14
+ || FFI_TYPE_COMPLEX != 15 \
+ || FFI_TYPE_LAST != 15
#error "osf.S out of sync with ffi.h"
#endif