Fix build with gcc4.3
This commit is contained in:
parent
658c5d1530
commit
fd0701a310
15 changed files with 207 additions and 8 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.18 2010/01/17 12:02:05 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.19 2011/01/29 21:15:11 markd Exp $
|
||||
|
||||
DISTNAME= libtunepimp-0.5.3
|
||||
PKGREVISION= 7
|
||||
PKGREVISION= 8
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ftp://ftp.musicbrainz.org/pub/musicbrainz/ \
|
||||
http://ftp.musicbrainz.org/pub/musicbrainz/
|
||||
|
|
|
@ -1,9 +1,21 @@
|
|||
$NetBSD: distinfo,v 1.9 2007/11/19 09:53:04 dillo Exp $
|
||||
$NetBSD: distinfo,v 1.10 2011/01/29 21:15:11 markd Exp $
|
||||
|
||||
SHA1 (libtunepimp-0.5.3.tar.gz) = 1b904cd97ce009588fe57336f40e79b6edf9947e
|
||||
RMD160 (libtunepimp-0.5.3.tar.gz) = 6bc312591b98a5b74824fc3103137cbf60d4b012
|
||||
Size (libtunepimp-0.5.3.tar.gz) = 1097005 bytes
|
||||
SHA1 (patch-aa) = e304cdb6e31fe7824da34b1c820c2dd62bfeddfc
|
||||
SHA1 (patch-aa) = 965b75b10379eee9b62917c25deb1610fb8364d5
|
||||
SHA1 (patch-ab) = 014fa77e2501bdc799287eaf733ecc8fdcbb9cbe
|
||||
SHA1 (patch-ac) = cb5049d1b9e4fdda3088e957ff615ff5d9c30734
|
||||
SHA1 (patch-ad) = cc78c69249ff733227320f8ca505e10d17354e26
|
||||
SHA1 (patch-ae) = f262266dda52164ff617e4a2b9728b6e6f734619
|
||||
SHA1 (patch-af) = 7a52c3918e813d918b85168c5b487e102c3968a7
|
||||
SHA1 (patch-ag) = 15e05fcabdf9fafaca7ebd54bc7a215e11a2d71d
|
||||
SHA1 (patch-ah) = 0b4aebe206516a29d1e36f6d54b47f2c2934d4c5
|
||||
SHA1 (patch-ai) = cc9093913444870155c380c87146e3e6f7cca342
|
||||
SHA1 (patch-aj) = c9152ac8e29dbb9d6ab2d97ca9bb3f840ec9d131
|
||||
SHA1 (patch-ak) = 74810860c0c73fcf1f7a4e27b70e5e64a91355a6
|
||||
SHA1 (patch-al) = aada44efbc7eb73e59150ea90b400d8ad7a4020b
|
||||
SHA1 (patch-am) = 0f26b9ffefd6e23e5a49e4516356cb0fc7005178
|
||||
SHA1 (patch-an) = cbd5466e85dbfd38974759033b59a6147a2e62ba
|
||||
SHA1 (patch-ao) = 589faf81480e89c310fe1ae199e15657723923dc
|
||||
SHA1 (patch-ap) = cbbdc7d28ca083ec51720370bf4cbe81ec475609
|
||||
|
|
|
@ -1,8 +1,16 @@
|
|||
$NetBSD: patch-aa,v 1.4 2007/11/19 09:53:08 dillo Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2011/01/29 21:15:11 markd Exp $
|
||||
|
||||
--- plugins/mp4/mp4.cpp.orig 2006-11-18 11:51:08.000000000 +0100
|
||||
--- plugins/mp4/mp4.cpp.orig 2006-11-18 10:51:08.000000000 +0000
|
||||
+++ plugins/mp4/mp4.cpp
|
||||
@@ -231,8 +231,7 @@ mp4ReadMetadata(metadata_t *mdata, const
|
||||
@@ -27,6 +27,7 @@
|
||||
|
||||
#include <string.h>
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <mp4.h>
|
||||
#include "metadata.h"
|
||||
#include "plugin.h"
|
||||
@@ -231,8 +232,7 @@ mp4ReadMetadata(metadata_t *mdata, const
|
||||
|
||||
strcpy(mdata->fileFormat, fileName + strlen(fileName) - 3);
|
||||
|
||||
|
@ -12,7 +20,7 @@ $NetBSD: patch-aa,v 1.4 2007/11/19 09:53:08 dillo Exp $
|
|||
|
||||
return 1;
|
||||
}
|
||||
@@ -315,8 +314,7 @@ mp4WriteMetadata(const metadata_t *mdata
|
||||
@@ -315,8 +315,7 @@ mp4WriteMetadata(const metadata_t *mdata
|
||||
sprintf(temp, "%d", mdata->nonAlbum);
|
||||
MP4SetMetadataFreeForm(mp4file, "MusicBrainz Non-Album", (u_int8_t *)temp, strlen(temp) + 1);
|
||||
|
||||
|
|
14
audio/libtunepimp/patches/patch-ae
Normal file
14
audio/libtunepimp/patches/patch-ae
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ae,v 1.3 2011/01/29 21:15:11 markd Exp $
|
||||
|
||||
fix build with gcc4.3
|
||||
|
||||
--- lib/metadata.cpp.orig 2006-11-18 10:52:33.000000000 +0000
|
||||
+++ lib/metadata.cpp
|
||||
@@ -26,6 +26,7 @@
|
||||
----------------------------------------------------------------------------*/
|
||||
#include <math.h>
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include "metadata.h"
|
||||
#include "../config.h"
|
||||
using namespace std;
|
14
audio/libtunepimp/patches/patch-af
Normal file
14
audio/libtunepimp/patches/patch-af
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-af,v 1.1 2011/01/29 21:15:11 markd Exp $
|
||||
|
||||
fix build with gcc4.3
|
||||
|
||||
--- lib/protocol.cpp.orig 2006-11-28 20:25:04.000000000 +0000
|
||||
+++ lib/protocol.cpp
|
||||
@@ -8,6 +8,7 @@
|
||||
-------------------------------------------------------------------*/
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#include <string.h>
|
||||
#include <string>
|
||||
#include <map>
|
||||
#include <expat.h>
|
14
audio/libtunepimp/patches/patch-ag
Normal file
14
audio/libtunepimp/patches/patch-ag
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ag,v 1.1 2011/01/29 21:15:11 markd Exp $
|
||||
|
||||
fix build with gcc4.3
|
||||
|
||||
--- lib/utf8/utf8util.cpp.orig 2006-11-18 10:52:26.000000000 +0000
|
||||
+++ lib/utf8/utf8util.cpp
|
||||
@@ -26,6 +26,7 @@
|
||||
----------------------------------------------------------------------------*/
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include "utf8util.h"
|
||||
#include "utf8.h"
|
||||
#ifdef WIN32
|
12
audio/libtunepimp/patches/patch-ah
Normal file
12
audio/libtunepimp/patches/patch-ah
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-ah,v 1.1 2011/01/29 21:15:11 markd Exp $
|
||||
|
||||
fix build with gcc4.3
|
||||
|
||||
--- lib/c_wrapper.cpp.orig 2006-11-18 10:52:33.000000000 +0000
|
||||
+++ lib/c_wrapper.cpp
|
||||
@@ -25,4 +25,5 @@
|
||||
|
||||
----------------------------------------------------------------------------*/
|
||||
+#include <stdlib.h>
|
||||
#include "tunepimp.h"
|
||||
#include "mutex.h"
|
14
audio/libtunepimp/patches/patch-ai
Normal file
14
audio/libtunepimp/patches/patch-ai
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ai,v 1.1 2011/01/29 21:15:11 markd Exp $
|
||||
|
||||
fix build with gcc4.3
|
||||
|
||||
--- lib/readmeta.cpp.orig 2006-11-18 10:52:33.000000000 +0000
|
||||
+++ lib/readmeta.cpp
|
||||
@@ -31,6 +31,7 @@
|
||||
#endif
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#ifndef WIN32
|
||||
#include <unistd.h>
|
||||
#endif
|
25
audio/libtunepimp/patches/patch-aj
Normal file
25
audio/libtunepimp/patches/patch-aj
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-aj,v 1.1 2011/01/29 21:15:11 markd Exp $
|
||||
|
||||
fix build with gcc4.3
|
||||
|
||||
--- lib/fileio.cpp.orig 2006-11-18 10:52:33.000000000 +0000
|
||||
+++ lib/fileio.cpp
|
||||
@@ -27,6 +27,8 @@
|
||||
|
||||
#include <assert.h>
|
||||
#include <errno.h>
|
||||
+#include <stdlib.h>
|
||||
+#include <string.h>
|
||||
#include <string>
|
||||
#ifndef WIN32
|
||||
#include <unistd.h>
|
||||
@@ -122,7 +124,8 @@ int taccess(const char *pathname, int mo
|
||||
|
||||
void tmktempname(const char *path, char *newPath, int newPathLen)
|
||||
{
|
||||
- char *ptr, *temp;
|
||||
+ const char *ptr;
|
||||
+ char *temp;
|
||||
|
||||
temp = (char *)malloc(strlen(path) + 32);
|
||||
ptr = strrchr(path, dirSepChar);
|
14
audio/libtunepimp/patches/patch-ak
Normal file
14
audio/libtunepimp/patches/patch-ak
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ak,v 1.1 2011/01/29 21:15:11 markd Exp $
|
||||
|
||||
fix build with gcc4.3
|
||||
|
||||
--- plugins/mp3/id3_meta.cpp.orig 2006-11-18 10:51:07.000000000 +0000
|
||||
+++ plugins/mp3/id3_meta.cpp
|
||||
@@ -26,6 +26,7 @@
|
||||
----------------------------------------------------------------------------*/
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <time.h>
|
||||
#include <ctype.h>
|
||||
#include <musicbrainz/mb_c.h>
|
14
audio/libtunepimp/patches/patch-al
Normal file
14
audio/libtunepimp/patches/patch-al
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-al,v 1.1 2011/01/29 21:15:11 markd Exp $
|
||||
|
||||
fix build with gcc4.3
|
||||
|
||||
--- plugins/mp3/id3_2_3_meta.cpp.orig 2006-11-18 10:51:07.000000000 +0000
|
||||
+++ plugins/mp3/id3_2_3_meta.cpp
|
||||
@@ -26,6 +26,7 @@
|
||||
----------------------------------------------------------------------------*/
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <assert.h>
|
||||
#include <ctype.h>
|
||||
#include <musicbrainz/mb_c.h>
|
14
audio/libtunepimp/patches/patch-am
Normal file
14
audio/libtunepimp/patches/patch-am
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-am,v 1.1 2011/01/29 21:15:11 markd Exp $
|
||||
|
||||
fix build with gcc4.3
|
||||
|
||||
--- plugins/wma/wma.cpp.orig 2006-11-18 10:51:28.000000000 +0000
|
||||
+++ plugins/wma/wma.cpp
|
||||
@@ -27,6 +27,7 @@
|
||||
|
||||
#include <string.h>
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <wmafile.h>
|
||||
#include "metadata.h"
|
||||
#include "plugin.h"
|
14
audio/libtunepimp/patches/patch-an
Normal file
14
audio/libtunepimp/patches/patch-an
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-an,v 1.1 2011/01/29 21:15:11 markd Exp $
|
||||
|
||||
fix build with gcc4.3
|
||||
|
||||
--- plugins/wma/wmafile.cpp.orig 2006-11-18 10:51:28.000000000 +0000
|
||||
+++ plugins/wma/wmafile.cpp
|
||||
@@ -19,6 +19,7 @@
|
||||
* USA *
|
||||
***************************************************************************/
|
||||
|
||||
+#include <string.h>
|
||||
#include <tstring.h>
|
||||
#include <wmafile.h>
|
||||
#include <wmatag.h>
|
14
audio/libtunepimp/patches/patch-ao
Normal file
14
audio/libtunepimp/patches/patch-ao
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ao,v 1.1 2011/01/29 21:15:11 markd Exp $
|
||||
|
||||
fix build with gcc4.3
|
||||
|
||||
--- include/tunepimp-0.5/metadata.h.orig 2006-11-18 10:52:08.000000000 +0000
|
||||
+++ include/tunepimp-0.5/metadata.h
|
||||
@@ -27,6 +27,7 @@
|
||||
#ifndef __METADATA_H__
|
||||
#define __METADATA_H__
|
||||
|
||||
+#include <string.h>
|
||||
#include <string>
|
||||
#include <cstdio>
|
||||
|
16
audio/libtunepimp/patches/patch-ap
Normal file
16
audio/libtunepimp/patches/patch-ap
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ap,v 1.1 2011/01/29 21:15:11 markd Exp $
|
||||
|
||||
fix build with gcc4.3
|
||||
|
||||
--- lib/tunepimp.cpp.orig 2006-11-18 10:52:33.000000000 +0000
|
||||
+++ lib/tunepimp.cpp
|
||||
@@ -30,7 +30,9 @@
|
||||
#endif
|
||||
#endif
|
||||
|
||||
+#include <string.h>
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <map>
|
||||
using namespace std;
|
||||
|
Loading…
Reference in a new issue