Fix PR#36236
This commit is contained in:
parent
a32e1d3558
commit
fd4788e79c
5 changed files with 61 additions and 14 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.11 2006/02/05 23:11:16 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2007/10/11 21:26:10 adam Exp $
|
||||
|
||||
PKGNAME= wmx-${WMX_VERS}
|
||||
PKGREVISION= 2
|
||||
PKGREVISION= 3
|
||||
COMMENT= Another X11 window manager based on wm2
|
||||
|
||||
.include "../../wm/wmx/Makefile.common"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.common,v 1.19 2006/12/27 13:37:42 joerg Exp $
|
||||
# $NetBSD: Makefile.common,v 1.20 2007/10/11 21:26:10 adam Exp $
|
||||
|
||||
DISTNAME= wmx-6
|
||||
WMX_VERS= 6.0
|
||||
|
@ -12,25 +12,25 @@ CONFLICTS+= wmx-[0-9]* wmx-gnome-[0-9]*
|
|||
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
|
||||
USE_LANGUAGES= c c++
|
||||
USE_X11BASE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
BUILD_TARGET= depend all
|
||||
USE_LANGUAGES= c c++
|
||||
USE_X11BASE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
BUILD_TARGET= depend all
|
||||
|
||||
DISTINFO_FILE= ${.CURDIR}/../../wm/wmx/distinfo
|
||||
PATCHDIR= ${.CURDIR}/../../wm/wmx/patches
|
||||
PLIST_SRC= ${.CURDIR}/../../wm/wmx/PLIST
|
||||
DISTINFO_FILE= ${.CURDIR}/../../wm/wmx/distinfo
|
||||
PATCHDIR= ${.CURDIR}/../../wm/wmx/patches
|
||||
PLIST_SRC= ${.CURDIR}/../../wm/wmx/PLIST
|
||||
|
||||
INSTALLATION_DIRS= bin
|
||||
INSTALLATION_DIRS+= etc/wmx
|
||||
INSTALLATION_DIRS+= share/doc/wmx
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/wmx ${PREFIX}/bin
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/wmx
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/wmx
|
||||
${INSTALL_DATA} ${WRKSRC}/README.contrib ${PREFIX}/share/doc/wmx
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/etc/wmx
|
||||
|
||||
BUILDLINK_DEPMETHOD.libXt?= build
|
||||
BUILDLINK_DEPMETHOD.libXt+= build
|
||||
|
||||
.include "../../x11/libXext/buildlink3.mk"
|
||||
.include "../../x11/libXpm/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.11 2006/12/27 13:37:42 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.12 2007/10/11 21:26:11 adam Exp $
|
||||
|
||||
SHA1 (wmx-6.tar.gz) = 89563c8c2af1d3ffbee06197928123fd03ae9c54
|
||||
RMD160 (wmx-6.tar.gz) = 871c0de0ddd30ed90cc8f7eae287fa62177142c4
|
||||
|
@ -10,3 +10,5 @@ SHA1 (patch-ad) = b4b66989ecfe0dc535abae38ddbbc271200d0c19
|
|||
SHA1 (patch-ae) = 20f155c556fd06d2cf721ab0620a0c5334b6ace4
|
||||
SHA1 (patch-af) = 84faece4f23af6d51aa8a87a28da2f5056101113
|
||||
SHA1 (patch-ag) = 6b69f800da04ec83fcf40ae6b00ebacdfec193f8
|
||||
SHA1 (patch-ah) = 10fdca5e6aeb823cb5291c65ca41344c05e882ed
|
||||
SHA1 (patch-ai) = 2247d741c96c93a3140142bd797f1d2ad0fff94c
|
||||
|
|
13
wm/wmx/patches/patch-ah
Normal file
13
wm/wmx/patches/patch-ah
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ah,v 1.1 2007/10/11 21:26:11 adam Exp $
|
||||
|
||||
--- Client.h.orig 2000-05-12 09:40:20.000000000 +0200
|
||||
+++ Client.h
|
||||
@@ -184,8 +184,6 @@ private:
|
||||
WindowManager *const m_windowManager;
|
||||
|
||||
char *getProperty(Atom);
|
||||
- int getAtomProperty(Atom, Atom);
|
||||
- int getIntegerProperty(Atom);
|
||||
|
||||
// accessors
|
||||
Boolean getState(int *);
|
32
wm/wmx/patches/patch-ai
Normal file
32
wm/wmx/patches/patch-ai
Normal file
|
@ -0,0 +1,32 @@
|
|||
$NetBSD: patch-ai,v 1.1 2007/10/11 21:26:11 adam Exp $
|
||||
|
||||
--- Client.C.orig 2000-05-12 09:40:20.000000000 +0200
|
||||
+++ Client.C
|
||||
@@ -662,27 +662,6 @@ char *Client::getProperty(Atom a)
|
||||
return (char *)p;
|
||||
}
|
||||
|
||||
-
|
||||
-int Client::getAtomProperty(Atom a, Atom type)
|
||||
-{
|
||||
- char **p, *x;
|
||||
- if (getProperty_aux(display(), m_window, a, type, 1L,
|
||||
- (unsigned char **)&p) <= 0) {
|
||||
- return 0;
|
||||
- }
|
||||
-
|
||||
- x = *p;
|
||||
- XFree((void *)p);
|
||||
- return (int)x;
|
||||
-}
|
||||
-
|
||||
-
|
||||
-int Client::getIntegerProperty(Atom a)
|
||||
-{
|
||||
- return getAtomProperty(a, XA_INTEGER);
|
||||
-}
|
||||
-
|
||||
-
|
||||
void Client::setState(int state)
|
||||
{
|
||||
m_state = state;
|
Loading…
Reference in a new issue