Update MCSim to version 5.4.0
Changes are unknown, changelog is unavailable.
This commit is contained in:
parent
a53ca6c50b
commit
fd643aa082
10 changed files with 110 additions and 488 deletions
|
@ -1,33 +1,23 @@
|
|||
# $NetBSD: Makefile,v 1.19 2008/03/04 18:12:59 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.20 2011/05/09 20:59:10 asau Exp $
|
||||
|
||||
DISTNAME= mcsim-4.2.0
|
||||
DISTNAME= mcsim-5.4.0
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=mcsim/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.gnu.org/software/mcsim
|
||||
COMMENT= Monte Carlo Simulation software
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= makeinfo
|
||||
INFO_FILES= # PLIST
|
||||
WRKSRC= ${WRKDIR}/mcsim
|
||||
|
||||
INSTALLATION_DIRS= bin ${PKGINFODIR} share/doc/mcsim share/doc/html/mcsim
|
||||
REPLACE_SH= sim/makemcsim.in sim/makemcsimd.in sim/makemcsims.in
|
||||
|
||||
post-build:
|
||||
cd ${WRKSRC}/doc && makeinfo mcsim.texinfo
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/mod/mod ${DESTDIR}${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/sim/mcsim ${DESTDIR}${PREFIX}/bin
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/*.txt ${WRKSRC}/doc/MCSim* \
|
||||
${WRKSRC}/doc/mcsim.dvi ${DESTDIR}${PREFIX}/share/doc/mcsim/
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/mcsim.html \
|
||||
${DESTDIR}${PREFIX}/share/doc/html/mcsim
|
||||
cd ${WRKSRC}/doc; for f in mcsim mcsim-[0-9]*; do \
|
||||
${TEST} ! -f "$$f" || \
|
||||
${INSTALL_DATA} "$$f" ${DESTDIR}${PREFIX}/${PKGINFODIR};\
|
||||
done
|
||||
TEST_TARGET= check
|
||||
|
||||
.include "../../math/gsl/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,13 +1,85 @@
|
|||
@comment $NetBSD: PLIST,v 1.6 2009/06/14 18:05:45 joerg Exp $
|
||||
bin/mcsim
|
||||
@comment $NetBSD: PLIST,v 1.7 2011/05/09 20:59:10 asau Exp $
|
||||
bin/makemcsim
|
||||
bin/makemcsimd
|
||||
bin/makemcsims
|
||||
bin/mod
|
||||
info/mcsim
|
||||
share/doc/html/mcsim/mcsim.html
|
||||
share/doc/mcsim/About-Datasets.txt
|
||||
share/doc/mcsim/About-Doc.txt
|
||||
share/doc/mcsim/About-MCSim.txt
|
||||
share/doc/mcsim/MCSim-changelog
|
||||
share/doc/mcsim/MCSim-to-do
|
||||
share/doc/mcsim/Manual-Update.txt
|
||||
share/doc/mcsim/Programming-notes.txt
|
||||
share/doc/mcsim/mcsim.dvi
|
||||
include/config.h
|
||||
include/hungtype.h
|
||||
include/lex.h
|
||||
include/lexfn.h
|
||||
include/list.h
|
||||
include/matutil.h
|
||||
include/modelu.h
|
||||
include/modiface.h
|
||||
include/random.h
|
||||
include/sim.h
|
||||
include/yourcode.h
|
||||
info/mcsim.info
|
||||
lib/libmcsim.la
|
||||
lib/libmodelu.la
|
||||
share/mcsim/doc/mcsim.pdf
|
||||
share/mcsim/doc/mcsim.ps
|
||||
share/mcsim/mod/getopt.c
|
||||
share/mcsim/mod/getopt.h
|
||||
share/mcsim/mod/hungtype.h
|
||||
share/mcsim/mod/lex.c
|
||||
share/mcsim/mod/lex.h
|
||||
share/mcsim/mod/lexerr.c
|
||||
share/mcsim/mod/lexerr.h
|
||||
share/mcsim/mod/lexfn.c
|
||||
share/mcsim/mod/lexfn.h
|
||||
share/mcsim/mod/mod.c
|
||||
share/mcsim/mod/mod.h
|
||||
share/mcsim/mod/modd.c
|
||||
share/mcsim/mod/modd.h
|
||||
share/mcsim/mod/modi.c
|
||||
share/mcsim/mod/modi.h
|
||||
share/mcsim/mod/modiSBML.c
|
||||
share/mcsim/mod/modiSBML.h
|
||||
share/mcsim/mod/modiSBML2.c
|
||||
share/mcsim/mod/modiface.h
|
||||
share/mcsim/mod/modo.c
|
||||
share/mcsim/mod/modo.h
|
||||
share/mcsim/mod/strutil.c
|
||||
share/mcsim/mod/strutil.h
|
||||
share/mcsim/sim/getopt.c
|
||||
share/mcsim/sim/getopt.h
|
||||
share/mcsim/sim/hungtype.h
|
||||
share/mcsim/sim/lex.c
|
||||
share/mcsim/sim/lex.h
|
||||
share/mcsim/sim/lexerr.c
|
||||
share/mcsim/sim/lexerr.h
|
||||
share/mcsim/sim/lexfn.c
|
||||
share/mcsim/sim/lexfn.h
|
||||
share/mcsim/sim/list.c
|
||||
share/mcsim/sim/list.h
|
||||
share/mcsim/sim/lsodes.h
|
||||
share/mcsim/sim/lsodes1.c
|
||||
share/mcsim/sim/lsodes2.c
|
||||
share/mcsim/sim/matutil.c
|
||||
share/mcsim/sim/matutil.h
|
||||
share/mcsim/sim/matutilo.c
|
||||
share/mcsim/sim/matutilo.h
|
||||
share/mcsim/sim/mh.c
|
||||
share/mcsim/sim/mh.h
|
||||
share/mcsim/sim/modelu.c
|
||||
share/mcsim/sim/modelu.h
|
||||
share/mcsim/sim/modiface.h
|
||||
share/mcsim/sim/optdsign.c
|
||||
share/mcsim/sim/optdsign.h
|
||||
share/mcsim/sim/random.c
|
||||
share/mcsim/sim/random.h
|
||||
share/mcsim/sim/sim.c
|
||||
share/mcsim/sim/sim.h
|
||||
share/mcsim/sim/simi.c
|
||||
share/mcsim/sim/simi.h
|
||||
share/mcsim/sim/siminit.c
|
||||
share/mcsim/sim/siminit.h
|
||||
share/mcsim/sim/simmonte.c
|
||||
share/mcsim/sim/simmonte.h
|
||||
share/mcsim/sim/simo.c
|
||||
share/mcsim/sim/simo.h
|
||||
share/mcsim/sim/strutil.c
|
||||
share/mcsim/sim/strutil.h
|
||||
share/mcsim/sim/yourcode.c
|
||||
share/mcsim/sim/yourcode.h
|
||||
|
|
|
@ -1,11 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.3 2005/02/23 12:06:56 agc Exp $
|
||||
$NetBSD: distinfo,v 1.4 2011/05/09 20:59:10 asau Exp $
|
||||
|
||||
SHA1 (mcsim-4.2.0.tar.gz) = 2ad29254cf40bb4ddadfc915e23e5d0eec90e2af
|
||||
RMD160 (mcsim-4.2.0.tar.gz) = 258884ed23500b1ee05c82012375595acf2e7e49
|
||||
Size (mcsim-4.2.0.tar.gz) = 521646 bytes
|
||||
SHA1 (patch-aa) = 993abbc45444214bf626eb2d41939860ae365e6c
|
||||
SHA1 (patch-ab) = 4d4d73af09fc96373c2255ff4a6a47bc3e556f27
|
||||
SHA1 (patch-ac) = a43fc2826a5b818579a536f5155b799001d180f8
|
||||
SHA1 (patch-ad) = 98e453e77d6b403464e3dfabfa84a4fa5992b3ad
|
||||
SHA1 (patch-ae) = 819a304489151e2f4c92f70e9425cd85da936daf
|
||||
SHA1 (patch-af) = cd2990081687b81e21af53379a8f682040ada0dd
|
||||
SHA1 (mcsim-5.4.0.tar.gz) = 63a9b9fd22869f49bb92dbbf5e90e8320571b8a1
|
||||
RMD160 (mcsim-5.4.0.tar.gz) = 7294cdac918fef2e0e52b4e0c226492af7423fd2
|
||||
Size (mcsim-5.4.0.tar.gz) = 1840057 bytes
|
||||
SHA1 (patch-Makefile.in) = 9d4e0a8b716d41a6e9c046909bc69ec8ff2a9749
|
||||
|
|
13
math/mcsim/patches/patch-Makefile.in
Normal file
13
math/mcsim/patches/patch-Makefile.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-Makefile.in,v 1.1 2011/05/09 20:59:10 asau Exp $
|
||||
|
||||
--- Makefile.in.orig 2011-01-29 15:52:31.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -481,7 +481,7 @@ check-TESTS: $(TESTS)
|
||||
if test -f ./$$tst; then dir=./; \
|
||||
elif test -f $$tst; then dir=; \
|
||||
else dir="$(srcdir)/"; fi; \
|
||||
- if $(TESTS_ENVIRONMENT) $${dir}$$tst; then \
|
||||
+ if $(TESTS_ENVIRONMENT) $(SHELL) $${dir}$$tst; then \
|
||||
all=`expr $$all + 1`; \
|
||||
case " $(XFAIL_TESTS) " in \
|
||||
*[\ \ ]$$tst[\ \ ]*) \
|
|
@ -1,20 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2000/11/26 23:02:38 jtb Exp $
|
||||
|
||||
--- doc/mcsim.texinfo.orig Sat Nov 15 02:14:40 1997
|
||||
+++ doc/mcsim.texinfo
|
||||
@@ -1,10 +1,14 @@
|
||||
\input texinfo @c -*-texinfo-*-
|
||||
@comment %**start of header (This is for running Texinfo on a region.)
|
||||
-@setfilename mcsimdoc
|
||||
+@setfilename mcsim
|
||||
@settitle MCSim User' Manual
|
||||
@setchapternewpage odd
|
||||
@comment %**end of header (This is for running Texinfo on a region.)
|
||||
|
||||
+@dircategory Monte Carlo Simulation
|
||||
+@direntry
|
||||
+* MCSim: (mcsim). A Monte Carlo Simulation Program.
|
||||
+@end direntry
|
||||
|
||||
@comment the following is just for the texinfo file
|
||||
@ifinfo
|
|
@ -1,70 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.2 2001/02/25 22:14:20 jtb Exp $
|
||||
|
||||
--- mod/Makefile.orig Thu Mar 6 16:14:37 1997
|
||||
+++ mod/Makefile
|
||||
@@ -77,16 +77,16 @@
|
||||
# `realclean' removes other stuff not distributed
|
||||
#
|
||||
|
||||
-
|
||||
+all: mod
|
||||
|
||||
#---------- System Calls ----------
|
||||
#
|
||||
#>>>> Define any system dependent calls here
|
||||
|
||||
-ECHO = echo
|
||||
-COPY = cp
|
||||
-DEL = rm
|
||||
-MKDIR = mkdir
|
||||
+ECHO ?= echo
|
||||
+COPY ?= cp
|
||||
+DEL ?= rm -f
|
||||
+MKDIR ?= mkdir
|
||||
ARC = tar
|
||||
ARCFLAGS = cvf
|
||||
MOD = mod
|
||||
@@ -97,8 +97,8 @@
|
||||
#
|
||||
#>>>> Define the COMPILER name and LINKER name here only.
|
||||
|
||||
-CC = gcc
|
||||
-LINK = gcc
|
||||
+#CC =
|
||||
+LINK = $(CC)
|
||||
|
||||
#>>>> Define PATHS
|
||||
# The include path should be a directory containing header
|
||||
@@ -137,27 +137,27 @@
|
||||
#>>>> To compile with OPTIMIZATION uncomment the following lines
|
||||
#
|
||||
DEBUG_SYMBOLS = -DNDEBUG
|
||||
-C_OPTIM_FLAG = -O
|
||||
+C_OPTIM_FLAG =
|
||||
L_OPTIM_FLAG =
|
||||
|
||||
#
|
||||
#>>>> Include any special warning flags
|
||||
#
|
||||
-WARNINGS = -Wall
|
||||
+WARNINGS = -ansi
|
||||
|
||||
#--------------------
|
||||
#**** You shouldn't need to change these lines. They are dependent
|
||||
#**** only on the above setup.
|
||||
|
||||
-CFLAGS = $(C_OPTIM_FLAG) $(C_DEBUG_FLAG) $(DEBUG_SYMBOLS) \
|
||||
+CFLAGS += $(C_OPTIM_FLAG) $(C_DEBUG_FLAG) $(DEBUG_SYMBOLS) \
|
||||
-I $(INCPATH) $(WARNINGS) -DMODGEN
|
||||
-CLFLAGS = $(L_OPTIM_FLAG) $(L_DEBUG_FLAG)
|
||||
+CLFLAGS += $(L_OPTIM_FLAG) $(L_DEBUG_FLAG)
|
||||
|
||||
|
||||
#
|
||||
#>>>> Extra link flags. Include libraries here
|
||||
#
|
||||
-LFLAGS = -lm
|
||||
+LFLAGS += -lm
|
||||
|
||||
|
||||
|
|
@ -1,69 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.2 2001/02/25 22:14:20 jtb Exp $
|
||||
|
||||
--- sim/Makefile.orig Fri Nov 14 15:45:53 1997
|
||||
+++ sim/Makefile
|
||||
@@ -46,14 +46,16 @@
|
||||
# LFLAGS : any flags specific to the linker.
|
||||
#
|
||||
|
||||
+all: mcsim
|
||||
+
|
||||
#---------- System Calls ----------
|
||||
#
|
||||
#>>>> Define any system dependent calls here
|
||||
|
||||
-ECHO = echo
|
||||
-COPY = cp
|
||||
-DEL = rm
|
||||
-MKDIR = mkdir
|
||||
+ECHO ?= echo
|
||||
+COPY ?= cp
|
||||
+DEL ?= rm
|
||||
+MKDIR ?= mkdir
|
||||
MOD = mod
|
||||
|
||||
|
||||
@@ -62,8 +64,8 @@
|
||||
#
|
||||
#>>>> Define the COMPILER name and LINKER name here only.
|
||||
|
||||
-CC = gcc
|
||||
-LINK = gcc
|
||||
+#CC = gcc
|
||||
+LINK = $(CC)
|
||||
|
||||
#>>>> Define PATHS
|
||||
# The include path should be a directory containing header
|
||||
@@ -101,27 +103,27 @@
|
||||
#>>>> To compile with OPTIMIZATION uncomment the following lines
|
||||
#
|
||||
DEBUG_SYMBOLS = -DNDEBUG
|
||||
-C_OPTIM_FLAG = -O
|
||||
+C_OPTIM_FLAG =
|
||||
L_OPTIM_FLAG =
|
||||
|
||||
#
|
||||
#>>>> Include any special warning flags
|
||||
#
|
||||
-WARNINGS = -Wall -ansi
|
||||
+WARNINGS = -ansi
|
||||
|
||||
#--------------------
|
||||
#**** You shouldn't need to change the next 2 lines. They are dependent
|
||||
#**** only on the above setup.
|
||||
|
||||
-CFLAGS = $(C_OPTIM_FLAG) $(C_DEBUG_FLAG) $(DEBUG_SYMBOLS) \
|
||||
+CFLAGS += $(C_OPTIM_FLAG) $(C_DEBUG_FLAG) $(DEBUG_SYMBOLS) \
|
||||
-I $(INCPATH) $(WARNINGS)
|
||||
-CLFLAGS = $(L_OPTIM_FLAG) $(L_DEBUG_FLAG)
|
||||
+CLFLAGS += $(L_OPTIM_FLAG) $(L_DEBUG_FLAG)
|
||||
|
||||
|
||||
#
|
||||
#>>>> Extra link flags. Include libraries here
|
||||
#
|
||||
-LFLAGS = -lm
|
||||
+LFLAGS += -lm
|
||||
|
||||
|
||||
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.2 2001/02/25 22:14:20 jtb Exp $
|
||||
|
||||
--- sim/sim.c.orig Wed Nov 22 22:45:45 2000
|
||||
+++ sim/sim.c
|
||||
@@ -653,7 +653,7 @@
|
||||
scanf ("%[^:\f\r\v\n]", *pszFileIn);
|
||||
getchar();
|
||||
#else
|
||||
- gets (*pszFileIn);
|
||||
+ fgets (*pszFileIn, sizeof(*pszFileIn), stdin);
|
||||
*pszFileIn = strtok (*pszFileIn, " \t");
|
||||
#endif
|
||||
|
||||
@@ -665,7 +665,7 @@
|
||||
#ifdef _MACOSLEVEL1_
|
||||
scanf ("%[^:\f\r\v\n]", *pszFileOut);
|
||||
#else
|
||||
- gets (*pszFileOut);
|
||||
+ fgets (*pszFileOut, sizeof(*pszFileOut), stdin);
|
||||
*pszFileOut = strtok (*pszFileOut, " \t");
|
||||
#endif
|
||||
}
|
|
@ -1,259 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.1.1.1 2000/11/26 23:02:41 jtb Exp $
|
||||
|
||||
--- sim/Test_mcsim.orig Fri Nov 14 15:45:56 1997
|
||||
+++ sim/Test_mcsim
|
||||
@@ -1,147 +1,147 @@
|
||||
# Run diagnostic tests on several features of the program.
|
||||
# results are compared to prepared files.
|
||||
-one:
|
||||
- @echo
|
||||
- @echo ----------
|
||||
- @echo
|
||||
- @echo '* Testing MCSim: this could take a few minutes.'
|
||||
- @echo '* Creating logfile mcsim.log'
|
||||
- @touch mcsim.log
|
||||
- @date >> mcsim.log
|
||||
-#
|
||||
- @echo
|
||||
- @echo ----------
|
||||
- @echo
|
||||
- @echo Testing with the tetrachloroethylene model
|
||||
- @mod perc.model
|
||||
- @gcc -I . -Wall -ansi -c model.c -o model.o > /dev/null
|
||||
- @gcc -o mcsim *.o -lm
|
||||
- @echo
|
||||
+#one:
|
||||
+ echo
|
||||
+ echo ----------
|
||||
+ echo
|
||||
+ echo '* Testing MCSim: this could take a few minutes.'
|
||||
+ echo '* Creating logfile mcsim.log'
|
||||
+ touch mcsim.log
|
||||
+ date >> mcsim.log
|
||||
+#
|
||||
+ echo
|
||||
+ echo ----------
|
||||
+ echo
|
||||
+ echo Testing with the tetrachloroethylene model
|
||||
+ ../mod/mod perc.model
|
||||
+ cc -I . -Wall -ansi -c model.c -o model.o > /dev/null
|
||||
+ cc -o mcsim *.o -lm
|
||||
+ echo
|
||||
#
|
||||
# perc.lsodes.in
|
||||
- @echo Testing Lsodes with perc.lsodes.in ...
|
||||
- @chmod -w perc.lsodes.in perc.lsodes.out
|
||||
- @mcsim perc.lsodes.in sim.out >> mcsim.log
|
||||
- @(diff sim.out perc.lsodes.out > .tmp) && echo '-PASSED-'
|
||||
+ echo Testing Lsodes with perc.lsodes.in ...
|
||||
+ chmod -w perc.lsodes.in perc.lsodes.out
|
||||
+ ./mcsim perc.lsodes.in sim.out >> mcsim.log
|
||||
+ (diff sim.out perc.lsodes.out > .tmp) && echo '-PASSED-'
|
||||
#
|
||||
# perc.ndoses.in
|
||||
- @echo Testing NDoses with perc.ndoses.in ...
|
||||
- @chmod -w perc.ndoses.in perc.ndoses.out
|
||||
- @mcsim perc.ndoses.in sim.out >> mcsim.log
|
||||
- @(diff sim.out perc.ndoses.out > .tmp) && echo '-PASSED-'
|
||||
+ echo Testing NDoses with perc.ndoses.in ...
|
||||
+ chmod -w perc.ndoses.in perc.ndoses.out
|
||||
+ ./mcsim perc.ndoses.in sim.out >> mcsim.log
|
||||
+ (diff sim.out perc.ndoses.out > .tmp) && echo '-PASSED-'
|
||||
#
|
||||
# perc.mtc.in
|
||||
- @echo Testing Monte Carlo with perc.mtc.in ...
|
||||
- @chmod -w perc.mtc.in perc.mtc.out
|
||||
- @mcsim perc.mtc.in sim.out >> mcsim.log
|
||||
- @(diff sim.out perc.mtc.out > .tmp) && echo '-PASSED-'
|
||||
+ echo Testing Monte Carlo with perc.mtc.in ...
|
||||
+ chmod -w perc.mtc.in perc.mtc.out
|
||||
+ ./mcsim perc.mtc.in sim.out >> mcsim.log
|
||||
+ (diff sim.out perc.mtc.out > .tmp) && echo '-PASSED-'
|
||||
#
|
||||
# perc.setpoint.in
|
||||
- @echo Testing Set Point run with perc.setpoint.in ...
|
||||
- @chmod -w perc.setpoint.dat perc.setpoint.in perc.setpoint.out
|
||||
- @mcsim perc.setpoint.in sim.out >> mcsim.log
|
||||
- @(diff sim.out perc.setpoint.out > .tmp) && echo '-PASSED-'
|
||||
-#
|
||||
- @echo
|
||||
- @echo ----------
|
||||
- @echo
|
||||
- @echo Testing with the 1 compartment model
|
||||
- @mod 1cpt.model
|
||||
- @gcc -I . -Wall -ansi -c model.c -o model.o > /dev/null
|
||||
- @gcc -o mcsim *.o -lm
|
||||
- @echo
|
||||
+ echo Testing Set Point run with perc.setpoint.in ...
|
||||
+ chmod -w perc.setpoint.dat perc.setpoint.in perc.setpoint.out
|
||||
+ ./mcsim perc.setpoint.in sim.out >> mcsim.log
|
||||
+ (diff sim.out perc.setpoint.out > .tmp) && echo '-PASSED-'
|
||||
+#
|
||||
+ echo
|
||||
+ echo ----------
|
||||
+ echo
|
||||
+ echo Testing with the 1 compartment model
|
||||
+ ../mod/mod 1cpt.model
|
||||
+ cc -I . -Wall -ansi -c model.c -o model.o > /dev/null
|
||||
+ cc -o mcsim *.o -lm
|
||||
+ echo
|
||||
#
|
||||
# 1cpt_no_noise.in
|
||||
- @echo Testing Lsodes non random output with 1cpt_no_noise.in ...
|
||||
- @chmod -w 1cpt_no_noise.in 1cpt_no_noise.out
|
||||
- @mcsim 1cpt_no_noise.in sim.out >> mcsim.log
|
||||
- @(diff sim.out 1cpt_no_noise.out > .tmp) && echo '-PASSED-'
|
||||
+ echo Testing Lsodes non random output with 1cpt_no_noise.in ...
|
||||
+ chmod -w 1cpt_no_noise.in 1cpt_no_noise.out
|
||||
+ ./mcsim 1cpt_no_noise.in sim.out >> mcsim.log
|
||||
+ (diff sim.out 1cpt_no_noise.out > .tmp) && echo '-PASSED-'
|
||||
#
|
||||
# 1cpt_w._noise.in
|
||||
- @echo Testing Lsodes randomized output with 1cpt_w._noise.in ...
|
||||
- @chmod -w 1cpt_w._noise.in 1cpt_w._noise.out
|
||||
- @mcsim 1cpt_w._noise.in sim.out >> mcsim.log
|
||||
- @(diff sim.out 1cpt_w._noise.out > .tmp) && echo '-PASSED-'
|
||||
+ echo Testing Lsodes randomized output with 1cpt_w._noise.in ...
|
||||
+ chmod -w 1cpt_w._noise.in 1cpt_w._noise.out
|
||||
+ ./mcsim 1cpt_w._noise.in sim.out >> mcsim.log
|
||||
+ (diff sim.out 1cpt_w._noise.out > .tmp) && echo '-PASSED-'
|
||||
#
|
||||
# 1cpt.MCMC1.in
|
||||
- @echo Testing MCMC set uncertainties with 1cpt.MCMC1.in ...
|
||||
- @chmod -w 1cpt.MCMC1.in 1cpt.MCMC1.out
|
||||
- @mcsim 1cpt.MCMC1.in sim.out >> mcsim.log
|
||||
- @(diff sim.out 1cpt.MCMC1.out > .tmp) && echo '-PASSED-'
|
||||
+ echo Testing MCMC set uncertainties with 1cpt.MCMC1.in ...
|
||||
+ chmod -w 1cpt.MCMC1.in 1cpt.MCMC1.out
|
||||
+ ./mcsim 1cpt.MCMC1.in sim.out >> mcsim.log
|
||||
+ (diff sim.out 1cpt.MCMC1.out > .tmp) && echo '-PASSED-'
|
||||
#
|
||||
# 1cpt.MCMC2.in
|
||||
- @echo Testing MCMC estimated uncertainties with 1cpt.MCMC2.in ...
|
||||
- @chmod -w 1cpt.MCMC2.in 1cpt.MCMC2.out
|
||||
- @mcsim 1cpt.MCMC2.in sim.out >> mcsim.log
|
||||
- @(diff sim.out 1cpt.MCMC2.out > .tmp) && echo '-PASSED-'
|
||||
+ echo Testing MCMC estimated uncertainties with 1cpt.MCMC2.in ...
|
||||
+ chmod -w 1cpt.MCMC2.in 1cpt.MCMC2.out
|
||||
+ ./mcsim 1cpt.MCMC2.in sim.out >> mcsim.log
|
||||
+ (diff sim.out 1cpt.MCMC2.out > .tmp) && echo '-PASSED-'
|
||||
#
|
||||
# 1cpt.MCMC3.in
|
||||
- @echo Testing MCMC print every 2 iterations with 1cpt.MCMC3.in ...
|
||||
- @chmod -w 1cpt.MCMC3.in 1cpt.MCMC3.out
|
||||
- @mcsim 1cpt.MCMC3.in sim.out >> mcsim.log
|
||||
- @(diff sim.out 1cpt.MCMC3.out > .tmp) && echo '-PASSED-'
|
||||
+ echo Testing MCMC print every 2 iterations with 1cpt.MCMC3.in ...
|
||||
+ chmod -w 1cpt.MCMC3.in 1cpt.MCMC3.out
|
||||
+ ./mcsim 1cpt.MCMC3.in sim.out >> mcsim.log
|
||||
+ (diff sim.out 1cpt.MCMC3.out > .tmp) && echo '-PASSED-'
|
||||
#
|
||||
# 1cpt.MCMC4.in
|
||||
- @echo Testing MCMC estimated bounds on F with 1cpt.MCMC4.in ...
|
||||
- @chmod -w 1cpt.MCMC4.in 1cpt.MCMC4.out
|
||||
- @mcsim 1cpt.MCMC4.in sim.out >> mcsim.log
|
||||
- @(diff sim.out 1cpt.MCMC4.out > .tmp) && echo '-PASSED-'
|
||||
+ echo Testing MCMC estimated bounds on F with 1cpt.MCMC4.in ...
|
||||
+ chmod -w 1cpt.MCMC4.in 1cpt.MCMC4.out
|
||||
+ ./mcsim 1cpt.MCMC4.in sim.out >> mcsim.log
|
||||
+ (diff sim.out 1cpt.MCMC4.out > .tmp) && echo '-PASSED-'
|
||||
#
|
||||
# 1cpt.MCMC5.in
|
||||
- @echo Testing MCMC model-computed SDs with 1cpt.MCMC5.in ...
|
||||
- @chmod -w 1cpt.MCMC5.in 1cpt.MCMC5.out
|
||||
- @mcsim 1cpt.MCMC5.in sim.out >> mcsim.log
|
||||
- @(diff sim.out 1cpt.MCMC5.out > .tmp) && echo '-PASSED-'
|
||||
-#
|
||||
- @echo
|
||||
- @echo ----------
|
||||
- @echo
|
||||
- @echo Testing with the linear model
|
||||
- @mod linear.model
|
||||
- @gcc -I . -Wall -ansi -c model.c -o model.o > /dev/null
|
||||
- @gcc -o mcsim *.o -lm
|
||||
- @echo
|
||||
+ echo Testing MCMC model-computed SDs with 1cpt.MCMC5.in ...
|
||||
+ chmod -w 1cpt.MCMC5.in 1cpt.MCMC5.out
|
||||
+ ./mcsim 1cpt.MCMC5.in sim.out >> mcsim.log
|
||||
+ (diff sim.out 1cpt.MCMC5.out > .tmp) && echo '-PASSED-'
|
||||
+#
|
||||
+ echo
|
||||
+ echo ----------
|
||||
+ echo
|
||||
+ echo Testing with the linear model
|
||||
+ ../mod/mod linear.model
|
||||
+ cc -I . -Wall -ansi -c model.c -o model.o > /dev/null
|
||||
+ cc -o mcsim *.o -lm
|
||||
+ echo
|
||||
#
|
||||
# linear.in
|
||||
- @echo Testing Lsodes with linear.in ...
|
||||
- @chmod -w linear.in linear.out
|
||||
- @mcsim linear.in sim.out >> mcsim.log
|
||||
- @(diff sim.out linear.out > .tmp) && echo '-PASSED-'
|
||||
+ echo Testing Lsodes with linear.in ...
|
||||
+ chmod -w linear.in linear.out
|
||||
+ ./mcsim linear.in sim.out >> mcsim.log
|
||||
+ (diff sim.out linear.out > .tmp) && echo '-PASSED-'
|
||||
#
|
||||
# linear.MCMC1.in
|
||||
- @echo Testing MCMC 1 experiment with linear.MCMC1.in ...
|
||||
- @chmod -w linear.MCMC1.in linear.MCMC1.out
|
||||
- @mcsim linear.MCMC1.in sim.out >> mcsim.log
|
||||
- @(diff sim.out linear.MCMC1.out > .tmp) && echo '-PASSED-'
|
||||
+ echo Testing MCMC 1 experiment with linear.MCMC1.in ...
|
||||
+ chmod -w linear.MCMC1.in linear.MCMC1.out
|
||||
+ ./mcsim linear.MCMC1.in sim.out >> mcsim.log
|
||||
+ (diff sim.out linear.MCMC1.out > .tmp) && echo '-PASSED-'
|
||||
#
|
||||
# linear.MCMC2.in
|
||||
- @echo Testing MCMC 1 repeated experiment with linear.MCMC2.in ...
|
||||
- @chmod -w linear.MCMC2.in linear.MCMC2.out
|
||||
- @mcsim linear.MCMC2.in sim.out >> mcsim.log
|
||||
- @(diff sim.out linear.MCMC2.out > .tmp) && echo '-PASSED-'
|
||||
+ echo Testing MCMC 1 repeated experiment with linear.MCMC2.in ...
|
||||
+ chmod -w linear.MCMC2.in linear.MCMC2.out
|
||||
+ ./mcsim linear.MCMC2.in sim.out >> mcsim.log
|
||||
+ (diff sim.out linear.MCMC2.out > .tmp) && echo '-PASSED-'
|
||||
#
|
||||
# linear.H.MCMC1.in
|
||||
- @echo Testing MCMC hierarchical linear model, 10 exps with \
|
||||
+ echo Testing MCMC hierarchical linear model, 10 exps with \
|
||||
linear.H.MCMC1.in ...
|
||||
- @chmod -w linear.H.MCMC1.in linear.H.MCMC1.out
|
||||
- @mcsim linear.H.MCMC1.in sim.out >> mcsim.log
|
||||
- @(diff sim.out linear.H.MCMC1.out > .tmp) && echo '-PASSED-'
|
||||
+ chmod -w linear.H.MCMC1.in linear.H.MCMC1.out
|
||||
+ ./mcsim linear.H.MCMC1.in sim.out >> mcsim.log
|
||||
+ (diff sim.out linear.H.MCMC1.out > .tmp) && echo '-PASSED-'
|
||||
#
|
||||
# linear.H.MCMC2.in
|
||||
- @echo Testing MCMC hierarchical linear model, B1.1 set with \
|
||||
+ echo Testing MCMC hierarchical linear model, B1.1 set with \
|
||||
linear.H.MCMC2.in
|
||||
- @chmod -w linear.H.MCMC2.in linear.H.MCMC2.out
|
||||
- @mcsim linear.H.MCMC2.in sim.out >> mcsim.log
|
||||
- @(diff sim.out linear.H.MCMC2.out > .tmp) && echo '-PASSED-'
|
||||
+ chmod -w linear.H.MCMC2.in linear.H.MCMC2.out
|
||||
+ ./mcsim linear.H.MCMC2.in sim.out >> mcsim.log
|
||||
+ (diff sim.out linear.H.MCMC2.out > .tmp) && echo '-PASSED-'
|
||||
#
|
||||
# linear.H.MCMC3.in
|
||||
- @echo Testing MCMC hierarchical model, restart file with \
|
||||
+ echo Testing MCMC hierarchical model, restart file with \
|
||||
linear.H.MCMC3.in
|
||||
- @chmod -w linear.H.MCMC3.in linear.H.MCMC3.out
|
||||
- @mcsim linear.H.MCMC3.in sim.out >> mcsim.log
|
||||
- @(diff sim.out linear.H.MCMC3.out > .tmp) && echo '-PASSED-'
|
||||
-#
|
||||
- @echo
|
||||
- @echo Hourra!
|
||||
- @echo MCSim passed all tests.
|
||||
+ chmod -w linear.H.MCMC3.in linear.H.MCMC3.out
|
||||
+ ./mcsim linear.H.MCMC3.in sim.out >> mcsim.log
|
||||
+ (diff sim.out linear.H.MCMC3.out > .tmp) && echo '-PASSED-'
|
||||
+#
|
||||
+ echo
|
||||
+ echo Hourra!
|
||||
+ echo MCSim passed all tests.
|
||||
|
|
@ -1,8 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.1 2001/02/25 22:14:20 jtb Exp $
|
||||
|
||||
--- /dev/null Sun Feb 25 21:54:22 2001
|
||||
+++ Makefile
|
||||
@@ -0,0 +1,3 @@
|
||||
+SUBDIR = mod sim
|
||||
+
|
||||
+.include <bsd.subdir.mk>
|
Loading…
Reference in a new issue