Add DragonFly. Be a bit nicer to CPP and add trailing \ to mask the

embedded newlines.
This commit is contained in:
joerg 2006-01-12 00:05:04 +00:00
parent 40c0f2336f
commit fd780466d5
6 changed files with 52 additions and 7 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.28 2005/06/30 14:55:03 minskim Exp $
# $NetBSD: Makefile,v 1.29 2006/01/12 00:05:04 joerg Exp $
DISTNAME= sather-1.2.1
PKGREVISION= 5
@ -25,7 +25,7 @@ SUBST_FILES.sather-configure= \
Boot/sacomp.code/Makefile \
Library/System/unix.sa \
System/Common/CONFIG.proto \
System/Platforms/netbsd/CONFIG \
System/Platforms/${LOWER_OPSYS}/CONFIG \
System/Platforms/X/Platform.module \
debian/bin-wrapper \
Browser/Web/convert-1.1 \
@ -50,6 +50,9 @@ SUBST_SED.sather-configure= \
INSTALLATION_DIRS= man/man1
post-patch:
cd ${WRKSRC}/System/Platforms && ${CP} -r netbsd dragonfly
post-build:
cd ${WRKSRC}/Emacs; ${MAKEINFO} sather.texinfo; \
${MAKEINFO} sather-tutorial.texinfo; \
@ -72,7 +75,7 @@ do-install:
System/Debug \
System/Common/*.c System/Common/*.h \
System/Common/*.module System/Common/CONFIG \
System/Platforms/f77 System/Platforms/netbsd \
System/Platforms/f77 System/Platforms/${LOWER_OPSYS} \
System/Platforms/X System/Platforms/dualgui \
System/Platforms/gui System/Platforms/tcltk \
Browser ${PREFIX}/lib/sather

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.7 2005/02/24 09:03:11 agc Exp $
$NetBSD: distinfo,v 1.8 2006/01/12 00:05:04 joerg Exp $
SHA1 (sather-1.2.1.tar.gz) = 434f6b9c69d63a022c83f3693011415ad9730cb1
RMD160 (sather-1.2.1.tar.gz) = 73ff88f8035f7f6a98548a0ca6c359217cb58950
@ -7,7 +7,7 @@ SHA1 (patch-aa) = d326038193ce2fb459ed19f9ab2ae2b6dce1ace3
SHA1 (patch-ab) = e45f8a8230d1fbe3fc72babbecfa8148699f7906
SHA1 (patch-ac) = 586cdebde7a2c1b49f9b75a33d26980a2c0397f3
SHA1 (patch-ad) = 687a05fe5d20757e82a366f04c9c3905f14b5271
SHA1 (patch-ae) = c1aed9437daf2a03303f06850700f40a91da4a17
SHA1 (patch-ae) = 3d36a3dcbc6bc36af6353a619366189445e2b14e
SHA1 (patch-af) = 601bd3f55f16917d525c29813c23999264c883e2
SHA1 (patch-ag) = c16f121bac6197284eef907c96e9f903b35835b2
SHA1 (patch-ah) = 9dad48a3bc7e6af65eb51ae6070b8e67cab9ca2b
@ -28,3 +28,6 @@ SHA1 (patch-av) = 89573de88e99140dfb7fdae226646e40792a5752
SHA1 (patch-aw) = 87dbb259e058d7f246b523b8b4e101b02435c004
SHA1 (patch-ax) = 21801b475c59f48d561fed063fc758cc331f92ec
SHA1 (patch-ay) = 69237cba23aef19677d681db60fabcd9029893a7
SHA1 (patch-az) = 4898f196406c62a1b81188b989c56f3c6b69731a
SHA1 (patch-ba) = c1399f620f7f7fae6b65efe98ca931ac1a586e16
SHA1 (patch-bb) = 8e82e1d5796c9109527282d67c8f81ca0b9338dc

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ae,v 1.1.1.1 2002/05/04 00:45:35 jtb Exp $
$NetBSD: patch-ae,v 1.2 2006/01/12 00:05:04 joerg Exp $
--- Makefile.orig Thu Nov 4 08:04:28 1999
+++ Makefile Thu May 2 17:09:46 2002
@ -29,7 +29,7 @@ $NetBSD: patch-ae,v 1.1.1.1 2002/05/04 00:45:35 jtb Exp $
# or the SATHER_PLATFORM environment variable
# Should be edited for a particular system
-DEFAULT_PLATFORM=unix
+DEFAULT_PLATFORM=netbsd
+DEFAULT_PLATFORM=${LOWER_OPSYS}
# The platform used to compile the boot compiler. Usually just default, but has to
# be one of: freebsd, hpux_at, iris-4, linux, osf_at, solaris, solaris_at, unix,

View file

@ -0,0 +1,13 @@
$NetBSD: patch-az,v 1.1 2006/01/12 00:05:04 joerg Exp $
--- System/Common/c_header.h.orig 2006-01-11 22:04:22.000000000 +0000
+++ System/Common/c_header.h
@@ -40,7 +40,7 @@
# include <unistd.h>
#endif
-#if !defined(__NeXT__) && !defined(__EMX__) && !defined(__NetBSD__) && !defined(__FreeBSD__) && !defined(__CYGWIN32__)
+#if !defined(__NeXT__) && !defined(__EMX__) && !defined(__NetBSD__) && !defined(__FreeBSD__) && !defined(__CYGWIN32__) && !defined(__DragonFly__)
# include <values.h>
#endif

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ba,v 1.1 2006/01/12 00:05:04 joerg Exp $
--- System/Common/runtime.h.orig 2006-01-11 22:04:54.000000000 +0000
+++ System/Common/runtime.h
@@ -179,7 +179,7 @@ void rt_file_close(INT fd);
#define isnormal(f) ((int)1) /* these two are hacks esc*/
#define issubnormal(f) ((int)0)
-#elif defined(_AIX) || defined(SUNOS5) || defined(__NeXT__) || defined(__sgi) || defined(ALPHA) || defined(__hpux) || defined(__FreeBSD__) || defined(__alpha) || defined(__CYGWIN32__)
+#elif defined(_AIX) || defined(SUNOS5) || defined(__NeXT__) || defined(__sgi) || defined(ALPHA) || defined(__hpux) || defined(__FreeBSD__) || defined(__alpha) || defined(__CYGWIN32__) || defined(__DragonFly__)
# define FLTDEXP10(f) pow(10.0,f)
#else
# define FLTDEXP10(f) exp10(f)

View file

@ -0,0 +1,13 @@
$NetBSD: patch-bb,v 1.1 2006/01/12 00:05:04 joerg Exp $
--- System/Common/Makefile.orig 1999-10-21 22:26:32.000000000 +0000
+++ System/Common/Makefile
@@ -33,7 +33,7 @@ CONFIG: Makefile ../../Makefile CONFIG.p
@echo "-- in the top level Makefile. Please do not edit it" >> $(TMPFILE)
@echo "#define CONFIG_DEFAULT_PLATFORM \"$(DEFAULT_PLATFORM)\"" >> $(TMPFILE)
@echo -n "#define CONFIG_PLATFORMS \"" >> $(TMPFILE)
- @echo -n $(PLATFORMS) | sed "s/ //;s/,/\",\"/" >> $(TMPFILE)
+ @echo $(PLATFORMS) | sed "s/ //;s/,/\",\"/" | sed 's/$$/\\/' >> $(TMPFILE)
@echo "\"" >> $(TMPFILE)
@echo "#include \"CONFIG.proto\"" >> $(TMPFILE)
@$(CPP) -undef $(TMPFILE) > CONFIG