Make this package build with gcc-4. Patch provided by John D. Baker in

PR pkg/33094.
This commit is contained in:
minskim 2006-06-08 01:12:45 +00:00
parent cbf5ec4bec
commit fd95c9bbf6
2 changed files with 48 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.7 2005/12/19 14:34:33 joerg Exp $
$NetBSD: distinfo,v 1.8 2006/06/08 01:12:45 minskim Exp $
SHA1 (minicom-2.1.tar.gz) = 720273f6ee8db5fb2da4379ac610a520a31aba70
RMD160 (minicom-2.1.tar.gz) = 58121cf29991a92914acee855d6e86486c6d370d
@ -11,3 +11,4 @@ SHA1 (patch-ae) = b037623c4e3ee4cbc8c73c4b04c6b7f77c689d38
SHA1 (patch-af) = 38905432b60a796742d43be1aed84ee2774bb222
SHA1 (patch-ag) = c8947fb6693d2508d7caa79916142af346e27cdd
SHA1 (patch-ah) = da65045ad1d02a7c005aba863a106472d05f5c1c
SHA1 (patch-ai) = 5a1ecdea3287dc4d0b1c71bb88656fb729522081

View file

@ -0,0 +1,46 @@
$NetBSD: patch-ai,v 1.1 2006/06/08 01:12:45 minskim Exp $
--- src/window.c.orig 2003-05-16 20:06:26.000000000 +0000
+++ src/window.c
@@ -62,7 +62,7 @@ static char *CE, *Al, *Dl, *AL, *DL;
static char *CS, *SF, *SR, *VB, *BL;
static char *VE, *VI, *KS, *KE;
static char *CD, *CL, *IC, *DC;
-static char *BC, *CR, *NL;
+static char *mcBC, *CR, *NL;
#if ST_LINE
static char *TS, *FS, *DS;
#endif
@@ -322,8 +322,8 @@ int x, y;
else if (NL != CNULL && x == 0 && x == curx && y == cury + 1)
outstr(NL);
#endif
- else if (BC != CNULL && y == cury && x == curx - 1)
- outstr(BC);
+ else if (mcBC != CNULL && y == cury && x == curx - 1)
+ outstr(mcBC);
else
outstr(tgoto(CM, x, y));
curx = x;
@@ -1918,7 +1918,7 @@ int attr;
CL = tgetstr("cl", &_tptr);
IC = tgetstr("ic", &_tptr);
DC = tgetstr("dc", &_tptr);
- BC = tgetstr("bc", &_tptr);
+ mcBC = tgetstr("bc", &_tptr);
CR = tgetstr("cr", &_tptr);
NL = tgetstr("nl", &_tptr);
AC = tgetstr("ac", &_tptr);
@@ -1967,10 +1967,10 @@ int attr;
_has_am = tgetflag("am");
_mv_standout = tgetflag("ms");
if (tgetflag("bs")) {
- if (BC == CNULL) BC = "\b";
+ if (mcBC == CNULL) mcBC = "\b";
}
else
- BC = CNULL;
+ mcBC = CNULL;
/* Special IBM box-drawing characters */
D_UL = 201;