Update to 0.4:

0.4 - 2014-05-03
~~~~~~~~~~~~~~~~

* Deprecated ``salt_length`` on
  :class:`~cryptography.hazmat.primitives.asymmetric.padding.MGF1` and added it
  to :class:`~cryptography.hazmat.primitives.asymmetric.padding.PSS`. It will be
  removed from ``MGF1`` in two releases per our :doc:`/api-stability` policy.
* Added :class:`~cryptography.hazmat.primitives.ciphers.algorithms.SEED` support.
* Added :class:`~cryptography.hazmat.primitives.cmac.CMAC`.
* Added decryption support to
  :class:`~cryptography.hazmat.primitives.asymmetric.rsa.RSAPrivateKey`
  and encryption support to
  :class:`~cryptography.hazmat.primitives.asymmetric.rsa.RSAPublicKey`.
* Added signature support to
  :class:`~cryptography.hazmat.primitives.asymmetric.dsa.DSAPrivateKey`
  and verification support to
  :class:`~cryptography.hazmat.primitives.asymmetric.dsa.DSAPublicKey`.

0.3 - 2014-03-27
~~~~~~~~~~~~~~~~

* Added :class:`~cryptography.hazmat.primitives.twofactor.hotp.HOTP`.
* Added :class:`~cryptography.hazmat.primitives.twofactor.totp.TOTP`.
* Added :class:`~cryptography.hazmat.primitives.ciphers.algorithms.IDEA` support.
* Added signature support to
  :class:`~cryptography.hazmat.primitives.asymmetric.rsa.RSAPrivateKey`
  and verification support to
  :class:`~cryptography.hazmat.primitives.asymmetric.rsa.RSAPublicKey`.
* Moved test vectors to the new ``cryptography_vectors`` package.
This commit is contained in:
wiz 2014-05-06 10:30:54 +00:00
parent 099349f8f5
commit fdb6618b04
8 changed files with 66 additions and 100 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.6 2014/03/31 13:42:29 wiz Exp $
# $NetBSD: Makefile,v 1.7 2014/05/06 10:30:54 wiz Exp $
DISTNAME= cryptography-0.2.2
DISTNAME= cryptography-0.4
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 3
CATEGORIES= security python
MASTER_SITES= https://pypi.python.org/packages/source/c/cryptography/

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2014/03/21 14:02:45 wiz Exp $
@comment $NetBSD: PLIST,v 1.3 2014/05/06 10:30:54 wiz Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
@ -83,6 +83,12 @@ ${PYSITELIB}/cryptography/hazmat/bindings/openssl/binding.pyo
${PYSITELIB}/cryptography/hazmat/bindings/openssl/bio.py
${PYSITELIB}/cryptography/hazmat/bindings/openssl/bio.pyc
${PYSITELIB}/cryptography/hazmat/bindings/openssl/bio.pyo
${PYSITELIB}/cryptography/hazmat/bindings/openssl/cmac.py
${PYSITELIB}/cryptography/hazmat/bindings/openssl/cmac.pyc
${PYSITELIB}/cryptography/hazmat/bindings/openssl/cmac.pyo
${PYSITELIB}/cryptography/hazmat/bindings/openssl/cms.py
${PYSITELIB}/cryptography/hazmat/bindings/openssl/cms.pyc
${PYSITELIB}/cryptography/hazmat/bindings/openssl/cms.pyo
${PYSITELIB}/cryptography/hazmat/bindings/openssl/conf.py
${PYSITELIB}/cryptography/hazmat/bindings/openssl/conf.pyc
${PYSITELIB}/cryptography/hazmat/bindings/openssl/conf.pyo
@ -98,6 +104,12 @@ ${PYSITELIB}/cryptography/hazmat/bindings/openssl/dsa.pyo
${PYSITELIB}/cryptography/hazmat/bindings/openssl/ec.py
${PYSITELIB}/cryptography/hazmat/bindings/openssl/ec.pyc
${PYSITELIB}/cryptography/hazmat/bindings/openssl/ec.pyo
${PYSITELIB}/cryptography/hazmat/bindings/openssl/ecdh.py
${PYSITELIB}/cryptography/hazmat/bindings/openssl/ecdh.pyc
${PYSITELIB}/cryptography/hazmat/bindings/openssl/ecdh.pyo
${PYSITELIB}/cryptography/hazmat/bindings/openssl/ecdsa.py
${PYSITELIB}/cryptography/hazmat/bindings/openssl/ecdsa.pyc
${PYSITELIB}/cryptography/hazmat/bindings/openssl/ecdsa.pyo
${PYSITELIB}/cryptography/hazmat/bindings/openssl/engine.py
${PYSITELIB}/cryptography/hazmat/bindings/openssl/engine.pyc
${PYSITELIB}/cryptography/hazmat/bindings/openssl/engine.pyo
@ -158,6 +170,12 @@ ${PYSITELIB}/cryptography/hazmat/primitives/__init__.pyo
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/__init__.py
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/__init__.pyc
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/__init__.pyo
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/dsa.py
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/dsa.pyc
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/dsa.pyo
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/padding.py
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/padding.pyc
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/padding.pyo
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/rsa.py
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/rsa.pyc
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/rsa.pyo
@ -173,6 +191,9 @@ ${PYSITELIB}/cryptography/hazmat/primitives/ciphers/base.pyo
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/modes.py
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/modes.pyc
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/modes.pyo
${PYSITELIB}/cryptography/hazmat/primitives/cmac.py
${PYSITELIB}/cryptography/hazmat/primitives/cmac.pyc
${PYSITELIB}/cryptography/hazmat/primitives/cmac.pyo
${PYSITELIB}/cryptography/hazmat/primitives/constant_time.py
${PYSITELIB}/cryptography/hazmat/primitives/constant_time.pyc
${PYSITELIB}/cryptography/hazmat/primitives/constant_time.pyo
@ -197,6 +218,15 @@ ${PYSITELIB}/cryptography/hazmat/primitives/kdf/pbkdf2.pyo
${PYSITELIB}/cryptography/hazmat/primitives/padding.py
${PYSITELIB}/cryptography/hazmat/primitives/padding.pyc
${PYSITELIB}/cryptography/hazmat/primitives/padding.pyo
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/__init__.py
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/__init__.pyc
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/__init__.pyo
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/hotp.py
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/hotp.pyc
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/hotp.pyo
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/totp.py
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/totp.pyc
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/totp.pyo
${PYSITELIB}/cryptography/utils.py
${PYSITELIB}/cryptography/utils.pyc
${PYSITELIB}/cryptography/utils.pyo

View file

@ -1,10 +1,8 @@
$NetBSD: distinfo,v 1.4 2014/03/21 22:04:19 wiz Exp $
$NetBSD: distinfo,v 1.5 2014/05/06 10:30:54 wiz Exp $
SHA1 (cryptography-0.2.2.tar.gz) = 578e6a4cae6e24ecfa7069e1924ca99bd3c7d3ba
RMD160 (cryptography-0.2.2.tar.gz) = 8203428fbef935cafe897ae0878ac7e482781211
Size (cryptography-0.2.2.tar.gz) = 13772494 bytes
SHA1 (patch-cryptography_____init____.py) = 540544faa803a1b07d8d4cedec164622601f5550
SHA1 (patch-cryptography_hazmat_bindings_openssl_ssl.py) = f599f85c9b4e344cc9cd5d97a5a94ee9e5bcb9a9
SHA1 (patch-cryptography_hazmat_bindings_utils.py) = ca5d740e397c5d49eb6934a4e94009866cef20ef
SHA1 (patch-cryptography_hazmat_primitives_constant__time.py) = 75a2a83930917059ad6e4dac14fcae0c7585d426
SHA1 (patch-cryptography_hazmat_primitives_padding.py) = 7c8b367c95a76f769e641587118d75597e3ce552
SHA1 (cryptography-0.4.tar.gz) = 10255ea8609436b74362d5873f5419aa0dd3d7b1
RMD160 (cryptography-0.4.tar.gz) = b8d99e06b13c46e45852d98ceedfdcf0227c4f91
Size (cryptography-0.4.tar.gz) = 260891 bytes
SHA1 (patch-cryptography_hazmat_bindings_utils.py) = 4f4f53262efac03ea2b93c1338fed00aef4dc9cc
SHA1 (patch-cryptography_hazmat_primitives_constant__time.py) = 2af2bed42ba2d8a3eca3898abf17715066664f82
SHA1 (patch-cryptography_hazmat_primitives_padding.py) = f840dbde2109dee89632bf4bc5b893521971d640

View file

@ -1,16 +0,0 @@
$NetBSD: patch-cryptography_____init____.py,v 1.1 2014/03/21 22:04:19 wiz Exp $
Fix use with python-2.x.
--- cryptography/__init__.py.orig 2014-03-04 00:51:26.000000000 +0000
+++ cryptography/__init__.py
@@ -10,6 +10,9 @@
# implied.
# See the License for the specific language governing permissions and
# limitations under the License.
+
+from __future__ import absolute_import, division, print_function
+
from cryptography.__about__ import (
__title__, __summary__, __uri__, __version__, __author__, __email__,
__license__, __copyright__

View file

@ -1,48 +0,0 @@
$NetBSD: patch-cryptography_hazmat_bindings_openssl_ssl.py,v 1.1 2014/03/21 15:14:21 wiz Exp $
Fixes linkage on NetBSD-current up to the version that has openssl fixed
to include d1_meth.c.
Based on upstream patch from
https://gist.github.com/reaperhulk/5e4d3d30ac1598473206
--- cryptography/hazmat/bindings/openssl/ssl.py.orig 2014-03-04 01:53:14.000000000 +0000
+++ cryptography/hazmat/bindings/openssl/ssl.py
@@ -37,6 +37,7 @@ static const int Cryptography_HAS_RELEAS
static const int Cryptography_HAS_OP_NO_COMPRESSION;
static const int Cryptography_HAS_SSL_OP_MSIE_SSLV2_RSA_PADDING;
+static const long Cryptography_HAS_NETBSD_D1_METH;
static const int SSL_FILETYPE_PEM;
static const int SSL_FILETYPE_ASN1;
@@ -365,6 +366,19 @@ const long SSL_OP_MSIE_SSLV2_RSA_PADDING
#ifdef OPENSSL_NO_EC
long (*SSL_CTX_set_tmp_ecdh)(SSL_CTX *, EC_KEY *) = NULL;
#endif
+
+// NetBSD shipped without including d1_meth.c. Sad trombone.
+#ifdef __NetBSD__
+# include <sys/param.h>
+# if (__NetBSD_Version__ < 699003800)
+static const long Cryptography_HAS_NETBSD_D1_METH = 0;
+const SSL_METHOD* DTLSv1_method(void) { return NULL; };
+# else
+static const long Cryptography_HAS_NETBSD_D1_METH = 1;
+# endif
+#else
+static const long Cryptography_HAS_NETBSD_D1_METH = 1;
+#endif
"""
CONDITIONAL_NAMES = {
@@ -408,5 +422,9 @@ CONDITIONAL_NAMES = {
"Cryptography_HAS_EC": [
"SSL_CTX_set_tmp_ecdh",
- ]
+ ],
+
+ "Cryptography_HAS_NETBSD_D1_METH": [
+ "DTLSv1_method",
+ ],
}

View file

@ -1,14 +1,15 @@
$NetBSD: patch-cryptography_hazmat_bindings_utils.py,v 1.1 2014/03/21 14:02:45 wiz Exp $
$NetBSD: patch-cryptography_hazmat_bindings_utils.py,v 1.2 2014/05/06 10:30:54 wiz Exp $
Fix soname so cffi doesn't invent one for each python version + platform.
--- cryptography/hazmat/bindings/utils.py.orig 2014-03-04 00:51:26.000000000 +0000
--- cryptography/hazmat/bindings/utils.py.orig 2014-05-03 14:19:18.000000000 +0000
+++ cryptography/hazmat/bindings/utils.py
@@ -69,6 +69,7 @@ def build_ffi(module_prefix, modules, pr
customizations
),
libraries=libraries,
+ modulename=module_name,
ext_package="cryptography",
@@ -73,7 +73,7 @@ def build_ffi(module_prefix, modules, pr
)
lib = ffi.verify(
source=source,
- modulename=_create_modulename(cdef_sources, source, sys.version),
+ modulename=module_name,
libraries=libraries,
ext_package="cryptography",
extra_compile_args=extra_compile_args,

View file

@ -1,14 +1,15 @@
$NetBSD: patch-cryptography_hazmat_primitives_constant__time.py,v 1.1 2014/03/21 14:02:45 wiz Exp $
$NetBSD: patch-cryptography_hazmat_primitives_constant__time.py,v 1.2 2014/05/06 10:30:54 wiz Exp $
Fix soname so cffi doesn't invent one for each python version + platform.
--- cryptography/hazmat/primitives/constant_time.py.orig 2014-03-04 00:51:26.000000000 +0000
--- cryptography/hazmat/primitives/constant_time.py.orig 2014-05-03 14:19:18.000000000 +0000
+++ cryptography/hazmat/primitives/constant_time.py
@@ -45,6 +45,7 @@ uint8_t Cryptography_constant_time_bytes
}
""",
ext_package="cryptography",
@@ -51,7 +51,7 @@ _ffi = cffi.FFI()
_ffi.cdef(TYPES)
_lib = _ffi.verify(
source=FUNCTIONS,
- modulename=_create_modulename([TYPES], FUNCTIONS, sys.version),
+ modulename="constanttime",
ext_package="cryptography",
)

View file

@ -1,14 +1,15 @@
$NetBSD: patch-cryptography_hazmat_primitives_padding.py,v 1.1 2014/03/21 14:02:45 wiz Exp $
$NetBSD: patch-cryptography_hazmat_primitives_padding.py,v 1.2 2014/05/06 10:30:54 wiz Exp $
Fix soname so cffi doesn't invent one for each python version + platform.
--- cryptography/hazmat/primitives/padding.py.orig 2014-03-04 00:51:26.000000000 +0000
--- cryptography/hazmat/primitives/padding.py.orig 2014-05-03 14:19:18.000000000 +0000
+++ cryptography/hazmat/primitives/padding.py
@@ -62,6 +62,7 @@ uint8_t Cryptography_check_pkcs7_padding
}
""",
ext_package="cryptography",
@@ -71,7 +71,7 @@ _ffi = cffi.FFI()
_ffi.cdef(TYPES)
_lib = _ffi.verify(
source=FUNCTIONS,
- modulename=_create_modulename([TYPES], FUNCTIONS, sys.version),
+ modulename="checkpkcs7padding",
ext_package="cryptography",
)