Fix up apache and apache-modssl pkgs:
- Now that bsd.pkg.mk filters out dlopen style .so's on NOPIC systems, re-merge the PLIST. - Rewrite apache-modssl's Makefile and PLIST to share apache's, reducing logic duplication.
This commit is contained in:
parent
6fe4778f70
commit
fdca7390ec
10 changed files with 118 additions and 354 deletions
|
@ -1,75 +1,54 @@
|
|||
# $NetBSD: Makefile,v 1.4 1998/09/22 06:11:40 garbled Exp $
|
||||
# FreeBSD: Makefile,v 1.2 1998/08/29 21:24:13 rse Exp
|
||||
# $NetBSD: Makefile,v 1.5 1998/10/03 21:01:15 tv Exp $
|
||||
#
|
||||
|
||||
DISTNAME= apache_1.3.1
|
||||
PKGNAME= apache-modssl-1.3.1
|
||||
CATEGORIES= www security
|
||||
MASTER_SITES= ftp://www.apache.org/apache/dist/ \
|
||||
http://www.engelschall.com/sw/mod_ssl/distrib/ \
|
||||
|
||||
MASTER_SITES+= http://www.engelschall.com/sw/mod_ssl/distrib/ \
|
||||
ftp://ftp.engelschall.com/sw/mod_ssl/ \
|
||||
ftp://ftp.ulpgc.es/pub/mod_ssl/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} mod_ssl-2.0.6-1.3.1${EXTRACT_SUFX}
|
||||
|
||||
NOT_FOR_ARCHS= alpha #mod_include.so ELF problems
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
HOMEPAGE= http://www.apache.org/
|
||||
DISTFILES+= mod_ssl-2.0.6-1.3.1${EXTRACT_SUFX}
|
||||
EXTRACT_ONLY+= mod_ssl-2.0.6-1.3.1${EXTRACT_SUFX}
|
||||
|
||||
DEPENDS+= SSLeay-0.9.0b:../../security/ssleay
|
||||
|
||||
CONFLICTS= apache-1.3.1
|
||||
|
||||
RESTRICTED= "Contains cryptography"
|
||||
IS_INTERACTIVE= yes
|
||||
|
||||
HAS_CONFIGURE= YES
|
||||
CONFIGURE_ARGS+=--compat --prefix=${PREFIX}/http --exec-prefix=${PREFIX} \
|
||||
--mandir=${PREFIX}/man --libexecdir=${PREFIX}/libexec/apache \
|
||||
--sbindir=${PREFIX}/sbin --runtimedir=/var/run \
|
||||
--enable-module=most --enable-module=auth_db \
|
||||
--disable-module=auth_dbm --with-perl=${PREFIX}/bin/perl \
|
||||
--enable-module=ssl
|
||||
CONFIGURE_ARGS+=--enable-module=ssl
|
||||
CONFIGURE_ENV+= SSL_BASE=${PREFIX} SSL_CNFDIR=${PREFIX}/lib
|
||||
|
||||
.if defined(APACHE_SUEXEC)
|
||||
CONFIGURE_ARGS+=--enable-suexec --suexec-caller=www \
|
||||
--suexec-userdir=WWW \
|
||||
--suexec-safepath='${PREFIX}/bin:/usr/local/bin:/usr/bin:/bin'
|
||||
.if defined(USE_RSAREF2) && ${USE_RSAREF2} == YES
|
||||
CONFIGURE_ENV+= RSA_BASE=${PREFIX}/lib
|
||||
.endif
|
||||
|
||||
OPTIM= -DHARD_SERVER_LIMIT=512 \
|
||||
-DDOCUMENT_LOCATION=\\"${PREFIX}/http/htdocs/\\" \
|
||||
-DDEFAULT_PATH=\\"/bin:/usr/bin:${PREFIX}/bin:/usr/local/bin\\"
|
||||
PLIST_SRC= ${PKGDIR}/PLIST ../apache/pkg/PLIST
|
||||
|
||||
.if defined(APACHE_PERF_TUNING) && ${APACHE_PERF_TUNING} == YES
|
||||
CONFIGURE_ARGS+= --disable-rule=STATUS
|
||||
OPTIM+= -DBUFFERED_LOGS
|
||||
CFLAGS+= -O6 -fomit-frame-pointer -fexpensive-optimizations
|
||||
.if !defined(USE_RSAREF2) || ${USE_RSAREF2} != YES && ${USE_RSAREF2} != NO
|
||||
fetch-depends:
|
||||
@${ECHO}
|
||||
@${ECHO} The variable USE_RSAREF2 must be set to either YES or NO
|
||||
@${ECHO} in order to build this package. People with no RSA
|
||||
@${ECHO} license MUST set this variable to YES. Users outside
|
||||
@${ECHO} the USA MUST set this variable to NO. RSA licensees may
|
||||
@${ECHO} choose -- NO is faster. This setting must match what the
|
||||
@${ECHO} SSLeay pkg was compiled with.
|
||||
@${FALSE}
|
||||
.endif
|
||||
|
||||
.if !defined(NOPIC)
|
||||
CONFIGURE_ARGS+=--enable-module=so --enable-shared=include
|
||||
.endif
|
||||
|
||||
CONFIGURE_ENV= OPTIM='${OPTIM}' SSL_BASE=${PREFIX} \
|
||||
SSL_CNFDIR=${PREFIX}/etc RSA_BASE=${PREFIX}/lib
|
||||
|
||||
INSTALL_TARGET= install-quiet
|
||||
|
||||
pre-patch:
|
||||
pre-patch: pre-patch-modssl
|
||||
pre-patch-modssl:
|
||||
@cd ${WRKDIR}/mod_ssl-2.0.6-1.3.1 \
|
||||
&& ${ECHO_MSG} "===> Applying mod_ssl-2.0.6 extension" \
|
||||
&& ./configure --with-apache=../${DISTNAME}
|
||||
&& ${ECHO_MSG} "===> Applying mod_ssl-2.0.6 extension" \
|
||||
&& ./configure --with-apache=../${DISTNAME}
|
||||
|
||||
pre-install: certificate
|
||||
certificate:
|
||||
@cd ${WRKSRC} \
|
||||
&& ${ECHO_MSG} "===> Creating Test Certificate for Server" \
|
||||
&& ${MAKE} certificate
|
||||
&& ${ECHO_MSG} "===> Creating Test Certificate for Server" \
|
||||
&& ${MAKE} certificate
|
||||
|
||||
post-install:
|
||||
@if [ ! -f ${PREFIX}/etc/rc.d/apache.sh ]; then \
|
||||
${ECHO} Installing ${PREFIX}/etc/rc.d/apache.sh ; \
|
||||
${SED} -e 's|@@@PREFIX@@@|${PREFIX}|g' \
|
||||
< ${FILESDIR}/apache.sh \
|
||||
> ${PREFIX}/etc/rc.d/apache.sh ; \
|
||||
fi
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
# There's lots of tuning the user can do; this makes it common.
|
||||
.include "../apache/Makefile"
|
||||
|
|
|
@ -1,4 +0,0 @@
|
|||
#!/bin/sh
|
||||
# $NetBSD: apache.sh,v 1.3 1998/09/17 12:21:56 frueauf Exp $
|
||||
|
||||
[ -x @@@PREFIX@@@/sbin/apachectl ] && @@@PREFIX@@@/sbin/apachectl start >/dev/null && echo -n ' apache'
|
|
@ -1,4 +1,5 @@
|
|||
$NetBSD: md5,v 1.2 1998/09/05 09:08:08 explorer Exp $
|
||||
$NetBSD: md5,v 1.3 1998/10/03 21:01:15 tv Exp $
|
||||
|
||||
MD5 (apache_1.3.1.tar.gz) = fd28c26f94451216a23f34f5fe22e2b4
|
||||
MD5 (mod_ssl-2.0.6-1.3.1.tar.gz) = bc7387ca02a7f29263ee7283755b44ba
|
||||
MD5 (sitedrivenby.gif) = ad0647dceb931d02bfd046e55915f7b1
|
||||
|
|
27
www/apache-modssl/patches/patch-ab
Normal file
27
www/apache-modssl/patches/patch-ab
Normal file
|
@ -0,0 +1,27 @@
|
|||
--- htdocs/index.html.orig Sat Oct 3 16:50:51 1998
|
||||
+++ htdocs/index.html Sat Oct 3 16:59:54 1998
|
||||
@@ -59,17 +59,22 @@
|
||||
HREF="manual/mod/mod_ssl.html"
|
||||
>SSL documentation</A>
|
||||
carefully.
|
||||
+ Information on the NetBSD multiplatform operating system can be found
|
||||
+ at <A HREF="http://www.netbsd.org/">NetBSD's homepage</A> on the net.
|
||||
</P>
|
||||
<P>
|
||||
The Webmaster of this site is free to use the images below on
|
||||
- an SSL-aware Apache Web server. <BR>
|
||||
- Thanks for using Apache!
|
||||
+ an SSL-aware Apache/NetBSD-powered Web server. Thanks for using <A HREF="http://www.netbsd.org/">NetBSD</A>!
|
||||
</P>
|
||||
<HR NOSHADE>
|
||||
<P>
|
||||
<DIV ALIGN="CENTER">
|
||||
<A HREF="http://www.apache.org/"
|
||||
><IMG SRC="manual/images/apache_pb.gif" ALT="Apache Webserver" BORDER=0></A>
|
||||
+
|
||||
+ <A HREF="http://www.netbsd.org/">
|
||||
+ <IMG SRC="sitedrivenby.gif" border=0
|
||||
+ ALT="Site driven by NetBSD - NetBSD rocks!"></A>
|
||||
|
||||
<A HREF="http://www.engelschall.com/sw/mod_ssl/"
|
||||
><IMG SRC="manual/images/mod_ssl_sb.gif" ALT="mod_ssl Interface" BORDER=0></A>
|
14
www/apache-modssl/patches/patch-ac
Normal file
14
www/apache-modssl/patches/patch-ac
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ac,v 1.1 1998/10/03 21:01:16 tv Exp $
|
||||
|
||||
--- src/os/unix/os.h.orig Fri Oct 2 10:14:27 1998
|
||||
+++ src/os/unix/os.h Fri Oct 2 10:14:54 1998
|
||||
@@ -114,7 +114,8 @@
|
||||
#define RTLD_GLOBAL 0
|
||||
#endif
|
||||
|
||||
-#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__)
|
||||
+#if defined(__FreeBSD__) || defined(__OpenBSD__) || \
|
||||
+ (defined(__NetBSD__) && !defined(__ELF__))
|
||||
#define DLSYM_NEEDS_UNDERSCORE
|
||||
#endif
|
||||
|
|
@ -1,280 +1,13 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 1998/09/17 12:21:57 frueauf Exp $
|
||||
bin/dbmmanage
|
||||
bin/htdigest
|
||||
bin/htpasswd
|
||||
sbin/ab
|
||||
sbin/apachectl
|
||||
sbin/apxs
|
||||
sbin/httpd
|
||||
sbin/logresolve
|
||||
sbin/rotatelogs
|
||||
sbin/ssl_gcache
|
||||
etc/rc.d/apache.sh
|
||||
man/man1/ab.1
|
||||
man/man1/apachectl.1
|
||||
man/man1/dbmmanage.1
|
||||
man/man1/htdigest.1
|
||||
man/man1/htpasswd.1
|
||||
man/man8/apxs.8
|
||||
man/man8/httpd.8
|
||||
man/man8/logresolve.8
|
||||
man/man8/rotatelogs.8
|
||||
http/conf/access.conf.default
|
||||
http/conf/httpd.conf.default
|
||||
http/conf/magic.default
|
||||
http/conf/mime.types.default
|
||||
http/conf/srm.conf.default
|
||||
@comment $NetBSD: PLIST,v 1.4 1998/10/03 21:01:16 tv Exp $
|
||||
http/conf/sslcerts/Makefile
|
||||
http/conf/sslcerts/server.pem
|
||||
http/include/alloc.h
|
||||
http/include/ap.h
|
||||
http/include/ap_compat.h
|
||||
http/include/ap_config.h
|
||||
http/include/ap_config_auto.h
|
||||
http/include/ap_ctype.h
|
||||
http/include/ap_md5.h
|
||||
http/include/buff.h
|
||||
http/include/compat.h
|
||||
http/include/conf.h
|
||||
http/include/explain.h
|
||||
http/include/fnmatch.h
|
||||
http/include/hsregex.h
|
||||
http/include/http_conf_globals.h
|
||||
http/include/http_config.h
|
||||
http/include/http_core.h
|
||||
http/include/http_log.h
|
||||
http/include/http_main.h
|
||||
http/include/http_protocol.h
|
||||
http/include/http_request.h
|
||||
http/include/http_vhost.h
|
||||
http/include/httpd.h
|
||||
http/include/multithread.h
|
||||
http/include/os.h
|
||||
http/include/rfc1413.h
|
||||
http/include/scoreboard.h
|
||||
http/include/util_date.h
|
||||
http/include/util_md5.h
|
||||
http/include/util_script.h
|
||||
http/include/util_uri.h
|
||||
http/htdocs/apache_pb.gif
|
||||
http/htdocs/index.html
|
||||
http/htdocs/manual/LICENSE
|
||||
http/htdocs/manual/bind.html
|
||||
http/htdocs/manual/cgi_path.html
|
||||
http/htdocs/manual/content-negotiation.html
|
||||
http/htdocs/manual/custom-error.html
|
||||
http/htdocs/manual/dns-caveats.html
|
||||
http/htdocs/manual/dso.html
|
||||
http/htdocs/manual/ebcdic.html
|
||||
http/htdocs/manual/env.html
|
||||
http/htdocs/manual/footer.html
|
||||
http/htdocs/manual/handler.html
|
||||
http/htdocs/manual/header.html
|
||||
http/htdocs/manual/images/custom_errordocs.gif
|
||||
http/htdocs/manual/images/home.gif
|
||||
http/htdocs/manual/images/index.gif
|
||||
http/htdocs/manual/images/mod_rewrite_fig1.fig
|
||||
http/htdocs/manual/images/mod_rewrite_fig1.gif
|
||||
http/htdocs/manual/images/mod_rewrite_fig2.fig
|
||||
http/htdocs/manual/images/mod_rewrite_fig2.gif
|
||||
http/htdocs/manual/images/mod_ssl.jpg
|
||||
http/htdocs/manual/images/ssleay.gif
|
||||
http/htdocs/manual/images/mod_ssl_sb.gif
|
||||
http/htdocs/manual/images/apache_pb.gif
|
||||
http/htdocs/manual/images/sub.gif
|
||||
http/htdocs/manual/index.html
|
||||
http/htdocs/manual/install.html
|
||||
http/htdocs/manual/invoking.html
|
||||
http/htdocs/manual/keepalive.html
|
||||
http/htdocs/manual/location.html
|
||||
http/htdocs/manual/man-template.html
|
||||
http/htdocs/manual/misc/API.html
|
||||
http/htdocs/manual/misc/FAQ.html
|
||||
http/htdocs/manual/misc/HTTP_Features.tsv
|
||||
http/htdocs/manual/misc/client_block_api.html
|
||||
http/htdocs/manual/misc/compat_notes.html
|
||||
http/htdocs/manual/misc/custom_errordocs.html
|
||||
http/htdocs/manual/misc/descriptors.html
|
||||
http/htdocs/manual/misc/fin_wait_2.html
|
||||
http/htdocs/manual/misc/footer.html
|
||||
http/htdocs/manual/misc/header.html
|
||||
http/htdocs/manual/misc/howto.html
|
||||
http/htdocs/manual/misc/index.html
|
||||
http/htdocs/manual/misc/known_client_problems.html
|
||||
http/htdocs/manual/misc/nopgp.html
|
||||
http/htdocs/manual/misc/perf-bsd44.html
|
||||
http/htdocs/manual/misc/perf-dec.html
|
||||
http/htdocs/manual/misc/perf-hp.html
|
||||
http/htdocs/manual/misc/perf-tuning.html
|
||||
http/htdocs/manual/misc/perf.html
|
||||
http/htdocs/manual/misc/security_tips.html
|
||||
http/htdocs/manual/misc/vif-info.html
|
||||
http/htdocs/manual/misc/windoz_keepalive.html
|
||||
http/htdocs/manual/mod/core.html
|
||||
http/htdocs/manual/mod/directive-dict.html
|
||||
http/htdocs/manual/mod/directives.html
|
||||
http/htdocs/manual/mod/footer.html
|
||||
http/htdocs/manual/mod/header.html
|
||||
http/htdocs/manual/mod/index.html
|
||||
http/htdocs/manual/mod/mod_access.html
|
||||
http/htdocs/manual/mod/mod_actions.html
|
||||
http/htdocs/manual/mod/mod_alias.html
|
||||
http/htdocs/manual/mod/mod_asis.html
|
||||
http/htdocs/manual/mod/mod_auth.html
|
||||
http/htdocs/manual/mod/mod_auth_anon.html
|
||||
http/htdocs/manual/mod/mod_auth_db.html
|
||||
http/htdocs/manual/mod/mod_auth_dbm.html
|
||||
http/htdocs/manual/mod/mod_autoindex.html
|
||||
http/htdocs/manual/mod/mod_browser.html
|
||||
http/htdocs/manual/mod/mod_cern_meta.html
|
||||
http/htdocs/manual/mod/mod_cgi.html
|
||||
http/htdocs/manual/mod/mod_cookies.html
|
||||
http/htdocs/manual/mod/mod_digest.html
|
||||
http/htdocs/manual/mod/mod_dir.html
|
||||
http/htdocs/manual/mod/mod_dld.html
|
||||
http/htdocs/manual/mod/mod_dll.html
|
||||
http/htdocs/manual/mod/mod_env.html
|
||||
http/htdocs/manual/mod/mod_example.html
|
||||
http/htdocs/manual/mod/mod_expires.html
|
||||
http/htdocs/manual/mod/mod_headers.html
|
||||
http/htdocs/manual/mod/mod_imap.html
|
||||
http/htdocs/manual/mod/mod_include.html
|
||||
http/htdocs/manual/mod/mod_info.html
|
||||
http/htdocs/manual/mod/mod_isapi.html
|
||||
http/htdocs/manual/mod/mod_log_agent.html
|
||||
http/htdocs/manual/mod/mod_log_common.html
|
||||
http/htdocs/manual/mod/mod_log_config.html
|
||||
http/htdocs/manual/mod/mod_log_referer.html
|
||||
http/htdocs/manual/mod/mod_mime.html
|
||||
http/htdocs/manual/mod/mod_mime_magic.html
|
||||
http/htdocs/manual/mod/mod_mmap_static.html
|
||||
http/htdocs/manual/mod/mod_negotiation.html
|
||||
http/htdocs/manual/mod/mod_proxy.html
|
||||
http/htdocs/manual/mod/mod_rewrite.html
|
||||
http/htdocs/manual/mod/mod_setenvif.html
|
||||
http/htdocs/manual/mod/mod_so.html
|
||||
http/htdocs/manual/mod/mod_speling.html
|
||||
http/htdocs/manual/mod/mod_ssl.html
|
||||
http/htdocs/manual/mod/mod_status.html
|
||||
http/htdocs/manual/mod/mod_unique_id.html
|
||||
http/htdocs/manual/mod/mod_userdir.html
|
||||
http/htdocs/manual/mod/mod_usertrack.html
|
||||
http/htdocs/manual/multilogs.html
|
||||
http/htdocs/manual/new_features_1_0.html
|
||||
http/htdocs/manual/new_features_1_1.html
|
||||
http/htdocs/manual/new_features_1_2.html
|
||||
http/htdocs/manual/new_features_1_3.html
|
||||
http/htdocs/manual/process-model.html
|
||||
http/htdocs/manual/sections.html
|
||||
http/htdocs/manual/sourcereorg.html
|
||||
http/htdocs/manual/stopping.html
|
||||
http/htdocs/manual/suexec.html
|
||||
http/htdocs/manual/unixware.html
|
||||
http/htdocs/manual/upgrading_to_1_3.html
|
||||
http/htdocs/manual/vhosts/details.html
|
||||
http/htdocs/manual/vhosts/details_1_2.html
|
||||
http/htdocs/manual/vhosts/examples.html
|
||||
http/htdocs/manual/vhosts/fd-limits.html
|
||||
http/htdocs/manual/vhosts/footer.html
|
||||
http/htdocs/manual/vhosts/header.html
|
||||
http/htdocs/manual/vhosts/host.html
|
||||
http/htdocs/manual/vhosts/index.html
|
||||
http/htdocs/manual/vhosts/ip-based.html
|
||||
http/htdocs/manual/vhosts/name-based.html
|
||||
http/htdocs/manual/vhosts/vhosts-in-depth.html
|
||||
http/htdocs/manual/vhosts/virtual-host.html
|
||||
http/htdocs/manual/windows.html
|
||||
http/cgi-bin/printenv
|
||||
http/cgi-bin/test-cgi
|
||||
http/icons/README
|
||||
http/icons/a.gif
|
||||
http/icons/alert.black.gif
|
||||
http/icons/alert.red.gif
|
||||
http/icons/apache_pb.gif
|
||||
http/icons/back.gif
|
||||
http/icons/ball.gray.gif
|
||||
http/icons/ball.red.gif
|
||||
http/icons/binary.gif
|
||||
http/icons/binhex.gif
|
||||
http/icons/blank.gif
|
||||
http/icons/bomb.gif
|
||||
http/icons/box1.gif
|
||||
http/icons/box2.gif
|
||||
http/icons/broken.gif
|
||||
http/icons/burst.gif
|
||||
http/icons/c.gif
|
||||
http/icons/comp.blue.gif
|
||||
http/icons/comp.gray.gif
|
||||
http/icons/compressed.gif
|
||||
http/icons/continued.gif
|
||||
http/icons/dir.gif
|
||||
http/icons/down.gif
|
||||
http/icons/dvi.gif
|
||||
http/icons/f.gif
|
||||
http/icons/folder.gif
|
||||
http/icons/folder.open.gif
|
||||
http/icons/folder.sec.gif
|
||||
http/icons/forward.gif
|
||||
http/icons/generic.gif
|
||||
http/icons/generic.red.gif
|
||||
http/icons/generic.sec.gif
|
||||
http/icons/hand.right.gif
|
||||
http/icons/hand.up.gif
|
||||
http/icons/icon.sheet.gif
|
||||
http/icons/image1.gif
|
||||
http/icons/image2.gif
|
||||
http/icons/image3.gif
|
||||
http/icons/index.gif
|
||||
http/icons/layout.gif
|
||||
http/icons/left.gif
|
||||
http/icons/link.gif
|
||||
http/icons/movie.gif
|
||||
http/icons/p.gif
|
||||
http/icons/patch.gif
|
||||
http/icons/pdf.gif
|
||||
http/icons/pie0.gif
|
||||
http/icons/pie1.gif
|
||||
http/icons/pie2.gif
|
||||
http/icons/pie3.gif
|
||||
http/icons/pie4.gif
|
||||
http/icons/pie5.gif
|
||||
http/icons/pie6.gif
|
||||
http/icons/pie7.gif
|
||||
http/icons/pie8.gif
|
||||
http/icons/portal.gif
|
||||
http/icons/ps.gif
|
||||
http/icons/quill.gif
|
||||
http/icons/right.gif
|
||||
http/icons/screw1.gif
|
||||
http/icons/screw2.gif
|
||||
http/icons/script.gif
|
||||
http/icons/sound1.gif
|
||||
http/icons/sound2.gif
|
||||
http/icons/sphere1.gif
|
||||
http/icons/sphere2.gif
|
||||
http/icons/tar.gif
|
||||
http/icons/tex.gif
|
||||
http/icons/text.gif
|
||||
http/icons/transfer.gif
|
||||
http/icons/unknown.gif
|
||||
http/icons/up.gif
|
||||
http/icons/uu.gif
|
||||
http/icons/uuencoded.gif
|
||||
http/icons/world1.gif
|
||||
http/icons/world2.gif
|
||||
@exec mkdir -p %D/http/proxy
|
||||
@exec cd %D/http/etc/sslcerts/ && make >/dev/null 2>&1
|
||||
@exec mkdir -p %D/http/conf/sslkeys
|
||||
@dirrm http/cgi-bin
|
||||
@dirrm http/conf
|
||||
@dirrm http/htdocs/manual/images
|
||||
@dirrm http/htdocs/manual/misc
|
||||
@dirrm http/htdocs/manual/mod
|
||||
@dirrm http/htdocs/manual/vhosts
|
||||
@dirrm http/htdocs/manual
|
||||
@dirrm http/htdocs
|
||||
@dirrm http/icons
|
||||
@dirrm http/include
|
||||
@dirrm http/logs
|
||||
@dirrm http/proxy
|
||||
@dirrm http
|
||||
http/htdocs/manual/images/apache_pb.gif
|
||||
http/htdocs/manual/images/mod_ssl.jpg
|
||||
http/htdocs/manual/images/mod_ssl_sb.gif
|
||||
http/htdocs/manual/images/ssleay.gif
|
||||
http/htdocs/manual/mod/mod_ssl.html
|
||||
sbin/ssl_gcache
|
||||
@exec cd %D/http/etc/sslcerts/ && make >/dev/null 2>&1
|
||||
@dirrm http/conf/sslcerts
|
||||
@dirrm http/conf/sslkeys
|
||||
|
|
|
@ -1,36 +1,53 @@
|
|||
# $NetBSD: Makefile,v 1.20 1998/10/02 14:40:13 tv Exp $
|
||||
# $NetBSD: Makefile,v 1.21 1998/10/03 21:01:14 tv Exp $
|
||||
#
|
||||
# The apache-modssl pkg .include's us, so that pkg tuning rules work for
|
||||
# both without a major duplication of Makefiles. So we use ?= and += in
|
||||
# many of the constructs up here at top.
|
||||
#
|
||||
|
||||
DISTNAME= apache_1.3.1
|
||||
PKGNAME= apache-1.3.1
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.apache.org/dist/ \
|
||||
DISTNAME= apache_1.3.1
|
||||
PKGNAME?= apache-1.3.1
|
||||
CATEGORIES?= www
|
||||
MASTER_SITES+= http://www.apache.org/dist/ \
|
||||
http://www.netbsd.org/images/logos/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
|
||||
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} \
|
||||
sitedrivenby.gif
|
||||
|
||||
MAINTAINER= cjs@netbsd.org
|
||||
HOMEPAGE= http://www.apache.org/
|
||||
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
CONFLICTS= apache-modssl-1.3.1
|
||||
EXTRACT_ONLY+= ${DISTNAME}${EXTRACT_SUFX}
|
||||
CONFLICTS?= apache-modssl-1.3.1
|
||||
HAS_CONFIGURE= YES
|
||||
CONFIGURE_ARGS+=--compat --prefix=${PREFIX}/http --exec-prefix=${PREFIX} \
|
||||
--mandir=${PREFIX}/man --libexecdir=${PREFIX}/lib/apache \
|
||||
--sbindir=${PREFIX}/sbin --runtimedir=/var/run \
|
||||
--enable-module=most --enable-module=auth_db \
|
||||
--disable-module=auth_dbm --with-perl=${PREFIX}/bin/perl
|
||||
CONFIGURE_ENV+= OPTIM='${OPTIM}'
|
||||
OPTIM= -DDEFAULT_PATH=\\"/bin:/usr/bin:${PREFIX}/bin:/usr/local/bin\\"
|
||||
|
||||
.if defined(APACHE_SUEXEC)
|
||||
CONFIGURE_ARGS+=--enable-suexec --suexec-caller=www \
|
||||
--suexec-userdir=WWW \
|
||||
--suexec-safepath='${PREFIX}/bin:/usr/local/bin:/usr/bin:/bin'
|
||||
.endif
|
||||
|
||||
.if defined(APACHE_PERF_TUNING) && ${APACHE_PERF_TUNING} == YES
|
||||
CONFIGURE_ARGS+=--disable-rule=STATUS
|
||||
OPTIM+= -DBUFFERED_LOGS
|
||||
CFLAGS+= -O6 -fomit-frame-pointer -fexpensive-optimizations
|
||||
.endif
|
||||
|
||||
# Note that there is NO static compile module hook here. This is intentional.
|
||||
# Under Apache 1.3, modules can be compiled to link dynamically to the server
|
||||
# using the "apxs" program. See apxs(8).
|
||||
|
||||
# Create dummy files because there's no way (that I can see --cjs)
|
||||
# to make an empty directory with pkg_add.
|
||||
post-patch:
|
||||
@find ${WRKSRC}/htdocs -name '*.orig' | xargs ${RM}
|
||||
|
||||
post-install:
|
||||
touch ${PREFIX}/http/logs/.keep_me
|
||||
touch ${PREFIX}/http/proxy/.keep_me
|
||||
${CP} ${DISTDIR}/sitedrivenby.gif ${PREFIX}/http/htdocs
|
||||
${INSTALL_DATA} ${DISTDIR}/sitedrivenby.gif ${PREFIX}/http/htdocs
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST-mi,v 1.5 1998/09/05 23:14:45 hubertf Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 1998/10/03 21:01:14 tv Exp $
|
||||
bin/dbmmanage
|
||||
bin/htdigest
|
||||
bin/htpasswd
|
||||
|
@ -244,8 +244,8 @@ http/include/util_date.h
|
|||
http/include/util_md5.h
|
||||
http/include/util_script.h
|
||||
http/include/util_uri.h
|
||||
http/logs/.keep_me
|
||||
http/proxy/.keep_me
|
||||
lib/apache/mod_include.so
|
||||
@exec mkdir -p %D/http/logs %D/http/proxy %D/lib/apache
|
||||
man/man1/ab.1
|
||||
man/man1/apachectl.1
|
||||
man/man1/dbmmanage.1
|
||||
|
@ -261,6 +261,7 @@ sbin/apxs
|
|||
sbin/httpd
|
||||
sbin/logresolve
|
||||
sbin/rotatelogs
|
||||
@dirrm lib/apache
|
||||
@dirrm http/cgi-bin
|
||||
@dirrm http/conf
|
||||
@dirrm http/htdocs/manual/images
|
|
@ -1,3 +0,0 @@
|
|||
@comment $NetBSD: PLIST-md.shared,v 1.2 1998/07/21 21:34:09 cjs Exp $
|
||||
lib/apache/mod_include.so
|
||||
@dirrm lib/apache
|
|
@ -1 +0,0 @@
|
|||
@comment $NetBSD: PLIST-md.static,v 1.1 1998/06/04 19:38:37 tv Exp $
|
Loading…
Reference in a new issue