Update wl to 2.12.2.

Patch submitted by FUKAUMI Naoki (PR pkg/29043).

* Changes in 2.12.2 from 2.10.1
 - Now Maildir is usable on Windows systems.
 - Fixed the problem of the cache flag inconsistency on the filter folder etc.
 - Fixed the bug that the new flag cannot be changed in some cases.
 - Fixed the bug that flag are not taken over correctly from Maildir.
 - Fixed the problem in display module for IMAP messages.
 - Fixed the problem that %INBOX is not appeared as a subfolder of %INBOX.
 - Now user defined flags are appeared in the completions for search conditions.
 - Fixed the problem that a wrong flag folders are created by some flag names.
 - Now expansion of the access group "@/" works correctly.
 - Fixed the problem to cause an error on automatic draft saving.
 - Fixed the problem to cause an error on invoking address manager.
 - Fixed the problem in the flag inheritance function of the filter folder.
 - Improved redisplay functions for "H" and "M" key.
 - Now attributes for netnews are displayed in the draft preview.
 - The structure of the message database is improved.
 - The temporary mark and corresponding action is now customizable.
 - SPAM filter module is added.
 - 'mark folder is renamed to 'flag folder.
 - Now you can put arbitrary user defined flag on message.
 - New marks, 'A' and 'a' are added for answered messages.
 - New mark,s 'F' and 'f' are added for forwarded messages.
 - New search condition 'Flag' (Status of the message) is added.
 - Draft save function is improved.
 - Automatically save draft buffers by using idle-timer.
 - 'H' key(display all header) and 'M' key(display without MIME analysis)
   are now toggle key.
 - Now you can sort summary lines into descending order.
 - Abbreviate too long header extended to lines in message buffer.
 - Persistent mark string in summary buffer is changed.
 - It displays draft preview on sending confirmation.
 - Sending parameters are displayed on draft preview.
 - You can run biff with idle-timer by setting wl-biff-use-idle-timer.
 - Now wl-draft-kill confirms with yes-or-no-p.
 - Summary thread will be divided if its depth is larger than certain amount.
   The limit is controlled by the variable wl-summary-max-thread-depth.
 - Emacs multi-tty support is supported.
 - New sort spec 'size' is added in the summary mode.
 - The variable wl-refile-policy-alist is abolished.
 - Batch processing module is added.
 - In the multi-folder, status of messages are synchronized with original
   folder.
 - The function wl-summary-resend-message is abolished.
 - Variables renamed
   wl-delete-folder-alist is renamed to wl-dispose-folder-alist.
 - POP3 folder existence check is simplified (by default).
 - POP3 response code extension defined in the RFC2449 is supported.
 - IMAP4 commands EXPUNGE and CHECK are now send asynchronously.
 - Default value of wl-folder-hierarchy-access-folders has been changed.
 - Access group "@/" of shimbun folders can be used now.
 - Show contents of NEWS(.ja) when you start Wanderlust newer than the
   one you used previously.
 - Default values of wl-draft-reply-*-list are changed.
 - wl-draft-reply-myself-*-list are abolished and integrated into
   wl-draft-reply-*-list.
 - You can control initial cursor position for replying draft.
 - Changed the way to specify configuration of draft buffer window.
 - Commands to verify/decrypt non-MIME PGP message are added.
 - New options
   wl-summary-resend-use-cache
   elmo-network-session-idle-timeout
 - New hooks
    wl-draft-reply-hook
    wl-summary-reply-hook
    wl-draft-forward-hook
    wl-summary-forward-hook
    wl-draft-kill-pre-hook
    wl-summary-resend-hook
 - Abolished hook
    wl-reply-hook
 - New face
    wl-highlight-summary-disposed-face
    wl-highlight-summary-prefetch-face
    wl-highlight-summary-resend-face
    wl-highlight-summary-answered-face
    wl-highlight-action-argument-face
 - Abolished face
    wl-highlight-refile-destination-face
    (renamed to wl-highlight-action-argument-face)
This commit is contained in:
hira 2005-03-06 19:24:55 +00:00
parent 972f8eb122
commit fe0beb1bc3
5 changed files with 22 additions and 29 deletions

View file

@ -1,16 +1,16 @@
Wanderlust is a mail/news management system with IMAP4rev1 support for Emacs.
* Implementation in elisp only.
* Support of IMAP4rev1 , NNTP , POP(POP3/APOP), MH and Maildir.
* Support of IMAP4rev1, NNTP, POP(POP3/APOP), MH and Maildir.
* Integrated access to messages based on Folder Specifications like Mew.
* Key bindings and mark processing like Mew.
* Management of threads and unread messages.
* Folder mode to select and edit subscribed folders.
* Message cache, Disconnected Operation.
* MH-like FCC (FCC: %Backup is possible).
* Full support of MIME (by SEMI or tm).
* MH-like Fcc (Fcc: %Backup is possible).
* Full support of MIME (by SEMI).
* Draft editing of mail and news as a same interface.
* Icon based interface for the list of Folder (XEmacs).
* Icon based interface for the list of Folder (XEmacs and Emacs 21).
* Skip fetching of a large message part of MIME(IMAP4).
* Server side searching (IMAP4), internationalized searching is available.
* Virtual folder.

View file

@ -1,14 +1,19 @@
# $NetBSD: Makefile,v 1.19 2004/09/19 13:41:24 wiz Exp $
# $NetBSD: Makefile,v 1.20 2005/03/06 19:24:55 hira Exp $
DISTNAME= wl-2.10.1
DISTNAME= wl-2.12.2
CATEGORIES= mail
MASTER_SITES= ftp://ftp.ring.gr.jp/pub/text/elisp/wl/stable/
MASTER_SITES= ftp://ftp.gohome.org/wl/stable/
MAINTAINER= tech-pkg-ja@jp.NetBSD.org
HOMEPAGE= http://www.gohome.org/wl/
COMMENT= Mail/news management system with IMAP4rev1 support for Emacs
DEPENDS+= semi>=1.13.7:../../devel/semi
USE_BUILDLINK3= yes
DEPENDS+= apel>=10.6:../../devel/apel
DEPENDS+= flim>=1.14.7:../../devel/flim
DEPENDS+= semi>=1.14.6:../../devel/semi
DEPENDS+= bbdb-[0-9]*:../../misc/bbdb
# XXX please someone adjust paths and PLIST for XEmacs...
EMACS_VERSIONS_ACCEPTED= emacs21 emacs21nox emacs20
@ -46,4 +51,5 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/samples/en/dot.* ${EXAMPLESDIR}/en
@${INSTALL_DATA} ${WRKSRC}/samples/ja/dot.* ${EXAMPLESDIR}/ja
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST.header,v 1.3 2004/03/07 21:51:26 seb Exp $
@comment $NetBSD: PLIST.header,v 1.4 2005/03/06 19:24:55 hira Exp $
share/doc/wl/en/BUGS
share/doc/wl/en/NEWS
share/doc/wl/en/README
@ -9,6 +9,7 @@ ${FOR_emacs21}share/wl/archive.xpm
${FOR_emacs21}share/wl/closed.xpm
${FOR_emacs21}share/wl/draft.xpm
${FOR_emacs21}share/wl/elmo.xpm
${FOR_emacs21}share/wl/file.xpm
${FOR_emacs21}share/wl/filter.xpm
${FOR_emacs21}share/wl/imap.xpm
${FOR_emacs21}share/wl/internal.xpm
@ -61,10 +62,10 @@ ${FOR_emacs21}share/wl/wl-message-read-up.xpm
${FOR_emacs21}share/wl/wl-stable-logo.xpm
${FOR_emacs21}share/wl/wl-stable-xmas-logo.xpm
${FOR_emacs21}share/wl/wl-summary-delete-up.xpm
${FOR_emacs21}share/wl/wl-summary-dispose-up.xpm
${FOR_emacs21}share/wl/wl-summary-exit-up.xpm
${FOR_emacs21}share/wl/wl-summary-forward-up.xpm
${FOR_emacs21}share/wl/wl-summary-jump-to-current-message-up.xpm
${FOR_emacs21}share/wl/wl-summary-mark-as-important-up.xpm
${FOR_emacs21}share/wl/wl-summary-next-page-up.xpm
${FOR_emacs21}share/wl/wl-summary-next-up.xpm
${FOR_emacs21}share/wl/wl-summary-prev-page-up.xpm
@ -72,6 +73,7 @@ ${FOR_emacs21}share/wl/wl-summary-prev-up.xpm
${FOR_emacs21}share/wl/wl-summary-read-up.xpm
${FOR_emacs21}share/wl/wl-summary-reply-up.xpm
${FOR_emacs21}share/wl/wl-summary-reply-with-citation-up.xpm
${FOR_emacs21}share/wl/wl-summary-set-flags-up.xpm
${FOR_emacs21}share/wl/wl-summary-sync-force-update-up.xpm
${FOR_emacs21}share/wl/wl-write-current-folder-up.xpm
share/wl/wl-alpha-logo.img

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.10 2005/02/24 09:59:30 agc Exp $
$NetBSD: distinfo,v 1.11 2005/03/06 19:24:55 hira Exp $
SHA1 (wl-2.10.1.tar.gz) = 022c5984ea576d96184d5e3a576ec2a23f015a45
RMD160 (wl-2.10.1.tar.gz) = deb002a3b22ce20c3a53daaeec62a3384a053942
Size (wl-2.10.1.tar.gz) = 967205 bytes
SHA1 (wl-2.12.2.tar.gz) = 0bd82b2f76b36162c6f1e5c2304a8b09e41a7791
RMD160 (wl-2.12.2.tar.gz) = 6e65bf183686b93d6d4d901e9a239785322f8da4
Size (wl-2.12.2.tar.gz) = 1091609 bytes
SHA1 (patch-aa) = ede97cce8b2574737a91941a905e067c940fb50a
SHA1 (patch-ab) = 6e476198c3a0d5c7b8cb6939e4bbe046f69066c2
SHA1 (patch-ac) = c30b711db7b73a2d2bd7d6025bc394ecf7c35aad

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ab,v 1.2 2003/01/25 03:49:43 uebayasi Exp $
--- WL-ELS.orig Tue Jan 14 12:44:20 2003
+++ WL-ELS
@@ -71,7 +71,7 @@
(cons WLDIR WL-MODULES)
(if (module-installed-p 'bbdb)
(cons UTILSDIR (list 'bbdb-wl)))
- (if (exec-installed-p "imput")
- (cons UTILSDIR (list 'im-wl)))
+;; (if (exec-installed-p "imput")
+;; (cons UTILSDIR (list 'im-wl)))
(if wl-install-utils
(cons UTILSDIR UTILS-MODULES))))