deforaos-mailer: update to 0.2.0

Changes since 0.1.8:
- Defaults to Gtk+ 3 (like libDesktop)
- Re-licensed to 2-clause BSD
- Use general-purpose version-flexible SSL/TLS methods
This commit is contained in:
khorben 2020-01-12 09:09:24 +00:00
parent 6ac18bfb00
commit fe3a87b9f3
4 changed files with 13 additions and 31 deletions

View file

@ -1,15 +1,14 @@
# $NetBSD: Makefile,v 1.34 2020/01/10 21:15:21 joerg Exp $
# $NetBSD: Makefile,v 1.35 2020/01/12 09:09:24 khorben Exp $
DISTNAME= Mailer-0.1.8
PKGNAME= deforaos-mailer-0.1.8
PKGREVISION= 9
DISTNAME= Mailer-0.2.0
PKGNAME= deforaos-mailer-0.2.0
CATEGORIES= mail
MASTER_SITES= https://www.defora.org/os/download/download/4439/
MASTER_SITES= https://ftp.defora.org/pub/DeforaOS/Apps/Desktop/src/Mailer/
MAINTAINER= khorben@defora.org
HOMEPAGE= https://www.defora.org/
COMMENT= DeforaOS desktop e-mail client
LICENSE= modified-bsd
LICENSE= 2-clause-bsd
BUILD_DEPENDS+= libxslt-[0-9]*:../../textproc/libxslt
BUILD_DEPENDS+= docbook-xsl-[0-9]*:../../textproc/docbook-xsl
@ -17,8 +16,6 @@ BUILD_DEPENDS+= docbook-xsl-[0-9]*:../../textproc/docbook-xsl
USE_TOOLS+= pkg-config
USE_TOOLS+= xgettext
MAKE_JOBS_SAFE= no
MAKE_FLAGS+= DESTDIR=${DESTDIR}
MAKE_FLAGS+= PREFIX=${PREFIX}
MAKE_FLAGS+= CFLAGS=${CFLAGS:Q}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.7 2020/01/10 21:15:21 joerg Exp $
@comment $NetBSD: PLIST,v 1.8 2020/01/12 09:09:24 khorben Exp $
bin/compose
bin/mailer
include/Desktop/Mailer.h
@ -24,6 +24,8 @@ man/html1/mailer.html
man/man1/compose.1
man/man1/mailer.1
share/applications/deforaos-mailer.desktop
share/doc/Mailer/COPYING
share/doc/Mailer/README.md
share/gtk-doc/html/Mailer/Mailer-account.html
share/gtk-doc/html/Mailer/Mailer-folder.html
share/gtk-doc/html/Mailer/Mailer-helper.html

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.8 2020/01/10 21:15:21 joerg Exp $
$NetBSD: distinfo,v 1.9 2020/01/12 09:09:24 khorben Exp $
SHA1 (Mailer-0.1.8.tar.gz) = a31bbeb22f11f692e937b6450a3c913424a80b0d
RMD160 (Mailer-0.1.8.tar.gz) = 5bc95b752896c8b9fc6019d13767b6663672d019
SHA512 (Mailer-0.1.8.tar.gz) = fff0b8e6a7796bfb10d76dcfc36297a44b377e14bc0de2c8c939880e5fd956dd0b837f8c7788a3adc295aad18ab6f98001ff1cea03076bffed291f35d77bdd33
Size (Mailer-0.1.8.tar.gz) = 108980 bytes
SHA1 (patch-src_mailer.c) = 5e3975a0672ab0882a8712e5c21233104d0747d8
SHA1 (Mailer-0.2.0.tar.gz) = 2224a0c3b90085c3a9ce5418e15a394b86e64ff8
RMD160 (Mailer-0.2.0.tar.gz) = 0c4a41c62413e0c2e476103cd4331e231b9c1915
SHA512 (Mailer-0.2.0.tar.gz) = 04f8562a3a5ad51666864f7e1316094cdfbd06c6f305cbf2cd49199e97ecb31c02e83e89115c1bbab381e4049c3d53e1c630e70d1cf97d0b3b96cc040701aac3
Size (Mailer-0.2.0.tar.gz) = 112837 bytes

View file

@ -1,16 +0,0 @@
$NetBSD: patch-src_mailer.c,v 1.1 2020/01/10 21:15:21 joerg Exp $
SSLv23 is considered the generic request and mapped to TLS with newer
OpenSSL.
--- src/mailer.c.orig 2020-01-08 23:37:23.358580636 +0000
+++ src/mailer.c
@@ -391,7 +391,7 @@ Mailer * mailer_new(void)
/* ssl */
SSL_load_error_strings();
SSL_library_init();
- if((mailer->ssl_ctx = SSL_CTX_new(SSLv3_client_method())) == NULL
+ if((mailer->ssl_ctx = SSL_CTX_new(SSLv23_client_method())) == NULL
|| SSL_CTX_set_cipher_list(mailer->ssl_ctx,
SSL_DEFAULT_CIPHER_LIST) != 1
|| SSL_CTX_load_verify_locations(mailer->ssl_ctx, NULL,