Add DragonFly support. patch-bf replaces a malloc prototype with an
include of stdlib.h.
This commit is contained in:
parent
3911dfca80
commit
fe6df6a9ab
6 changed files with 56 additions and 10 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.6 2005/06/19 10:39:23 hira Exp $
|
||||
$NetBSD: distinfo,v 1.7 2005/10/10 21:23:24 joerg Exp $
|
||||
|
||||
SHA1 (transcode-0.6.12.tar.gz) = 3d9b223f804253a6a76d9645feb86609b0a2499a
|
||||
RMD160 (transcode-0.6.12.tar.gz) = 81d2d70fdb9398f97aa5b59b31ff4243c8f31b2f
|
||||
|
@ -6,9 +6,9 @@ Size (transcode-0.6.12.tar.gz) = 3454807 bytes
|
|||
SHA1 (patch-ad) = dc3777cbfd86eba3d62c0bfa947e9877c6c44fea
|
||||
SHA1 (patch-ae) = f49a155b84edbeb3c93705e6ab15e80f48adbdb1
|
||||
SHA1 (patch-af) = 88d2209445c4011f400ae2dd79d9e285aecd3f0a
|
||||
SHA1 (patch-ag) = 23fbedeb2db586af0afee74785013a64b9562c4e
|
||||
SHA1 (patch-ah) = db21f19742abfb6db70b4c77371a8da79cc8c7d0
|
||||
SHA1 (patch-ai) = 86f49f23d8af5320be93c8dc475b53b906dff10f
|
||||
SHA1 (patch-ag) = 85c3f8cd84ce0cfaf3aa70c044ba5eaa96267ea4
|
||||
SHA1 (patch-ah) = 7c401876c7f74dfd62edfb39575eebbf130cad42
|
||||
SHA1 (patch-ai) = 8437ea9d0bd0b08f0e8156e373f338084d68f2cd
|
||||
SHA1 (patch-aj) = f62d0e1e23868b290221cffc367c3f0a5cc5cbc6
|
||||
SHA1 (patch-ak) = add9a293ddb73e3f82982d2021a6310f742e45f1
|
||||
SHA1 (patch-al) = 797bd770565263452d47e2f4d8942974ef153553
|
||||
|
@ -26,3 +26,5 @@ SHA1 (patch-ba) = 65d1dfbbce181941d145359ef32f8d8c28adce3e
|
|||
SHA1 (patch-bb) = 2bec18cdca63ef4d0cc6c1caf8837890c9e116c6
|
||||
SHA1 (patch-bc) = f6a0f0dd550d798bb8919f40dea7df899beac3a1
|
||||
SHA1 (patch-bd) = ffca7a74422e0dac82d1a728b9c6ceef24f744cb
|
||||
SHA1 (patch-be) = 05bece81e5d45fd493ce6d5cbeda97226f363237
|
||||
SHA1 (patch-bf) = b0a7e5353578ef82f8113b4938ecf81708bf2b8a
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ag,v 1.1.1.1 2004/05/10 13:47:08 wiz Exp $
|
||||
$NetBSD: patch-ag,v 1.2 2005/10/10 21:23:24 joerg Exp $
|
||||
|
||||
diff -rcp import/iodump.c import/iodump.c
|
||||
*** import/iodump.c Wed Apr 2 19:03:05 2003
|
||||
|
@ -16,7 +16,7 @@ diff -rcp import/iodump.c import/iodump.c
|
|||
#include "dvd_reader.h"
|
||||
#endif
|
||||
|
||||
! #if defined(__bsdi__) || defined(__FreeBSD__) || defined(__APPLE__) || defined(__NetBSD__)
|
||||
! #if defined(__bsdi__) || defined(__FreeBSD__) || defined(__APPLE__) || defined(__NetBSD__) || defined(__DragonFly__)
|
||||
typedef off_t off64_t;
|
||||
#define lseek64 lseek
|
||||
#endif
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ah,v 1.1.1.1 2004/05/10 13:47:08 wiz Exp $
|
||||
$NetBSD: patch-ah,v 1.2 2005/10/10 21:23:24 joerg Exp $
|
||||
|
||||
diff -rcp import/nuv/rtjpeg_aud_plugin.c import/nuv/rtjpeg_aud_plugin.c
|
||||
*** import/nuv/rtjpeg_aud_plugin.c Tue Apr 8 20:50:11 2003
|
||||
|
@ -16,7 +16,7 @@ diff -rcp import/nuv/rtjpeg_aud_plugin.c import/nuv/rtjpeg_aud_plugin.c
|
|||
regions[0].end = -1;
|
||||
}
|
||||
|
||||
! #if defined(__FreeBSD__) || defined(__APPLE__) || defined(__NetBSD__)
|
||||
! #if defined(__FreeBSD__) || defined(__APPLE__) || defined(__NetBSD__) || defined(__DragonFly__)
|
||||
rtjpeg_aud_file=open(tplorg, O_RDONLY);
|
||||
#else
|
||||
rtjpeg_aud_file=open(tplorg, O_RDONLY|O_LARGEFILE);
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ai,v 1.1.1.1 2004/05/10 13:47:08 wiz Exp $
|
||||
$NetBSD: patch-ai,v 1.2 2005/10/10 21:23:24 joerg Exp $
|
||||
|
||||
diff -rcp import/nuv/rtjpeg_vid_plugin.c import/nuv/rtjpeg_vid_plugin.c
|
||||
*** import/nuv/rtjpeg_vid_plugin.c Tue Apr 8 20:50:11 2003
|
||||
|
@ -16,7 +16,7 @@ diff -rcp import/nuv/rtjpeg_vid_plugin.c import/nuv/rtjpeg_vid_plugin.c
|
|||
regions[0].end = -1;
|
||||
}
|
||||
|
||||
! #if defined(__FreeBSD__) || defined(__APPLE__) || defined(__NetBSD__)
|
||||
! #if defined(__FreeBSD__) || defined(__APPLE__) || defined(__NetBSD__) || defined(__DragonFly__)
|
||||
rtjpeg_vid_file=open(tplorg, O_RDONLY);
|
||||
#else
|
||||
rtjpeg_vid_file=open(tplorg, O_RDONLY|O_LARGEFILE);
|
||||
|
|
22
multimedia/transcode/patches/patch-be
Normal file
22
multimedia/transcode/patches/patch-be
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-be,v 1.1 2005/10/10 21:23:24 joerg Exp $
|
||||
|
||||
--- configure.in.orig 2005-07-10 17:19:18.000000000 +0000
|
||||
+++ configure.in
|
||||
@@ -147,7 +147,7 @@ AC_CHECK_LIB(m, lrintf, AC_DEFINE([HAVE_
|
||||
|
||||
dnl Replace `main' with a function in pthread libs:
|
||||
case "$host" in
|
||||
- *-*-freebsd*)
|
||||
+ *-*-freebsd* | *-*-dragonfly*)
|
||||
pthread_cflags="-D_REENTRANT -D_THREAD_SAFE"
|
||||
pthread_lib="-pthread"
|
||||
;;
|
||||
@@ -350,7 +350,7 @@ if test x$have_x86cpu = xtrue ; then
|
||||
AC_MSG_CHECKING(for CMOV support)
|
||||
if test "$enable_cmov_extension" != "no" ; then
|
||||
case "$host" in
|
||||
- *-*-freebsd*)
|
||||
+ *-*-freebsd* | *-*-dragonfly*)
|
||||
cpu_features=`grep -l CMOV /var/run/dmesg.boot`
|
||||
if test X"$cpu_features" = X"/var/run/dmesg.boot" ; then
|
||||
have_cmov=true
|
22
multimedia/transcode/patches/patch-bf
Normal file
22
multimedia/transcode/patches/patch-bf
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-bf,v 1.1 2005/10/10 21:23:24 joerg Exp $
|
||||
|
||||
--- filter/subtitler/frame_list.c.orig 2005-07-10 17:53:50.000000000 +0000
|
||||
+++ filter/subtitler/frame_list.c
|
||||
@@ -15,7 +15,7 @@ Foundation, Inc., 675 Mass Ave, Cambridg
|
||||
*/
|
||||
|
||||
#include "subtitler.h"
|
||||
-
|
||||
+#include <stdlib.h>
|
||||
|
||||
int hash(s)/* form hash value for string s */
|
||||
char *s;
|
||||
@@ -33,7 +33,7 @@ return(hashval % FRAME_HASH_SIZE);
|
||||
|
||||
char *strsave(char *s) /*save char array s somewhere*/
|
||||
{
|
||||
-char *p, *malloc();
|
||||
+char *p;
|
||||
if(p = malloc( strlen(s) + 1) ) strcpy(p, s);
|
||||
return(p);
|
||||
}
|
Loading…
Reference in a new issue