Initial import of kapooka-0.2:

KaPooka is a logic game, written in SDL.

The object of the game is to guide your red blobby to the exit,
pushing the green blobbies out of the way. You can only push a
green blobby if there is an empty space behind it.
This commit is contained in:
wiz 2004-11-24 17:05:03 +00:00
parent 082e6a8069
commit fea8da339c
5 changed files with 118 additions and 0 deletions

5
games/kapooka/DESCR Normal file
View file

@ -0,0 +1,5 @@
KaPooka is a logic game, written in SDL.
The object of the game is to guide your red blobby to the exit,
pushing the green blobbies out of the way. You can only push a
green blobby if there is an empty space behind it.

43
games/kapooka/Makefile Normal file
View file

@ -0,0 +1,43 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/11/24 17:05:03 wiz Exp $
#
DISTNAME= kapooka_0.2
PKGNAME= ${DISTNAME:S/_/-/}
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=kapooka/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://kapooka.sourceforge.net/
COMMENT= Puzzle game
WRKSRC= ${WRKDIR}/kapooka
USE_BUILDLINK3= yes
USE_GNU_TOOLS+= make
SUBST_CLASSES+= kapooka
SUBST_STAGE.kapooka= pre-build
SUBST_MESSAGE.kapooka= "Fixing path to data files."
SUBST_FILES.kapooka= main.h objects.c
SUBST_SED.kapooka= "s!data/!${PREFIX}/share/kapooka/!"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/kapooka ${PREFIX}/bin
${INSTALL_DATA_DIR} ${PREFIX}/share/kapooka
${INSTALL_DATA_DIR} ${PREFIX}/share/kapooka/interface
${INSTALL_DATA_DIR} ${PREFIX}/share/kapooka/levelDummy
${INSTALL_DATA_DIR} ${PREFIX}/share/kapooka/music
${INSTALL_DATA_DIR} ${PREFIX}/share/kapooka/sound
${INSTALL_DATA_DIR} ${PREFIX}/share/kapooka/sprites
${INSTALL_DATA} ${WRKSRC}/data/level.dat ${PREFIX}/share/kapooka
${INSTALL_DATA} ${WRKSRC}/data/interface/* ${PREFIX}/share/kapooka/interface
${INSTALL_DATA} ${WRKSRC}/data/levelDummy/* ${PREFIX}/share/kapooka/levelDummy
${INSTALL_DATA} ${WRKSRC}/data/music/* ${PREFIX}/share/kapooka/music
${INSTALL_DATA} ${WRKSRC}/data/sound/* ${PREFIX}/share/kapooka/sound
${INSTALL_DATA} ${WRKSRC}/data/sprites/*.png ${PREFIX}/share/kapooka/sprites
.include "../../audio/SDL_mixer/buildlink3.mk"
.include "../../audio/libmikmod/buildlink3.mk"
.include "../../devel/SDL/buildlink3.mk"
.include "../../graphics/SDL_image/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

45
games/kapooka/PLIST Normal file
View file

@ -0,0 +1,45 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/11/24 17:05:04 wiz Exp $
bin/kapooka
share/kapooka/level.dat
share/kapooka/interface/company_logo.png
share/kapooka/interface/title.png
share/kapooka/interface/title_bg.png
share/kapooka/levelDummy/layer0.png
share/kapooka/music/dummy.xm
share/kapooka/sound/weak_shot.wav
share/kapooka/sprites/1x1transparent.png
share/kapooka/sprites/blank.png
share/kapooka/sprites/exit.png
share/kapooka/sprites/interface_back_disabled.png
share/kapooka/sprites/interface_back_idle.png
share/kapooka/sprites/interface_back_in.png
share/kapooka/sprites/interface_back_lit.png
share/kapooka/sprites/interface_begin_disabled.png
share/kapooka/sprites/interface_begin_idle.png
share/kapooka/sprites/interface_begin_in.png
share/kapooka/sprites/interface_begin_lit.png
share/kapooka/sprites/interface_end_disabled.png
share/kapooka/sprites/interface_end_idle.png
share/kapooka/sprites/interface_end_in.png
share/kapooka/sprites/interface_end_lit.png
share/kapooka/sprites/interface_forward_disabled.png
share/kapooka/sprites/interface_forward_idle.png
share/kapooka/sprites/interface_forward_in.png
share/kapooka/sprites/interface_forward_lit.png
share/kapooka/sprites/mainchar_exit.png
share/kapooka/sprites/mainchar_idle.png
share/kapooka/sprites/mainchar_in_teleport.png
share/kapooka/sprites/mainchar_move_in.png
share/kapooka/sprites/mainchar_move_out.png
share/kapooka/sprites/mainchar_teleport.png
share/kapooka/sprites/standard_idle.png
share/kapooka/sprites/standard_move_in.png
share/kapooka/sprites/standard_move_out.png
share/kapooka/sprites/stuck_idle.png
share/kapooka/sprites/teleport_idle.png
@dirrm share/kapooka/sprites
@dirrm share/kapooka/sound
@dirrm share/kapooka/music
@dirrm share/kapooka/levelDummy
@dirrm share/kapooka/interface
@dirrm share/kapooka

5
games/kapooka/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2004/11/24 17:05:04 wiz Exp $
SHA1 (kapooka_0.2.tar.bz2) = b61080370ccb47ca7320e812fdcdea39a1589aca
Size (kapooka_0.2.tar.bz2) = 322009 bytes
SHA1 (patch-aa) = 429e7ae7e70854bef13a860db8699376b203c158

View file

@ -0,0 +1,20 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/11/24 17:05:04 wiz Exp $
--- Makefile.orig 2004-10-17 23:08:42.000000000 +0200
+++ Makefile
@@ -1,10 +1,10 @@
NAME=kapooka
#CC=gcc-3.0
-CC=gcc
-DESTDIR=/usr/local
-DATADIR=$(DESTDIR)/$(NAME)
-COMPILE_FLAGS=-Wall -O2 -fomit-frame-pointer `libmikmod-config --cflags` -DDATADIR=$(DATADIR) -g
-LINK_FLAGS=-lm -L /usr/X11R6/lib -L /usr/local/lib `libmikmod-config --libs` -lpthread -lSDL -lSDL_image
+#CC=gcc
+DESTDIR=${PREFIX}
+DATADIR=$(DESTDIR)/share/$(NAME)
+COMPILE_FLAGS=-Wall -DDATADIR=$(DATADIR) -g
+LINK_FLAGS=-lm -L /usr/X11R6/lib `libmikmod-config --libs` `sdl-config --libs` -lSDL_image
CFILES=$(wildcard *.c)
OFILES=$(patsubst %.c,%.o,$(CFILES))