Xmess is now part of xmame.

This commit is contained in:
soren 1999-11-10 07:58:36 +00:00
parent 3b9f25b706
commit feaf11b64b
11 changed files with 0 additions and 285 deletions

View file

@ -1,46 +0,0 @@
# $NetBSD: Makefile,v 1.12 1999/05/22 19:41:31 tv Exp $
#
DISTNAME= unix02s4
PKGNAME= xmess-0.2b4.1
CATEGORIES= emulators games x11
MASTER_SITES= http://mess.emuverse.com/files/
EXTRACT_SUFX= .tgz
MAINTAINER= mycroft@NetBSD.ORG
HOMEPAGE= http://mess.emuverse.com/
DEPENDS= unzip-5.40:../../archivers/unzip
DEPENDS+= xpm-3.4k:../../graphics/xpm
USE_X11BASE= yes
USE_GMAKE= yes
MAKE_ENV+= OPSYS=${OPSYS} ARCH=${ARCH} DESTDIR=${DESTDIR} \
INSTALL_MAN="${INSTALL_MAN}" \
INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
NETBSD_JOYSTICK="${NETBSD_JOYSTICK}" \
DISPLAY_METHOD="${DISPLAY_METHOD}"
MAKEFILE= makefile.unix
DISPLAY_METHOD= x11
ALL_TARGET= xmess.${DISPLAY_METHOD}
WRKSRC= ${WRKDIR}/xmess-0.2b4.1
MESSDIR= ${PREFIX}/share/xmess
.if exists(/usr/include/machine/joystick.h)
NETBSD_JOYSTICK= yes
.else
NETBSD_JOYSTICK= no
.endif
post-patch:
(cd ${WRKSRC}/doc && ${SED} 's|@MESSDIR@|${MESSDIR}|' xmessrc.dist >xmessrc)
(cd ${WRKSRC}/src/unix && ${MV} netbsd_i386.c netbsd.c)
do-install:
(cd ${WRKSRC} && ${INSTALL_PROGRAM} ${ALL_TARGET} ${PREFIX}/bin/xmess)
${MKDIR} ${MESSDIR}
(cd ${WRKSRC}/doc && ${INSTALL_DATA} xmessrc ${MESSDIR}/xmessrc)
@${ECHO} Remember to set MESSDIR to ${MESSDIR}.
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +0,0 @@
$NetBSD: md5,v 1.5 1999/05/22 19:41:31 tv Exp $
MD5 (unix02s4.tgz) = 2036d994aba7315d3204a9310c66f37c

View file

@ -1,7 +0,0 @@
$NetBSD: patch-sum,v 1.2 1999/07/27 03:25:04 mycroft Exp $
MD5 (patch-aa) = 7b77620362788d6c9d1bdb6f18ae0fb4
MD5 (patch-ab) = dad5320a40cf852801f674394bca1d1b
MD5 (patch-ae) = 1b18c8a385925013511d9af5d943d02c
MD5 (patch-af) = 2f2879bbe1a519ef62ca9e60814b2e66
MD5 (patch-ag) = ffcf05090ca285decdaa22188ff97f2c

View file

@ -1,142 +0,0 @@
$NetBSD: patch-aa,v 1.11 1999/07/27 03:20:38 mycroft Exp $
--- makefile.unix.orig Wed Aug 26 18:40:21 1998
+++ makefile.unix Mon Aug 31 04:06:42 1998
@@ -39,7 +39,7 @@
# GNU MAKE is MANDATORY !!!
# so please give me the path...
# if GNU make is "native" use this
-MAKE = make
+MAKE = gmake
# else ...
# MAKE=/usr/people/jantonio/bin/gmake
@@ -99,18 +99,18 @@
# *** Select destination directory for your compiled program , manual page
# and binary distribution ( if you want to... )
# ( only needed to install, not to compile... )
-DESTDIR = /usr/games
-MANDIR = /usr/local/man/man6
+DESTDIR = ${PREFIX}/bin
+MANDIR = ${PREFIX}/man/man6
DISTDIR = /home/ftp/pub/emulators/$(NAME)
# *** Where the ROM source tree ?
-ROMPATH = \"/usr/games/lib/$(NAME)\"
+ROMPATH = \"${PREFIX}/share/$(NAME)\"
# *** Where to store high scores ?
-SDIR = \"/usr/games/lib/$(NAME)\"
+SDIR = \"${PREFIX}/share/$(NAME)\"
# *** Where resides global configuration file ?
-MRC = \"/usr/games/lib/$(NAME)/$(NAME)rc\"
+MRC = \"${PREFIX}/share/$(NAME)/$(NAME)rc\"
##############################################################################
@@ -118,7 +118,9 @@
##############################################################################
# *** To disable joystick support comment next line
-# JOY = -DUSE_JOYSTICK
+ifeq (${NETBSD_JOYSTICK},yes)
+JOY = -DUSE_JOYSTICK
+endif
# *** To disable mouse support comment next line
MOUSE = -DUSE_MOUSE
@@ -137,7 +139,9 @@
# JSLIB = -lXi
# On iX86 based OS's, if supported, you can use standard joystick driver
-# JS = -DI386_JOYSTICK
+ifeq (${NETBSD_JOYSTICK},yes)
+JS = -DI386_JOYSTICK
+endif
# Linux FM-TOWNS game PAD joystick emulation support
# Thanks to Osamu Kurati for provided patch
@@ -158,8 +162,8 @@
# you might decide to use these feature. Otherwise, you should use a
# timer based audio code and ajust in src/unix/sound.h AUDIO_TIMER_FREQ item
#
-S_TIM = -DDONTUSE_TIMER
-# S_TIM = -DUSE_TIMER
+# S_TIM = -DDONTUSE_TIMER
+S_TIM = -DUSE_TIMER
# *** When using timer, you should provide the frequency to generate audio sample
# frames in your system. See readme.unix notes about these item
@@ -192,7 +196,7 @@
# note: x11 is the only one supported on all platforms
### normal X11
-DISPLAY_METHOD = x11
+#DISPLAY_METHOD = x11
### XFree86's DGA extension, only tested under linux
#DISPLAY_METHOD = xf86_dga
### svgalib, only supported under linux
@@ -215,14 +219,16 @@
# *** If you haven't the MIT-Shared Memory X Extensions, comment the following:
# ( Test if available by mean of xdpyinfo command )
# Comment it if not compiling for normal x11
-# MSHM = -DUSE_MITSHM
+ifeq (${DISPLAY_METHOD},x11)
+MSHM = -DUSE_MITSHM
+endif
# standard location for X11
# X11INC = -I/usr/include/X11
# X11LIB = -L/usr/lib/X11
# standard location for XFree86
-X11INC = -I/usr/X11R6/include
-X11LIB = -L/usr/X11R6/lib
+X11INC = -I${PREFIX}/include
+X11LIB = -L${PREFIX}/lib -Wl,-R${PREFIX}/lib
# for Sun systems
# X11INC = -I/usr/openwin/include
# X11LIB = -L/usr/openwin/lib
@@ -243,11 +249,12 @@
######## Alpha/Linux
# ARCH = linux_alpha
######## ix86/Linux
-ARCH = linux_i386
+# ARCH = linux_i386
######## ix86/FreeBSD and ix86/BSDi
# ARCH = FREEBSD
######## ix86/NetBSD
-# ARCH = netbsd_i386
+ARCH = netbsd
+MACHINE = $(shell uname -m)
######## Sparc/SunOS ( no sound )
# ARCH = sunos
######## ix86/Solaris
@@ -282,7 +289,11 @@
DEFS.linux_alpha = -Dlinux -DLSB_FIRST -DAXP_ASM -DACORN
DEFS.linux_i386 = -Dlinux -DLSB_FIRST -DX86_ASM
DEFS.FREEBSD = -DLSB_FIRST -DX86_ASM -Dlinux -DFREEBSD_SOUND_WORKAROUND
-DEFS.netbsd_i386 = -DLSB_FIRST -DX86_ASM -DNETBSD -DUSE_AUDIO
+ifeq (${MACHINE},i386)
+DEFS.netbsd = -DLSB_FIRST -DX86_ASM -DNETBSD -DUSE_AUDIO
+else
+DEFS.netbsd = -DLSB_FIRST -DACORN -DNETBSD -DUSE_AUDIO
+endif
DEFS.sunos = -Dsun -DCLOCKS_PER_SEC=1000000 -DACORN
DEFS.solaris = -Dsun -DACORN
DEFS.solaris_i386 = -DLSB_FIRST -Dsun -Dsolaris
@@ -300,12 +311,14 @@
LIBS.solaris_i386 = -lm -lnsl -lsocket
LIBS.irix = -lm -laudio
LIBS.aix = -lm -lUMSobj
+LIBS.netbsd = -lm
##############################################################################
# **** Architecture dependent cflags. Only change if you know what're you doing...
##############################################################################
CFLAGS.linux_powerpc = -fsigned-char
CFLAGS.aix = -I/usr/include/UMS -I/usr/lpp/som/include
+CFLAGS.netbsd = -fstrength-reduce -funroll-loops -fomit-frame-pointer
#############################################################################
# **** Display dependent libs. Only change if you know what're you doing...

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ab,v 1.4 1998/08/29 19:42:00 frueauf Exp $
--- src/unix/Makefile.orig Tue Aug 25 07:39:20 1998
+++ src/unix/Makefile Fri Aug 28 23:08:49 1998
@@ -16,6 +16,7 @@
$(TARGET): $(OBJS)
ar -rcv $@ $(OBJS)
+ ranlib $@
$(OBJDIR)/%.o: %.c xmame.h sound.h
$(CC) -I../../src/ $(CFLAGS) -o $@ -c $<

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ae,v 1.2 1998/08/07 10:40:37 agc Exp $
--- doc/xmessrc.dist.orig Tue Jun 9 08:14:22 1998
+++ doc/xmessrc.dist Thu Jul 9 08:11:39 1998
@@ -21,7 +21,7 @@
############################ General options ##########################
#
# Mess needs a public-writable directory to store high scores
-spooldir /var/games/mess
+spooldir @MESSDIR@
# Type here the name of the display where play xmame
# overriden by DISPLAY environment variable. Not usefull in config file but...

View file

@ -1,31 +0,0 @@
$NetBSD: patch-af,v 1.2 1998/08/07 10:40:38 agc Exp $
--- src/unix/devices.c.orig Wed Jun 17 05:48:00 1998
+++ src/unix/devices.c Sat Jul 4 07:42:07 1998
@@ -60,7 +60,7 @@
#elif I386_JOYSTICK
void i386_poll_joystick (void);
/* specific joystick for PC clones */
-#ifdef netbsd_i386
+#ifdef NETBSD
#include <machine/joystick.h>
extern struct joystick joy_data,joy_orig;
#else
@@ -658,7 +658,7 @@
{
#if ( defined USE_JOYSTICK ) && ( defined I386_JOYSTICK )
int res;
-#ifdef netbsd_i386
+#ifdef NETBSD
res = read(joy_fd,&joy_data,sizeof(struct joystick) );
if (res == sizeof(struct joystick )) {
#else
@@ -666,7 +666,7 @@
if (res == sizeof(struct JS_DATA_TYPE )) {
#endif
/* get value of buttons */
-#ifdef netbsd_i386
+#ifdef NETBSD
joy_b1 = joy_data.b1;
joy_b2 = joy_data.b2;
#else

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ag,v 1.2 1998/08/07 10:40:38 agc Exp $
--- src/unix/netbsd_i386.c.orig Fri Jun 5 07:00:43 1998
+++ src/unix/netbsd_i386.c Sat Jul 4 07:42:09 1998
@@ -5,7 +5,7 @@
* Audio code is based on the solaris driver, by jantonio@dit.upm.es
*/
-#ifdef netbsd_i386
+#ifdef NETBSD
#include "xmame.h"
#include "sound.h"

View file

@ -1 +0,0 @@
X11 emulator for game consoles

View file

@ -1,13 +0,0 @@
X-MESS is the X11 port of the MESS game console emulator.
MESS is virtual machine emulator; it includes emulators for the CPUs,
sound and video chips used in game consoles, as well as special purpose
PALs and detailed information about the memory layout of each machine.
MESS currently emulates the Nintendo Entertainment System (NES), Sega
Genesis/Megadrive, TRS-80 models 1 and 3, Colour Genie, Colecovision,
Vectrex, Apple ][ series, Atari 800, Atari 5200, Sega Master System/Game
Gear, Bally Astrocade, Kaypro 2x and PDP-1.
To play games in X-MESS you must have a copy of the original game,
extracted from a cartridge, floppy or tape image.

View file

@ -1,4 +0,0 @@
@comment $NetBSD: PLIST,v 1.2 1998/08/29 04:24:29 mycroft Exp $
bin/xmess
share/xmess/xmessrc
@dirrm share/xmess