Reimport of p5-BigInteger as p5-Math-BigInteger.
This commit is contained in:
parent
0add1997de
commit
fec180220c
5 changed files with 52 additions and 0 deletions
18
math/p5-Math-BigInteger/Makefile
Normal file
18
math/p5-Math-BigInteger/Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2001/04/27 23:16:31 jtb Exp $
|
||||
|
||||
DISTNAME= Math-BigInteger-1.0
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
CATEGORIES= math perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Math/}
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
COMMENT= Arbitrary length integer extension module for Perl
|
||||
|
||||
USE_PERL5= #defined
|
||||
PERL5_PACKLIST= ${PERL5_SITEARCH}/auto/Math/BigInteger/.packlist
|
||||
|
||||
do-configure:
|
||||
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
5
math/p5-Math-BigInteger/distinfo
Normal file
5
math/p5-Math-BigInteger/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2001/04/27 23:16:31 jtb Exp $
|
||||
|
||||
SHA1 (Math-BigInteger-1.0.tar.gz) = 15a738cfee2e0d235b324c07e477739c747f62f7
|
||||
Size (Math-BigInteger-1.0.tar.gz) = 19869 bytes
|
||||
SHA1 (patch-aa) = 3a3d3792e499dc1cd5104c9db5e0e9c4aa03e35e
|
24
math/p5-Math-BigInteger/patches/patch-aa
Normal file
24
math/p5-Math-BigInteger/patches/patch-aa
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2001/04/27 23:16:31 jtb Exp $
|
||||
|
||||
--- bn.c.orig Wed Feb 7 20:53:14 2001
|
||||
+++ bn.c
|
||||
@@ -304,8 +304,8 @@
|
||||
int i,j,v,z=0;
|
||||
static char *hex="0123456789ABCDEF";
|
||||
|
||||
- if (a->neg) Fputc('-',fp);
|
||||
- if (a->top == 0) Fputc('0',fp);
|
||||
+ if (a->neg) fputc('-',fp);
|
||||
+ if (a->top == 0) fputc('0',fp);
|
||||
for (i=a->top-1; i >=0; i--)
|
||||
{
|
||||
for (j=BITS2-4; j >= 0; j-=4)
|
||||
@@ -314,7 +314,7 @@
|
||||
v=(a->d[i]>>j)&0x0f;
|
||||
if (z || (v != 0))
|
||||
{
|
||||
- Fputc(hex[v],fp);
|
||||
+ fputc(hex[v],fp);
|
||||
z=1;
|
||||
}
|
||||
}
|
4
math/p5-Math-BigInteger/pkg/DESCR
Normal file
4
math/p5-Math-BigInteger/pkg/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
The BigInteger extension module gives access to Eric Young's bignum
|
||||
library. This provides a faster alternative to the Math::BigInt
|
||||
library. The basic object in this library is a BigInteger. It is used
|
||||
to hold a single large integer.
|
1
math/p5-Math-BigInteger/pkg/PLIST
Normal file
1
math/p5-Math-BigInteger/pkg/PLIST
Normal file
|
@ -0,0 +1 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2001/04/27 23:16:31 jtb Exp $
|
Loading…
Reference in a new issue