py-robobrowser: Add support for Python 3.7
re.Pattern should be used instead of re._pattern_type in Python 3.7.
This commit is contained in:
parent
2a4c3ffcfd
commit
fefd4e9b72
2 changed files with 16 additions and 1 deletions
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2017/02/01 15:27:14 leot Exp $
|
||||
$NetBSD: distinfo,v 1.2 2018/10/12 23:08:10 leot Exp $
|
||||
|
||||
SHA1 (robobrowser-0.5.3.tar.gz) = 82e6e6efa161d0d9bf73677332ad97981d760d9a
|
||||
RMD160 (robobrowser-0.5.3.tar.gz) = d2192d22f67b09cd07730784123f1a92ecccd6fa
|
||||
SHA512 (robobrowser-0.5.3.tar.gz) = d26d351d65fc963459b49ff277c2c412165ee70b75f17581f61991ef6000cdf574648b72e65ef778425f7023a14109f02b1a0e53b67d9ac793941d0382060f54
|
||||
Size (robobrowser-0.5.3.tar.gz) = 22040 bytes
|
||||
SHA1 (patch-robobrowser_helpers.py) = 8abcbb33dbc487698a0c5717ef1e1e4079490457
|
||||
|
|
14
www/py-robobrowser/patches/patch-robobrowser_helpers.py
Normal file
14
www/py-robobrowser/patches/patch-robobrowser_helpers.py
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-robobrowser_helpers.py,v 1.1 2018/10/12 23:08:10 leot Exp $
|
||||
|
||||
Add support for Python 3.7.
|
||||
|
||||
--- robobrowser/helpers.py.orig 2015-06-07 19:27:41.000000000 +0000
|
||||
+++ robobrowser/helpers.py
|
||||
@@ -3,6 +3,7 @@ Miscellaneous helper functions
|
||||
"""
|
||||
|
||||
import re
|
||||
+re._pattern_type = getattr(re, '_pattern_type', re.Pattern)
|
||||
|
||||
from bs4 import BeautifulSoup
|
||||
from bs4.element import Tag
|
Loading…
Reference in a new issue