Update to 0.89.0. Renumbered patches because it got increasingly difficult
to track patches to individual files. We now install only the Motif-2.0 compatible libraries and the Motif-2.0 compatible include files. Changes from 0.88.9: * Add FontChooser widget to Xlt. * Fix to XmText to make a second call to SetValues with the same pointer still work. * Added a directory tree lib/Xbae which contains the Xbae widget set (XbaeMatrix, XbaeCaption, and XbaeInput). * Made build system changes to build Xbae in the same way as Xlt. * Add build system options to Xlt and/or Xbae can be compiled together with LessTif. Use the --enable-build-Xlt and --enable-build-Xbae options. * Xbae contains both automake-based and Imake based build support; we're not sure how actively we'll support Imake though. * RowColumn tear-off segfault fix. * Fixed segfault with xmgrace. * various fixes for openDX * VaSimpleOption fix for Xquote * fixes for mapCallback for DialogShells with BulletionBoard children * Even though binary compatibility is not our true goal, Netscape-dynMotif (4.61) now runs out-of-the-box with lesstif! * Initial attempts at making lesstif threadsafe (PushB, PushBG) * mxftp should now work * XmScrolledWindow/XmScrollBar geometry fixes * Many compilation warnings silenced.
This commit is contained in:
parent
ecb6971b7b
commit
ff17d3c80f
4 changed files with 0 additions and 80 deletions
|
@ -1,20 +0,0 @@
|
|||
$NetBSD: patch-ca,v 1.1 1999/09/03 19:45:12 drochner Exp $
|
||||
--- include/Motif-2.0/Mrm/Makefile.in.orig Tue Aug 17 00:04:38 1999
|
||||
+++ include/Motif-2.0/Mrm/Makefile.in Tue Aug 17 00:05:35 1999
|
||||
@@ -119,7 +119,7 @@
|
||||
# Lets put the headers in a sub directory to avoid
|
||||
# poluting /usr/local with more directories for default installs.
|
||||
#
|
||||
-@Version_2_0_TRUE@mrmdir = $(prefix)/LessTif/Motif2.0/include/Mrm
|
||||
+@Version_2_0_TRUE@mrmdir = $(prefix)/include/Mrm
|
||||
|
||||
@Version_2_0_TRUE@HEADERS1_2 = MrmAppl.h MrmDecls.h MrmPrivate.h MrmPublic.h
|
||||
|
||||
@@ -218,7 +218,6 @@
|
||||
|
||||
install-data-am: install-mrmHEADERS
|
||||
@$(NORMAL_INSTALL)
|
||||
- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
|
||||
install-data: install-data-am
|
||||
|
||||
install-am: all-am
|
|
@ -1,20 +0,0 @@
|
|||
$NetBSD: patch-cb,v 1.1 1999/09/03 19:45:12 drochner Exp $
|
||||
--- include/Motif-2.0/Xm/Makefile.in.orig Tue Aug 17 00:06:46 1999
|
||||
+++ include/Motif-2.0/Xm/Makefile.in Tue Aug 17 00:07:17 1999
|
||||
@@ -119,7 +119,7 @@
|
||||
# Lets put the headers in a sub directory to avoid
|
||||
# poluting /usr/local with more directories for default installs.
|
||||
#
|
||||
-@Version_2_0_TRUE@xmdir = $(prefix)/LessTif/Motif2.0/include/Xm
|
||||
+@Version_2_0_TRUE@xmdir = $(prefix)/include/Xm
|
||||
|
||||
@Version_2_0_TRUE@HEADERS1_2 = ArrowB.h ArrowBG.h AtomMgr.h BaseClassP.h BulletinB.h BulletinBP.h CacheP.h CascadeB.h CascadeBG.h CascadeBGP.h CascadeBP.h Command.h CommandP.h CutPaste.h CutPasteP.h DesktopP.h DialogS.h DialogSEP.h DialogSP.h Display.h DisplayP.h DragC.h DragCP.h DragDrop.h DragIcon.h DragIconP.h DragOverS.h DragOverSP.h DrawingA.h DrawnB.h DrawnBP.h DropSMgr.h DropSMgrP.h DropTrans.h DropTransP.h ExtObjectP.h FileSB.h FileSBP.h Form.h FormP.h Frame.h FrameP.h Label.h LabelG.h LabelGP.h LabelP.h List.h ListP.h MainW.h MainWP.h MenuShell.h MenuUtilP.h MessageB.h MessageBP.h MwmUtil.h PanedW.h Protocols.h ProtocolsP.h PushB.h PushBG.h PushBGP.h PushBP.h RCUtilsP.h RepType.h RowColumn.h RowColumnP.h SashP.h Scale.h Screen.h ScreenP.h ScrollBar.h ScrollBarP.h ScrolledW.h SelectioB.h SelectioBP.h SeparatoG.h SeparatoGP.h Separator.h SeparatorP.h ShellEP.h TearOffBP.h TearOffP.h Text.h TextF.h TextFP.h TextFSelP.h TextInP.h TextOutP.h TextP.h TextSelP.h TextStrSoP.h ToggleB.h ToggleBG.h VaSimpleP.h VendorS.h VendorSEP.h VendorSP.h VirtKeys.h VirtKeysP.h WorldP.h XmosP.h
|
||||
|
||||
@@ -248,7 +248,6 @@
|
||||
|
||||
install-data-am: install-xmDATA install-xmHEADERS
|
||||
@$(NORMAL_INSTALL)
|
||||
- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
|
||||
install-data: install-data-am
|
||||
|
||||
install-am: all-am
|
|
@ -1,20 +0,0 @@
|
|||
$NetBSD: patch-cc,v 1.1 1999/09/03 19:45:12 drochner Exp $
|
||||
--- lib/Mrm-2.0/Makefile.in.orig Tue Aug 17 00:08:08 1999
|
||||
+++ lib/Mrm-2.0/Makefile.in Tue Aug 17 00:09:41 1999
|
||||
@@ -121,7 +121,7 @@
|
||||
|
||||
EXTRA_DIST = ${SRCS_2_0}
|
||||
|
||||
-@Version_2_0_TRUE@libdir = $(prefix)/LessTif/Motif2.0/lib
|
||||
+@Version_2_0_TRUE@libdir = $(prefix)/lib
|
||||
|
||||
#
|
||||
# Sources in another directory
|
||||
@@ -312,7 +312,6 @@
|
||||
|
||||
install-data-am:
|
||||
@$(NORMAL_INSTALL)
|
||||
- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
|
||||
install-data: install-data-am
|
||||
|
||||
install-am: all-am
|
|
@ -1,20 +0,0 @@
|
|||
$NetBSD: patch-cd,v 1.1 1999/09/03 19:45:12 drochner Exp $
|
||||
--- lib/Xm-2.0/Makefile.in.orig Tue Aug 17 00:10:45 1999
|
||||
+++ lib/Xm-2.0/Makefile.in Tue Aug 17 00:11:08 1999
|
||||
@@ -143,7 +143,7 @@
|
||||
# Lets put the headers in a sub directory to avoid
|
||||
# poluting /usr/local with more directories for default installs.
|
||||
#
|
||||
-@Version_2_0_TRUE@libdir = $(prefix)/LessTif/Motif2.0/lib
|
||||
+@Version_2_0_TRUE@libdir = $(prefix)/lib
|
||||
|
||||
@Version_2_0_TRUE@lib_LTLIBRARIES = libXm.la
|
||||
|
||||
@@ -339,7 +339,6 @@
|
||||
|
||||
install-data-am:
|
||||
@$(NORMAL_INSTALL)
|
||||
- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
|
||||
install-data: install-data-am
|
||||
|
||||
install-am: all-am
|
Loading…
Reference in a new issue