Add py-jsparser-2.4.5, a fast Javascript parser in Python.
This commit is contained in:
parent
6a73e52472
commit
ff2d2bbb0b
5 changed files with 62 additions and 0 deletions
1
lang/py-jsparser/DESCR
Normal file
1
lang/py-jsparser/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
This module implements a fast Javascript parser.
|
17
lang/py-jsparser/Makefile
Normal file
17
lang/py-jsparser/Makefile
Normal file
|
@ -0,0 +1,17 @@
|
|||
# $NetBSD: Makefile,v 1.1 2017/02/07 23:48:57 joerg Exp $
|
||||
|
||||
VERS= 2.4.5
|
||||
DISTNAME= pyjsparser-${VERS}
|
||||
PKGNAME= ${PYPKGPREFIX}-jsparser-${VERS}
|
||||
CATEGORIES= python lang
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=p/pyjsparser/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://pypi.python.org/pypi/pyjsparser/
|
||||
COMMENT= Pure-Python Javascript parser
|
||||
LICENSE= mit
|
||||
|
||||
USE_LANGUAGES= # empty
|
||||
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
17
lang/py-jsparser/PLIST
Normal file
17
lang/py-jsparser/PLIST
Normal file
|
@ -0,0 +1,17 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2017/02/07 23:48:57 joerg Exp $
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
|
||||
${PYSITELIB}/pyjsparser/__init__.py
|
||||
${PYSITELIB}/pyjsparser/__init__.pyc
|
||||
${PYSITELIB}/pyjsparser/__init__.pyo
|
||||
${PYSITELIB}/pyjsparser/parser.py
|
||||
${PYSITELIB}/pyjsparser/parser.pyc
|
||||
${PYSITELIB}/pyjsparser/parser.pyo
|
||||
${PYSITELIB}/pyjsparser/pyjsparserdata.py
|
||||
${PYSITELIB}/pyjsparser/pyjsparserdata.pyc
|
||||
${PYSITELIB}/pyjsparser/pyjsparserdata.pyo
|
||||
${PYSITELIB}/pyjsparser/std_nodes.py
|
||||
${PYSITELIB}/pyjsparser/std_nodes.pyc
|
||||
${PYSITELIB}/pyjsparser/std_nodes.pyo
|
7
lang/py-jsparser/distinfo
Normal file
7
lang/py-jsparser/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2017/02/07 23:48:57 joerg Exp $
|
||||
|
||||
SHA1 (pyjsparser-2.4.5.tar.gz) = 14ae78908511f06124f3f1744dc219361e5cb004
|
||||
RMD160 (pyjsparser-2.4.5.tar.gz) = 5659643be312b9b0fc5f88168e7de1eb86fbe315
|
||||
SHA512 (pyjsparser-2.4.5.tar.gz) = cec6633ffa938d4db1ef9164bf4eca7459fca3635f1ef090b00668b4e5fb170e466bb5d6b3b063388cd3de156d770eb4c08e21bb3a99b0e9761553a00701913c
|
||||
Size (pyjsparser-2.4.5.tar.gz) = 24061 bytes
|
||||
SHA1 (patch-setup.py) = e265fba1f7a19fbf7f72b6c8321adefc4c26179b
|
20
lang/py-jsparser/patches/patch-setup.py
Normal file
20
lang/py-jsparser/patches/patch-setup.py
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-setup.py,v 1.1 2017/02/07 23:48:57 joerg Exp $
|
||||
|
||||
--- setup.py.orig 2017-02-07 17:06:34.545212473 +0000
|
||||
+++ setup.py
|
||||
@@ -1,11 +1,13 @@
|
||||
-from distutils.core import setup
|
||||
+try:
|
||||
+ from setuptools import setup
|
||||
+except ImportError:
|
||||
+ from distutils.core import setup
|
||||
|
||||
setup(
|
||||
name='pyjsparser',
|
||||
version='2.4.5',
|
||||
packages=['pyjsparser'],
|
||||
url='https://github.com/PiotrDabkowski/pyjsparser',
|
||||
- install_requires = [],
|
||||
license='MIT',
|
||||
author='Piotr Dabkowski',
|
||||
author_email='piodrus@gmail.com',
|
Loading…
Reference in a new issue