p5-Module-FromPerlVer: update to 0.005005.

-   v0.5.5 Thu Mar 15 20:05:10 CDT 2018

    Fix make-sandbox-dir.

    Fix MANIFEST

    Alwyas remove version, dynamic, sandbox/.git dir's in ./t
    to force running the build code during module packaging.

    Snag path search using File::Spec from FindBin::libs, doesn't
    seem to be any other way to deal with Windows (or VMS).

    Re-factor tests into Test::KwikHak to avoid cut+paste errors.

    Add steparate step to re-extract tarball and use Makefile.PL +
    make all test install prior to upload to verify MANIFEST
    contents (not visible in package, other than that perhaps
    the manifest is more likely to represent the necessary files).

-   v0.5.3 Wed Mar 14 22:18:31 CDT 2018

    Unlink all version.* tmp files.

    Deal with MSW filesystem not using '/' for the root.

    Missing file in MANIFEST.

-   v0.5.2 Wed Mar 14 16:16:10 CDT 2018

    Fix no 5.0 test to account for '5' or '5.'.

    Add test 13-*.t to check full variety of versions with 'no 5',
    hence the improvements in the no-5.0 check.

    Fix MANIFEST.

    Add strict to tests, fix undef vars.

-   v0.5.1 Wed Mar 14 13:43:46 CDT 2018

    Handle edge case "no 5.0.0".

    Search up $Bin for version directory. Simplifies handing standard
    path with test sub-dirs. "version_dir" can be path to any existing
    directory or the path will be searched up $Bin to the root.

    Test cleanups.

    More example output in POD.

-   v0.5.0 Tue Mar 13 18:24:57 CDT 2018

    Working version_from handler.

    Kwikhaks to generate version directory for a variety of
    version formats (make-version-dir) and recover the sandbox
    (make-sandbox-dir).

    Generator for dynamic tests based on version dir's (make-tests).

    The t/bin/make-* files are called from Makefile.PL.

-   v0.4.4 Mon Mar 12 10:14:04 CDT 2018

    Fix botched path in usability for extracting the
    sandbox .git.

-   v0.4.3 Sun Mar 11 14:08:02 CDT 2018

    Added tests, shell script to generate minimal
    sandbox test directory (extracted as necessary
    via 0-usable.t). this needs to be re-run if
    there are changes to the ./version directory.

    Added shell snippets to acquire usable test list
    into MANIFEST. The trick here is grabbing all of
    ./t other than the stub .git directory and including
    the ./t/sandbox/.git.tar file.
This commit is contained in:
wiz 2018-03-17 07:46:14 +00:00
parent 7546b17aa6
commit ff66e968bd
4 changed files with 47 additions and 7 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.5 2018/03/11 10:18:41 wiz Exp $
# $NetBSD: Makefile,v 1.6 2018/03/17 07:46:14 wiz Exp $
DISTNAME= Module-FromPerlVer-0.004002
DISTNAME= Module-FromPerlVer-0.005005
PKGNAME= p5-${DISTNAME}
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Module/}
@ -11,11 +11,18 @@ COMMENT= Install modules compatible with the running perl
LICENSE= ${PERL5_LICENSE}
DEPENDS+= p5-File-Copy-Recursive-[0-9]*:../../sysutils/p5-File-Copy-Recursive
DEPENDS+= p5-List-MoreUtils-[0-9]*:../../devel/p5-List-MoreUtils
# TEST_DEPENDS
BUILD_DEPENDS+= p5-Test-Deep-[0-9]*:../../devel/p5-Test-Deep
# 3 test failures in 0.004002
PERL5_PACKLIST= auto/Module/FromPerlVer/.packlist
USE_TOOLS+= perl
REPLACE_PERL+= t/bin/make-version-dir
REPLACE_PERL+= t/bin/make-sandbox-dir
REPLACE_PERL+= t/bin/make-tests
REPLACE_SH+= t/bin/make-sandbox-tarball
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.5 2018/03/11 10:18:41 wiz Exp $
$NetBSD: distinfo,v 1.6 2018/03/17 07:46:14 wiz Exp $
SHA1 (Module-FromPerlVer-0.004002.tar.gz) = 20adc6c16c36ff0365bbe72b7be5b102d47a39ad
RMD160 (Module-FromPerlVer-0.004002.tar.gz) = 3c4d4401a368716564e9d2ba202d824a0965c14d
SHA512 (Module-FromPerlVer-0.004002.tar.gz) = e3760b8aa72d5182902e1f0c2b92ddf53e1ba3576f1948171d8447f0746a5d920dc8a0ed01587bd6e1db7614a72501fb6ba4dd8a605e311e52649414e97c46dd
Size (Module-FromPerlVer-0.004002.tar.gz) = 31813 bytes
SHA1 (Module-FromPerlVer-0.005005.tar.gz) = d886385575e33754a6ab88a37143c2ff37119dd4
RMD160 (Module-FromPerlVer-0.005005.tar.gz) = 67a8dfdefcb13bf4d2d7dfaf1c0628c872210fc9
SHA512 (Module-FromPerlVer-0.005005.tar.gz) = d49c926942e8ad9b4b58f4f346da7ee68d323da6e6ab3bed9e67c41ddcc2f9a235aba552da317eb2e017283ea9811c70609c12390e316af737cab3db3b3ccc65
Size (Module-FromPerlVer-0.005005.tar.gz) = 34162 bytes
SHA1 (patch-MANIFEST) = cd9b03da38a0449bb6145adb46f0c91bfab0003d
SHA1 (patch-Makefile.PL) = 50dc79e42d667722546a351df1e8624a18d4fc09

View file

@ -0,0 +1,15 @@
$NetBSD: patch-MANIFEST,v 1.1 2018/03/17 07:46:15 wiz Exp $
Fix incorrect MANIFEST.
https://rt.cpan.org/Ticket/Display.html?id=124776
--- MANIFEST.orig 2018-03-16 01:10:01.000000000 +0000
+++ MANIFEST
@@ -33,7 +33,6 @@ t/bin/31-git-local-version-from_t
t/bin/make-sandbox-dir
t/bin/make-sandbox-tarball
t/bin/make-tests
-t/bin/make-tests~
t/bin/make-version-dir
t/lib/Test/KwikHaks.pm

View file

@ -0,0 +1,16 @@
$NetBSD: patch-Makefile.PL,v 1.1 2018/03/17 07:46:15 wiz Exp $
Fix path to env(1).
https://rt.cpan.org/Ticket/Display.html?id=124776
--- Makefile.PL.orig 2018-03-16 01:09:46.000000000 +0000
+++ Makefile.PL
@@ -36,7 +36,7 @@ for my $base
print "Setup: '$path'";
- system "/bin/env perl $path";
+ system "/usr/bin/env perl $path";
my $err = $!;
print "$path fails: $err"