py27-cryptography: Fix use with OpenSSL 3.x

pkgsrc changes:
---------------
  * Add patches to disable deprecated functions with OpenSSL 3.x.
  * Bump revision.
This commit is contained in:
triaxx 2024-01-04 20:49:27 +00:00
parent faeef76be7
commit ff6e40bede
4 changed files with 34 additions and 3 deletions

View File

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.9 2023/11/05 13:42:01 wiz Exp $
# $NetBSD: Makefile,v 1.10 2024/01/04 20:49:27 triaxx Exp $
DISTNAME= cryptography-3.3.2
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 4
PKGREVISION= 5
CATEGORIES= security python
MASTER_SITES= ${MASTER_SITE_PYPI:=c/cryptography/}

View File

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.1 2022/04/21 10:48:49 wiz Exp $
$NetBSD: distinfo,v 1.2 2024/01/04 20:49:27 triaxx Exp $
BLAKE2s (cryptography-3.3.2.tar.gz) = 8ff42f679d01215069547cd6ca98b9f9f828ef7d85397b5d7af260c5a67718f1
SHA512 (cryptography-3.3.2.tar.gz) = 55f6ee13342b3209b1fcb310f4c4d33d22856ee785cb2347e6ad36c34e9b42f6e0d5bece8e458b09663a5b78e34c4567fe7a211b51ca71f55ccc93e3f62dc5e4
Size (cryptography-3.3.2.tar.gz) = 539883 bytes
SHA1 (patch-src___cffi__src_openssl_err.py) = 79b61e66b37fe7c63dad710fb2c9c09d61ff36c6
SHA1 (patch-src___cffi__src_openssl_fips.py) = 3254d5508d44b8a72f49d2564ad413e2ed3cbfc8

View File

@ -0,0 +1,14 @@
$NetBSD: patch-src___cffi__src_openssl_err.py,v 1.1 2024/01/04 20:49:27 triaxx Exp $
Disable deprecated function with OpenSSL 3.x.
--- src/_cffi_src/openssl/err.py.orig 2021-02-07 16:39:35.000000000 +0000
+++ src/_cffi_src/openssl/err.py
@@ -46,4 +46,7 @@ int ERR_GET_REASON(unsigned long);
"""
CUSTOMIZATIONS = """
+#if OPENSSL_VERSION_MAJOR >= 3
+int (*ERR_GET_FUNC)(unsigned long) = NULL;
+#endif
"""

View File

@ -0,0 +1,15 @@
$NetBSD: patch-src___cffi__src_openssl_fips.py,v 1.1 2024/01/04 20:49:27 triaxx Exp $
Disable deprecated function with OpenSSL 3.x.
--- src/_cffi_src/openssl/fips.py.orig 2021-02-07 16:39:35.000000000 +0000
+++ src/_cffi_src/openssl/fips.py
@@ -18,7 +18,7 @@ int FIPS_mode(void);
"""
CUSTOMIZATIONS = """
-#if CRYPTOGRAPHY_IS_LIBRESSL
+#if CRYPTOGRAPHY_IS_LIBRESSL || OPENSSL_VERSION_MAJOR >= 3
static const long Cryptography_HAS_FIPS = 0;
int (*FIPS_mode_set)(int) = NULL;
int (*FIPS_mode)(void) = NULL;