Fix build on SunOS.

The makefile uses uname -m to decide which programs to build on i386 vs.
x86_64 (and then builds the same programs on both, but thats a different
story). Teach it about i86pc, which is what SunOS usually returns on an
x86 machine.
This commit is contained in:
hans 2012-02-20 17:27:33 +00:00
parent 3d8c4392cf
commit ff8fc2b050
2 changed files with 12 additions and 4 deletions

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.10 2011/02/12 11:09:30 shattered Exp $
$NetBSD: distinfo,v 1.11 2012/02/20 17:27:33 hans Exp $
SHA1 (dmidecode-2.11.tar.gz) = 4b53195a10b74869fda6e0c3bf84a5e1be8761be
RMD160 (dmidecode-2.11.tar.gz) = 8126cc464fb441f025ddf0cbef4ee04ec71b1773
Size (dmidecode-2.11.tar.gz) = 66389 bytes
SHA1 (patch-aa) = 15030aee9d7cc0eb91c04911cb8dcea8d5e4aee4
SHA1 (patch-aa) = 6c861b3742b1627a1b60dbaea9df0843f2ed603d

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.4 2006/12/23 10:30:59 wiz Exp $
$NetBSD: patch-aa,v 1.5 2012/02/20 17:27:33 hans Exp $
--- Makefile.orig 2005-10-03 20:38:20.000000000 +0200
+++ Makefile
@@ -22,9 +22,9 @@ CFLAGS += -O2
@@ -26,9 +26,9 @@ CFLAGS += -O2
LDFLAGS =
DESTDIR =
@ -14,3 +14,11 @@ $NetBSD: patch-aa,v 1.4 2006/12/23 10:30:59 wiz Exp $
man8dir = $(mandir)/man8
docdir = $(prefix)/share/doc/dmidecode
@@ -48,6 +48,7 @@ PROGRAMS-i586 := $(PROGRAMS-i386)
PROGRAMS-i686 := $(PROGRAMS-i386)
PROGRAMS-x86_64 := biosdecode ownership vpddecode
PROGRAMS-amd64 := $(PROGRAMS-x86_64)
+PROGRAMS-i86pc := $(PROGRAMS-x86_64)
PROGRAMS := dmidecode $(PROGRAMS-$(MACHINE))