Update to 1.6.1, provided by the maintainer Hauke Fath in PR 33938.

Changes from 1.6.0:
    - Fixed non OS X compile bug

 Major changes from 1.5.1:
    - Added support for network communication compression ( patch #1348172 )
      Thanks Maarten Thibaut for the original code

    - OS X Package contains universal binaries.

 Other Changes
    - config file now supports optional comment in third column

    - lapply fix for OS X symlink permission bug ( bug #1441965 )

    - Fixes for AppleSingle support on i386. ( bug #1438290 )

    - lmerge -f no longer duplicates some minus lines ( bug 1346368 )

    - Server logs child process stats including blocks in and out

    - specify user to ra.sh with -U ( patch #1435665 )
      Thanks Sean Sweda

    - ra.sh prompt for username when USER=root ( patch #1420980 )
      Thanks Sean Sweda

    - ra.sh uses $SUDO_USER if set

    - fixed errno assignment if FD_ISSET fails ( libsnet bug #1436043 )
      Thanks Matt Selsky

    - ktcheck not sending quit if special file is created ( bug #1429169 )

    - twhich can deal with null/empty transcript ( bug 1372729 )

    - Pass correct configure args to libsnet for ssl and sasl ( bug #1435999 )
      Thanks Matt Selsky

    - ./configure now warns if tmp exists ( patch #1384558 )
      Thanks Jose Calhariz
    - ./configure now supports DISTDIR ( patch #1384555 )
      Thanks Jose Calhariz

    - Explaining the numeric range in radmind.8 ( patch #1408441 )
      Thanks David Coulthart

    - moved MIN and MAX to config.h

    - Added COMP info to SPEC

    - Apple package will install /var/radmind/client, preapply and postapply

    - make dist now follows symlinks
This commit is contained in:
wiz 2006-07-17 17:59:05 +00:00
parent a5c6b68a4d
commit ffaa2bbbcd
4 changed files with 22 additions and 22 deletions

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.9 2006/01/18 13:11:56 joerg Exp $
# $NetBSD: Makefile,v 1.10 2006/07/17 17:59:05 wiz Exp $
#
DISTNAME= radmind-1.5.1
DISTNAME= radmind-1.6.1
CATEGORIES= sysutils
MASTER_SITES= http://rsug.itd.umich.edu/software/radmind/files/
EXTRACT_SUFX= .tgz
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=radmind/}
EXTRACT_SUFX= .tar.gz
MAINTAINER= hf@spg.tu-darmstadt.de
HOMEPAGE= http://rsug.itd.umich.edu/software/radmind/

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.7 2006/01/18 13:11:56 joerg Exp $
$NetBSD: distinfo,v 1.8 2006/07/17 17:59:05 wiz Exp $
SHA1 (radmind-1.5.1.tgz) = 10d79eec04341796e039e1f93167bf19c32c6b6f
RMD160 (radmind-1.5.1.tgz) = eb16c4852be5e9d942e732ce9f8b9bc2b1241827
Size (radmind-1.5.1.tgz) = 353879 bytes
SHA1 (radmind-1.6.1.tar.gz) = e5058aff8119ffa4915081c8dffa4b38e4cee1f8
RMD160 (radmind-1.6.1.tar.gz) = 01cd361dd527ba77ae8b1c1c90fba726a5d51487
Size (radmind-1.6.1.tar.gz) = 360036 bytes
SHA1 (patch-aa) = 3c0467baeda68d1013ab09288c71bfc75c8738b9
SHA1 (patch-ab) = b9f766e9383bd289e980faa0fdbc281e33e42059
SHA1 (patch-ab) = e01889e50bb74759d997d19bcd85d3ae5ea8f0f1
SHA1 (patch-ac) = c1ea9930b9c2fee94a0b0d43e8aeec1925e454e7
SHA1 (patch-ad) = 1e69e4ddf4d255b4673261eb6b16015ce8bb5dd3
SHA1 (patch-ad) = 40974d0b41be44c2ebd0d29dca31bcc42837328a
SHA1 (patch-ae) = 58b15301aa1df00e6e5bab9f21db8ddc99461f2a

View file

@ -1,17 +1,17 @@
$NetBSD: patch-ab,v 1.3 2006/01/18 13:11:56 joerg Exp $
$NetBSD: patch-ab,v 1.4 2006/07/17 17:59:05 wiz Exp $
--- ra.sh.orig 2005-12-07 21:10:01.000000000 +0100
--- ra.sh.orig 2006-02-21 22:57:54.000000000 +0100
+++ ra.sh
@@ -24,7 +24,7 @@ KFILE="_RADMIND_COMMANDFILE"
SERVER="_RADMIND_HOST"
@@ -25,7 +25,7 @@ SERVER="_RADMIND_HOST"
TLSLEVEL="_RADMIND_AUTHLEVEL"
EDITOR=${EDITOR:-vi}
USER=${SUDO_USER:-$USER}
-DEFAULTS="/etc/defaults/radmind"
+DEFAULTS="_PKG_SYSCONFDIR/radmind.defaults"
FSDIFFROOT="."
FLAG="_RADMIND_DIR/client/.RadmindRunning"
CHECKEDOUT="_RADMIND_DIR/client/.CheckedOut"
@@ -34,7 +34,7 @@ VERSION=_RADMIND_VERSION
@@ -35,7 +35,7 @@ VERSION=_RADMIND_VERSION
PREAPPLY="_RADMIND_PREAPPLY"
POSTAPPLY="_RADMIND_POSTAPPLY"
@ -20,7 +20,7 @@ $NetBSD: patch-ab,v 1.3 2006/01/18 13:11:56 joerg Exp $
RETRY=10
MKTEMP="_RADMIND_MKTEMP"
@@ -50,14 +50,6 @@ fi
@@ -51,14 +51,6 @@ fi
LTMP="${TMPDIR}/lapply.out"
FTMP="${TMPDIR}/fsdiff.out"
@ -35,7 +35,7 @@ $NetBSD: patch-ab,v 1.3 2006/01/18 13:11:56 joerg Exp $
Yn() {
echo -n "$*" "[Yn] "
read ans
@@ -88,7 +80,7 @@ cleanup() {
@@ -89,7 +81,7 @@ cleanup() {
dopreapply() {
if [ -d ${PREAPPLY} ]; then
@ -44,7 +44,7 @@ $NetBSD: patch-ab,v 1.3 2006/01/18 13:11:56 joerg Exp $
if [ ${SCRIPTS} ]; then
for script in ${SCRIPTS}; do
${script} "$1"
@@ -99,7 +91,7 @@ dopreapply() {
@@ -100,7 +92,7 @@ dopreapply() {
dopostapply() {
if [ -d ${POSTAPPLY} ]; then

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ad,v 1.1 2006/01/13 19:16:06 joerg Exp $
$NetBSD: patch-ad,v 1.2 2006/07/17 17:59:05 wiz Exp $
--- connect.c.orig 2006-01-13 19:03:13.000000000 +0000
--- connect.c.orig 2006-03-03 15:29:20.000000000 +0100
+++ connect.c
@@ -11,6 +11,7 @@
#include <netinet/in.h>
@ -10,11 +10,11 @@ $NetBSD: patch-ad,v 1.1 2006/01/13 19:16:06 joerg Exp $
#include <netdb.h>
#include <stdio.h>
#include <stdlib.h>
@@ -30,7 +31,6 @@
@@ -36,7 +37,6 @@
extern void (*logger)( char * );
extern int verbose;
struct timeval timeout = { 60, 0 };
-extern int errno;
extern SSL_CTX *ctx;
static SNET *
#ifdef HAVE_ZLIB