Adapt reader.conf handling to pcsc-lite changes.

This commit is contained in:
hasso 2009-10-02 12:38:44 +00:00
parent f0989b1333
commit fface6f887
5 changed files with 46 additions and 2 deletions

10
security/openct/DEINSTALL Normal file
View file

@ -0,0 +1,10 @@
#!/bin/sh
# $NetBSD: DEINSTALL,v 1.1 2009/10/02 12:38:44 hasso Exp $
case ${STAGE} in
POST-DEINSTALL)
if [ -x ${PREFIX}/sbin/update-reader.conf ]; then
${PREFIX}/sbin/update-reader.conf
fi
;;
esac

10
security/openct/INSTALL Normal file
View file

@ -0,0 +1,10 @@
#!/bin/sh
# $NetBSD: INSTALL,v 1.1 2009/10/02 12:38:44 hasso Exp $
case ${STAGE} in
POST-INSTALL)
if [ -x ${PREFIX}/sbin/update-reader.conf ]; then
${PREFIX}/sbin/update-reader.conf
fi
;;
esac

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.5 2009/09/25 08:36:05 hasso Exp $
# $NetBSD: Makefile,v 1.6 2009/10/02 12:38:44 hasso Exp $
DISTNAME= openct-0.6.18
PKGREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.opensc-project.org/files/openct/
@ -23,8 +24,10 @@ RCD_SCRIPTS= openct
MAKE_DIRS+= ${VARBASE}/openct
MAKE_DIRS+= ${VARBASE}/openct/run
MAKE_DIRS+= ${VARBASE}/openct/run/openct
MAKE_DIRS+= ${PKG_SYSCONFDIR}/reader.conf.d
EGDIR= ${PREFIX}/share/examples/openct
CONF_FILES+= ${EGDIR}/openct.conf ${PKG_SYSCONFDIR}/openct.conf
CONF_FILES+= ${EGDIR}/reader.conf ${PKG_SYSCONFDIR}/reader.conf.d/openct-reader.conf
BUILD_DEFS+= VARBASE
INSTALLATION_DIRS= ${EGDIR}

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.4 2009/09/25 08:36:05 hasso Exp $
$NetBSD: distinfo,v 1.5 2009/10/02 12:38:44 hasso Exp $
SHA1 (openct-0.6.18.tar.gz) = b0c5bfa92683fd6c608e21eb07559dfd666f1883
RMD160 (openct-0.6.18.tar.gz) = 377fe50775a5bd104aadf7770f14f494047a099a
Size (openct-0.6.18.tar.gz) = 688931 bytes
SHA1 (patch-aa) = d44e8daa9cc402c8276bf385a5fbbe5a498b37bb
SHA1 (patch-ab) = 117d4a1636620f65feb130deb295a31c4cb90d5a

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ab,v 1.1 2009/10/02 12:38:44 hasso Exp $
--- etc/reader.conf.in.orig 2009-10-02 15:25:50 +0300
+++ etc/reader.conf.in 2009-10-02 15:26:17 +0300
@@ -1,9 +1,9 @@
# OpenCT configuration file for pcsc-lite
# http://www.opensc.org/openct/
-
-FRIENDLYNAME "OpenCT"
-DEVICENAME /dev/null
-LIBPATH @libdir@/openct-ifd.so
-CHANNELID 0
-
+#
+# FRIENDLYNAME "OpenCT"
+# DEVICENAME /dev/null
+# LIBPATH @libdir@/openct-ifd.so
+# CHANNELID 0
+#
# End of file