Feature and bugfix release. New Touch commands, counters, and a change to connection limit functionality.
*Touch Commands
*Binary Touch/GAT commands were backported from 1.6.
*New GATK/GATKQ commands were added for completeness.
*Finally, an Ascii protocol touch command was also added.
*Fast Connection Limit Handling
*Internal Hash Table
*New Stats: expired_unfetched, evicted_unfetched

1.4.9:
Small bugfix release. Mainly fixing a critical issue where using -c to increase the connection limit was broken in 1.4.8. If you are on 1.4.8, an upgrade is highly recommended.

1.4.10:
This release is focused on thread scalability and performance improvements. This release should be able to feed data back faster than any network card can support as of this writing.

1.4.11:
Memcached 1.4.11. Fixes race conditions and crashes introduced in 1.4.10. Adds the ability to rebalance and reassign slab memory.
*Slab Reassign
*Slab Automove
*New Stats: slab_reassign_running, slabs_moved

1.4.12:
Fix a small number of bugs, mostly in building on different platforms.

1.4.13:
Really tiny release with some important build fixes which were accidentally omitted from 1.4.12.
This commit is contained in:
mspo 2012-02-25 20:52:53 +00:00
parent 0d9d388221
commit ffc8f99e53
5 changed files with 25 additions and 33 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.25 2011/10/03 11:53:11 adam Exp $
# $NetBSD: Makefile,v 1.26 2012/02/25 20:52:53 mspo Exp $
DISTNAME= memcached-1.4.7
DISTNAME= memcached-1.4.13
CATEGORIES= devel
MASTER_SITES= http://memcached.googlecode.com/files/

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.11 2011/10/03 11:53:11 adam Exp $
$NetBSD: distinfo,v 1.12 2012/02/25 20:52:53 mspo Exp $
SHA1 (memcached-1.4.7.tar.gz) = 09e6ba550ea9f55b3116cd084b23ea2b923f9b41
RMD160 (memcached-1.4.7.tar.gz) = 95bad7c299721fd0d6ff7c0e4b36314a7a29c792
Size (memcached-1.4.7.tar.gz) = 307741 bytes
SHA1 (memcached-1.4.13.tar.gz) = d9a48d222de53a2603fbab6156d48d0e8936ee92
RMD160 (memcached-1.4.13.tar.gz) = eb2dc6c034594024522c4880c76f8ea90d3b6bc8
Size (memcached-1.4.13.tar.gz) = 320751 bytes
SHA1 (patch-Makefile.in) = 1f1b924b47840c7aa3e2a11c03300bbce58629e2
SHA1 (patch-aa) = 1513c6d8004242711b1c7f1d83b589edb623d772
SHA1 (patch-ab) = 5ed8e65afebc44404c11b67cbed1012d54a4228c
SHA1 (patch-configure) = e908620cdeee51673a80f958f3ce6d1d190c0822
SHA1 (patch-aa) = a888e2d8ff08278514ff081706465a93c19c44a8
SHA1 (patch-ab) = a870c803752bca12550da73d19ee0e675b5e576d
SHA1 (patch-configure) = 7f776205954f8a12bf52d97722ce59693f6f5aa6

View file

@ -1,10 +1,10 @@
$NetBSD: patch-aa,v 1.5 2011/10/03 11:53:11 adam Exp $
$NetBSD: patch-aa,v 1.6 2012/02/25 20:52:53 mspo Exp $
time_t changes
--- items.c.orig 2011-08-10 15:44:52.000000000 +0000
--- items.c.orig 2012-02-25 20:16:35.000000000 +0000
+++ items.c
@@ -383,9 +383,9 @@ char *do_item_cachedump(const unsigned i
@@ -379,9 +379,9 @@ char *do_item_cachedump(const unsigned i
/* Copy the key since it may not be null-terminated in the struct */
strncpy(key_temp, ITEM_key(it), it->nkey);
key_temp[it->nkey] = 0x00; /* terminate */
@ -16,19 +16,20 @@ time_t changes
if (bufcurr + len + 6 > memlimit) /* 6 is END\r\n\0 */
break;
memcpy(buffer + bufcurr, temp, len);
@@ -429,13 +429,13 @@ void do_item_stats(ADD_STAT add_stats, v
@@ -419,13 +419,13 @@ void do_item_stats(ADD_STAT add_stats, v
continue;
}
APPEND_NUM_FMT_STAT(fmt, i, "number", "%u", sizes[i]);
- APPEND_NUM_FMT_STAT(fmt, i, "age", "%u", tails[i]->time);
+ APPEND_NUM_FMT_STAT(fmt, i, "age", "%jd", tails[i]->time);
- APPEND_NUM_FMT_STAT(fmt, i, "age", "%u", current_time - tails[i]->time);
+ APPEND_NUM_FMT_STAT(fmt, i, "age", "%jd", current_time - tails[i]->time);
APPEND_NUM_FMT_STAT(fmt, i, "evicted",
"%u", itemstats[i].evicted);
"%llu", (unsigned long long)itemstats[i].evicted);
APPEND_NUM_FMT_STAT(fmt, i, "evicted_nonzero",
"%u", itemstats[i].evicted_nonzero);
"%llu", (unsigned long long)itemstats[i].evicted_nonzero);
APPEND_NUM_FMT_STAT(fmt, i, "evicted_time",
- "%u", itemstats[i].evicted_time);
+ "%jd", itemstats[i].evicted_time);
APPEND_NUM_FMT_STAT(fmt, i, "outofmemory",
"%u", itemstats[i].outofmemory);
"%llu", (unsigned long long)itemstats[i].outofmemory);
APPEND_NUM_FMT_STAT(fmt, i, "tailrepairs",

View file

@ -1,10 +1,10 @@
$NetBSD: patch-ab,v 1.7 2011/10/03 11:53:11 adam Exp $
$NetBSD: patch-ab,v 1.8 2012/02/25 20:52:53 mspo Exp $
time_t changes
--- memcached.h.orig 2011-08-10 04:53:38.000000000 +0000
+++ memcached.h
@@ -195,7 +195,7 @@ enum delta_result_type {
@@ -199,7 +199,7 @@ enum delta_result_type {
};
/** Time relative to server start. Smaller than time_t on 64-bit systems. */

View file

@ -1,22 +1,13 @@
$NetBSD: patch-configure,v 1.1 2011/10/03 11:53:11 adam Exp $
$NetBSD: patch-configure,v 1.2 2012/02/25 20:52:53 mspo Exp $
--- configure.orig 2011-08-16 22:35:45.000000000 +0000
--- configure.orig 2012-02-25 19:58:48.000000000 +0000
+++ configure
@@ -5282,7 +5282,7 @@ rm -f core conftest.err conftest.$ac_obj
saved_LDFLAGS="$saved_LDFLAGS -Wl,-R$ledir/lib"
else
if test "$GCC" = "yes"; then :
- saved_LDFLAGS="$saved_LDFLAGS -Wl,-rpath=$ledir/lib"
+ saved_LDFLAGS="$saved_LDFLAGS -Wl,-rpath $ledir/lib"
fi
fi
else
@@ -6183,7 +6183,7 @@ $as_echo "#define _GNU_SOURCE 1" >>confd
@@ -6261,7 +6261,7 @@ $as_echo "#define _GNU_SOURCE 1" >>confd
elif test "$GCC" = "yes"
then
GCC_VERSION=`$CC -dumpversion`
- CFLAGS="$CFLAGS -Wall -Werror -pedantic -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls"
+ CFLAGS="$CFLAGS -Wall -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls"
+ CFLAGS="$CFLAGS -Wall -pedantic -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls"
case $GCC_VERSION in
4.4.*)
CFLAGS="$CFLAGS -fno-strict-aliasing"