Added two patches to make the package compile on Solaris 8.

This commit is contained in:
rillig 2006-08-03 00:39:24 +00:00
parent f63a40d9e4
commit ffce49442e
3 changed files with 38 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.5 2006/01/05 16:03:25 gdt Exp $
$NetBSD: distinfo,v 1.6 2006/08/03 00:39:24 rillig Exp $
SHA1 (mail-notification-2.0.tar.gz) = dcfc89bbc03c08da086843426f459ac0127f5891
RMD160 (mail-notification-2.0.tar.gz) = 0fb3adc3331f0699ca6fb01f3c63f360aa79a7fb
@ -6,3 +6,5 @@ Size (mail-notification-2.0.tar.gz) = 869151 bytes
SHA1 (patch-aa) = a11b31afa5a50d2a5f079fb388cb6cc14ac718f5
SHA1 (patch-ab) = 1fa7a94e4c9b25d810d85c7a2b136a7cdee51f5a
SHA1 (patch-ac) = ba2b926da035ac2b53245d2a80e09574ace4d438
SHA1 (patch-ad) = 9698b4e6551fcacd3fe4dea5a1227eb3b4c50f0c
SHA1 (patch-ae) = f6b6eddb8739b77a9e9932a1d1cf77830268de08

View file

@ -0,0 +1,16 @@
$NetBSD: patch-ad,v 1.1 2006/08/03 00:39:24 rillig Exp $
This is needed so that the preprocessor macros can be queried in
mn-md5.h.
--- src/mn-md5.c.orig 2006-08-01 11:13:36.000000000 +0200
+++ src/mn-md5.c 2006-08-01 11:13:47.255953537 +0200
@@ -26,6 +26,8 @@
* edited for clarity and style only.
*/
+#include <config.h>
+
#include <sys/types.h>
#include <string.h>
#include <glib.h>

View file

@ -0,0 +1,19 @@
$NetBSD: patch-ae,v 1.1 2006/08/03 00:39:24 rillig Exp $
Solaris 8 has <inttypes.h>, but not u_int32_t.
--- src/mn-md5.h.orig 2005-06-11 01:19:32.000000000 +0200
+++ src/mn-md5.h 2006-08-01 11:18:34.558138839 +0200
@@ -29,6 +29,12 @@
#ifndef _MN_MD5_H
#define _MN_MD5_H
+#ifdef HAVE_INTTYPES_H
+# include <inttypes.h>
+# if defined(__sun) && !defined(u_int32_t)
+# define u_int32_t uint32_t
+# endif
+#endif
#include <sys/types.h>
typedef struct