dependencies. Changes not explicitly listed, but the config file format changed again. :-( NOTES mentions: the semantics of WMII_MENU, WMII_9MENU and WMII_TERM have changed. If you're using them in custom scripts you'll need to change them to "eval $WMII_MENU" instead of just "$WMII_MENU"
28 lines
612 B
Text
28 lines
612 B
Text
$NetBSD: patch-aa,v 1.6 2008/01/06 21:55:38 ghen Exp $
|
|
|
|
--- config.mk.orig 2007-11-16 14:59:15.000000000 +0100
|
|
+++ config.mk
|
|
@@ -1,10 +1,9 @@
|
|
# Customize below to fit your system
|
|
|
|
# paths
|
|
-PREFIX = /usr/local
|
|
BIN = ${PREFIX}/bin
|
|
-MAN = ${PREFIX}/share/man
|
|
-ETC = ${PREFIX}/etc
|
|
+MAN = ${PREFIX}/${PKGMANDIR}
|
|
+ETC = ${PKG_SYSCONFBASE}
|
|
LIBDIR = ${PREFIX}/lib
|
|
INCLUDE = ${PREFIX}/include
|
|
|
|
@@ -14,8 +13,8 @@ LIBS = -L/usr/lib -lc -L${ROOT}/lib
|
|
|
|
# Flags
|
|
include ${ROOT}/mk/gcc.mk
|
|
-CFLAGS += -g -O0 -DIXPlint
|
|
-LDFLAGS += -g ${LIBS}
|
|
+CFLAGS += -DIXPlint
|
|
+LDFLAGS += ${LIBS}
|
|
STATIC = -static
|
|
MKDEP = cpp -M
|
|
|