pkgsrc/emulators/vice/patches/patch-aa
wiz dc209878d9 Update to 2.3, provided by Olaf 'Rhialto' Seibert in PR 44820, with a
slight fix.

* Changes in VICE 2.3
======================

** General
----------

- Added x64sc, the accurate C64 emulator:

  * VIC-II emulation rewritten from scratch using results from extensive
    testing with newly written test programs on real hardware.

  * Emulation is done on a cycle by cycle basis combined with pixel exact
    dot clock domain handling.

  * Accurate handling of all possible in-line splits of VIC-II registers
    and graphics data.

  * C64 model and even individual chip revisions can be selected for very
    detailed emulation of their differences.

  * Equally accurate PAL, NTSC and PAL-N emulation.

  We believe x64sc is one of the most accurate C64 emulators at the
  moment.

- Drive improvements, including weak bit emulation.

- Major reSID overhaul:

  * Emulation of all known pipeline delays for full cycle accuracy.
  * New shift register model based on revectorized die photograps.
  * Accurate DAC models based on revectorized die photograps.
  * Emulation of floating waveform DAC input for waveform 0.
  * Advanced 6581 transistor level filter model based on revectorized
    die photograps, yielding unprecedented accuracy.

- CRT Emulation (former "PAL emulation") is now available regardless of
  video mode or -chip and works in all emulators.

  NOTE: Color gamma range changed. You may need to set to 2.200 manually.
  (ColorGamma=2200)

- Added "True aspect ratio" option.

- Sound buffer overflows reduced and the error replaced with a warning.

- Various monitor improvements (io details, expansion port status ...)

- Removed little used Emulator ID feature.

- VIA wrap handling rewritten to fix problems with timer 2.

- Added autostart option to do LOAD ,8 instead of ,8,1.

- RESTORE key presses are now distributed randomly across a frame.

- Improved accuracy of CIA interrupts. (6526/6526A selectable)

** C64/C128 changes
-------------------

- Cartridge emulation improvements. Many broken cartridges fixed, and the
  following ones added:

  * Action Replay 2
  * Action Replay 3
  * Capture
  * Diashow Maker
  * EXOS
  * Final Cartridge Plus
  * Freeze Frame
  * Freeze Machine
  * Game Killer
  * MACH 5
  * Magic Voice
  * MMC Replay
  * Prophet 64
  * Snapshot 64
  * Super Explode V5
  * Super Snapshot

- Added emulation of the passthrough port of MMC64, Magic Voice and IEEE488
  cartridges.

- CIA TOD 50/60 Hz toggle emulation fixed.

- Improved 1351/paddles port MUX emulation.

** C64 changes
--------------

- Added Drean (PAL-N) emulation.

- Fixed bug with autostart mode Inject-to-RAM.  It now writes to RAM under
  I/O correctly.

** C128 changes
---------------

- Fixed a bug with autostarting t64 images.

** VIC20 changes
----------------

- Added Vic Flash Plugin cartridge emulation.

- Fixed video cache & reverse bug.

- Fixed bug in attaching 4kB cartridges.

- Fixed autostarting bug, mostly seen with tape images.

** PLUS4 changes
----------------

- Fixed crashes in NTSC mode.

- Added v364 speech emulation.

** PET changes
--------------

- Added DWW emulation.

- Added userport DAC emulation.

** CBM2 changes
---------------

- Split 5x0 and 6x0/7x0 settings in the configuration file.

** Unix changes
---------------

- (Xaw) The menus can now be operated without holding the
  mouse button down. Keyboard control is also available
  (Shift-Alt-Z for left menu, Shift-Alt-X for right menu).

- (Xaw) Lightpen/gun support added.

- (GTK+) Fixed aspect ratio option added.

** SDL UI changes
-----------------

- Added vsid UI, FFMPEG and printer menus. The UI is complete.
2011-04-04 13:42:08 +00:00

21 lines
755 B
Text

$NetBSD: patch-aa,v 1.11 2011/04/04 13:42:08 wiz Exp $
Bring back DESTDIR support which is somehow patched out by pkgsrc.
localedir = $(DESTDIR)$(datadir)/locale
is changed to
localedir = /usr/pkg/share/locale
and the same for gnulocaledir.
--- po/Makefile.in.in.dist 2011-02-27 00:39:47.000000000 +0100
+++ po/Makefile.in.in 2011-02-27 01:11:12.000000000 +0100
@@ -126,8 +126,8 @@
for cat in $$catalogs; do \
cat=`basename $$cat`; \
case "$$cat" in \
- *.gmo) destdir=$(gnulocaledir);; \
- *) destdir=$(localedir);; \
+ *.gmo) destdir=$(DESTDIR)$(gnulocaledir);; \
+ *) destdir=$(DESTDIR)$(localedir);; \
esac; \
lang=`echo $$cat | sed 's/\$(CATOBJEXT)$$//'`; \
dir=$$destdir/$$lang/LC_MESSAGES; \