2c2374c4a2
3.10.1: bootstrap: Check support for unordered_map from compiler mode CPack: Fix macOS PKG component dependency information CUDA: Treat /usr/include as an implicit include directory server: Revert "Report backtraces in codemodel response" CMake 3.10.1 FindMPI: Correct legacy variable handling FindMPI: Fix multiple configure runs FindMPI: Fix various legacy problems IRSL: Fix MSVC variable deferencing IAR: FindBinUtils should work for CXX as well as C GoogleTest: Fix multiple discovery on same target GoogleTest: Improve gtest_discover_tests messages GoogleTest: Add timeout to discovery GoogleTest: Add test for missing test executable CUDA: Shared libraries on Darwin properly setup @rpath install_names Autogen: Fix for AUTOMOC on macOS frameworks in CMake 3.10 Autogen: Tests: Add test for MacOS frameworks Clang: Do not mistake clang-cl 6.0 for GNU-like clang
31 lines
1.2 KiB
Text
31 lines
1.2 KiB
Text
$NetBSD: patch-bootstrap,v 1.2 2017/12/14 22:13:34 adam Exp $
|
|
|
|
Use external libuv; the one included with cmake makes building fail.
|
|
|
|
--- bootstrap.orig 2017-11-20 15:19:54.000000000 +0000
|
|
+++ bootstrap
|
|
@@ -1305,11 +1306,8 @@ objs=""
|
|
for a in ${CMAKE_CXX_SOURCES} ${CMAKE_C_SOURCES} ${LexerParser_CXX_SOURCES} ${LexerParser_C_SOURCES} ${KWSYS_CXX_SOURCES} ${KWSYS_C_SOURCES}; do
|
|
objs="${objs} ${a}.o"
|
|
done
|
|
-for a in ${LIBUV_C_SOURCES}; do
|
|
- objs="${objs} uv-`cmake_obj ${a}`"
|
|
-done
|
|
|
|
-libs=""
|
|
+libs="-luv"
|
|
|
|
uv_c_flags=""
|
|
if ${cmake_system_mingw}; then
|
|
@@ -1419,11 +1417,6 @@ for a in ${KWSYS_CXX_SOURCES}; do
|
|
echo "${a}.o : ${src} ${dep}" >> "${cmake_bootstrap_dir}/Makefile"
|
|
echo " ${cmake_cxx_compiler} ${cmake_cxx_flags} -DKWSYS_NAMESPACE=cmsys ${src_flags} -c ${src} -o ${a}.o" >> "${cmake_bootstrap_dir}/Makefile"
|
|
done
|
|
-for a in ${LIBUV_C_SOURCES}; do
|
|
- src=`cmake_escape "${cmake_source_dir}/Utilities/cmlibuv/${a}"`
|
|
- echo "uv-`cmake_obj ${a}` : ${src} ${dep}" >> "${cmake_bootstrap_dir}/Makefile"
|
|
- echo " ${cmake_c_compiler} ${cmake_c_flags} ${uv_c_flags} -c ${src} -o uv-`cmake_obj ${a}`" >> "${cmake_bootstrap_dir}/Makefile"
|
|
-done
|
|
echo '
|
|
rebuild_cache:
|
|
cd "${cmake_binary_dir}" && "${cmake_source_dir}/bootstrap"
|