pkgsrc/x11/fltk/patches/patch-ad
adam 489e7e05e2 Changes 1.1.9:
- Improved color contrast in secondary selection blocks of Fl_Text_Display
- Fixed regression in callback handling
- Fixed wrong relative path when absolute path has a
  trailing slash in fl_filename_relative
- Fixed multiple selction of files and directories in Fl_File_Chooser
- Fixed MSWindows crash when selecting umlauts in Fl_Help_View

Changes 1.1.8:
- Documentation fixes
- Fixed library path in Makefile
- Fixed image read for partial regions on X11
- Fixed KDE/Gnome icon paths
- Fixed Tab key to wrap around menu bars
- Fixed possible timer leak in Scrollbar
- Added documentation about the potential limitations
  of Fl::grab on newer operating systems
- Fixed lockout when mixing popups and alerts
- Fixed recursion crash in event handling
- Fixed missing return code in 'fltk-config'
- Fixed inconsistencies with CHANGED flags
- Fixed message sent to hidden widgets
- Fixed width calculation in Fl_Help_View
- Fixed offset bug in OS X pixmap code
- Fixed potential buffer overrun in Fl_Preferences
- More...
2008-11-10 19:03:15 +00:00

16 lines
749 B
Text

$NetBSD: patch-ad,v 1.10 2008/11/10 19:03:15 adam Exp $
--- documentation/Makefile.orig 2008-11-10 17:38:24.000000000 +0100
+++ documentation/Makefile
@@ -237,11 +237,6 @@ install: $(MANPAGES)
$(INSTALL_DATA) $$file $(DESTDIR)$(docdir); \
done
echo "Installing man pages in $(DESTDIR)$(mandir)..."
- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat1
- $(INSTALL_MAN) fluid.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
- $(INSTALL_MAN) fltk-config.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat3
- $(INSTALL_MAN) fltk.$(CAT3EXT) $(DESTDIR)$(mandir)/cat3
-$(INSTALL_DIR) $(DESTDIR)$(mandir)/man1
$(INSTALL_MAN) fluid.man $(DESTDIR)$(mandir)/man1/fluid.1
$(INSTALL_MAN) fltk-config.man $(DESTDIR)$(mandir)/man1/fltk-config.1