7a194ddbc8
Based on patch from Tim Larson by PR#43061. CHANGES IN FLTK 1.1.10 - Widgets now remove stale entries from the default callback queue when they are deleted (STR #2302) - Fixed selection bug in Fl_Int_Input (STR #2292) - Fixed character set conversion functions (STR #2268) - Fixed image lib configure and fltk-config issues by backporting the image lib and zlib configure code from FLTK 1.3 (STR #2203) - Updated the bundled libpng to v1.2.40 (released Sep. 10, 2009) - Fixed Fl_Choice contrast with light-on-dark settings (STR #2219) - Added Xft2 font lookup table (STR #2215) - Fixed X server "lock", if a modal dialog window is opened while a menu is active (STR #1986) - Updated mirror sites in documentation (STR #2220) - Setting a default font for Xft (STR #2216) - Temporarily limited builds to 32-bit on OX S to stay compatible to Snow Leopard - Fixed Windows compile bug with "#define USE_COLORMAP 0" (STR #2241) - Fixed glibc 2.10 compiler problems (Fedora 11 and others) with scandir() and strchr() (STR #2222) - Fixed OpenGL shared context handling (STR #2135) - Fixed gray-scale images with alpha channel (STR #2105) - Fixed unexpected shortcut behavior for Win32 (STR #2199) - Added cast to Fl_Color in all Fluid code (STR #2206) - Fixed wrong identifier for special keys combined with modifier (STR #2196) - Fixed documentation for Fl_Progress (STR #2209) - Fix for multiple popups, when dragging and calling fl_alert() and friends from the callback (STR #2159) - Avoiding crashes for recursive common dialogs (this does not fix the issue at hand yet) (STR 2150) - Fluid printing used wrong colors under Windows (STR #2195) - Fixed bad system menu hadling in OS X (STR #2153) - Fixed File Input mouse pointer dragging (STR #2181) - Added Fl_Scroll::bbox() documentation (STR #1893) - Fixed static linking of image libraries (STR #1962) - Fixed callback would not be called when shortcut was used with radio and toggle buttons in default FL_RELEASE mode. - Fixed a problem with TrackMouseEvent() (Windows only) that would generate wrong FL_LEAVE events with subwindows. TrackMouseEvent is now enabled by default (it was disabled for GNU compilers). It can be disabled by defining NO_TRACK_MOUSE. Improved test/subwindow.cxx (STR #2079) - Fixed RGB colors for round box (STR #2097) - Fixed documentation (added missing COMCTRL32.LIB dependency) - Fl_Group::clip_children() is now public (STR #2017) - Fixed first modifier key event (STR #1952) - Fixed wrong default value of Fl_Spinner in Fluid (STR #1991) - Fixed Fluid textcolor output (STR #1992) - Added clarification to Fl_GL_Window mode function (STR #1945) - Fl_Group and Fl_Scroll now resize themselves before resizing their children (STR #2032) - Fixed adding an idle handler during a draw() call (STR #1950) - Improved stability of fl_read_image (STR #2021) - Fixed menu position close to screen border (STR #2057)
88 lines
3.5 KiB
Text
88 lines
3.5 KiB
Text
$NetBSD: patch-ag,v 1.8 2010/04/09 13:35:42 obache Exp $
|
|
|
|
--- src/Makefile.orig 2009-07-02 09:42:17.000000000 +0000
|
|
+++ src/Makefile
|
|
@@ -208,6 +208,10 @@ $(LIBNAME): $(OBJECTS)
|
|
$(LIBCOMMAND) $@ $(OBJECTS)
|
|
$(RANLIB) $@
|
|
|
|
+libfltk.la: $(OBJECTS)
|
|
+ echo $(CXX) $@ ...
|
|
+ ${LIBTOOL} --mode=link $(CXX) $(ARCHFLAGS) $(LDFLAGS) -o $@ $(OBJECTS:.o=.lo) -rpath $(prefix)/lib -version-info 1:9 $(LDLIBS)
|
|
+
|
|
libfltk.so.1.1: $(OBJECTS)
|
|
echo $(DSOCOMMAND) $@ ...
|
|
$(DSOCOMMAND) $@ $(OBJECTS)
|
|
@@ -244,6 +248,10 @@ $(FLLIBNAME): $(FLOBJECTS)
|
|
$(LIBCOMMAND) $@ $(FLOBJECTS)
|
|
$(RANLIB) $@
|
|
|
|
+libfltk_forms.la: $(FLOBJECTS)
|
|
+ echo $(CXX) $@ ...
|
|
+ ${LIBTOOL} --mode=link $(CXX) $(ARCHFLAGS) $(LDFLAGS) -o $@ $(FLOBJECTS:.o=.lo) -rpath $(prefix)/lib -version-info 1:9 $(LDLIBS)
|
|
+
|
|
libfltk_forms.so.1.1: $(FLOBJECTS) libfltk.so.1.1
|
|
echo $(DSOCOMMAND) $@ ...
|
|
$(DSOCOMMAND) $@ $(FLOBJECTS) -L. -lfltk
|
|
@@ -280,6 +288,10 @@ $(GLLIBNAME): $(GLOBJECTS)
|
|
$(LIBCOMMAND) $@ $(GLOBJECTS)
|
|
$(RANLIB) $@
|
|
|
|
+libfltk_gl.la: $(GLOBJECTS)
|
|
+ echo $(CXX) $@ ...
|
|
+ ${LIBTOOL} --mode=link $(CXX) $(ARCHFLAGS) $(LDFLAGS) -o $@ $(GLOBJECTS:.o=.lo) -rpath $(prefix)/lib -version-info 1:9 $(LDLIBS)
|
|
+
|
|
libfltk_gl.so.1.1: $(GLOBJECTS) libfltk.so.1.1
|
|
echo $(DSOCOMMAND) $@ ...
|
|
$(DSOCOMMAND) $@ $(GLOBJECTS) -L. -lfltk
|
|
@@ -316,6 +328,10 @@ $(IMGLIBNAME): $(IMGOBJECTS)
|
|
$(LIBCOMMAND) $@ $(IMGOBJECTS)
|
|
$(RANLIB) $@
|
|
|
|
+libfltk_images.la: $(IMGOBJECTS)
|
|
+ echo $(CXX) $@ ...
|
|
+ ${LIBTOOL} --mode=link $(CXX) $(ARCHFLAGS) $(LDFLAGS) -o $@ $(IMGOBJECTS:.o=.lo) -rpath $(prefix)/lib -version-info 1:9 $(LDLIBS)
|
|
+
|
|
libfltk_images.so.1.1: $(IMGOBJECTS) libfltk.so.1.1
|
|
echo $(DSOCOMMAND) $@ ...
|
|
$(DSOCOMMAND) $@ $(IMGOBJECTS) -L. $(IMAGELIBS) -lfltk
|
|
@@ -504,6 +520,9 @@ install: $(LIBNAME) $(DSONAME) \
|
|
$(RANLIB) $(DESTDIR)$(libdir)/$(GLLIBBASENAME); \
|
|
fi
|
|
$(RANLIB) $(DESTDIR)$(libdir)/$(IMGLIBBASENAME)
|
|
+ if test x$(DSONAME) = xlibfltk.la; then\
|
|
+ ${LIBTOOL} --mode=install $(INSTALL_LIB) libfltk.la $(DESTDIR)$(libdir); \
|
|
+ fi
|
|
if test x$(DSONAME) = xlibfltk.so.1.1; then\
|
|
$(RM) $(DESTDIR)$(libdir)/libfltk.so*;\
|
|
$(INSTALL_LIB) libfltk.so.1.1 $(DESTDIR)$(libdir); \
|
|
@@ -523,6 +542,9 @@ install: $(LIBNAME) $(DSONAME) \
|
|
$(RM) $(DESTDIR)$(libdir)/libfltk_s.a;\
|
|
$(INSTALL_LIB) libfltk_s.a $(DESTDIR)$(libdir); \
|
|
fi
|
|
+ if test x$(FLDSONAME) = xlibfltk_forms.la; then\
|
|
+ ${LIBTOOL} --mode=install $(INSTALL_LIB) libfltk_forms.la $(DESTDIR)$(libdir); \
|
|
+ fi
|
|
if test x$(DSONAME) = xcygfltknox-1.1.dll; then\
|
|
$(RM) $(DESTDIR)$(bindir)/$(DSONAME);\
|
|
$(INSTALL_LIB) $(DSONAME) $(DESTDIR)$(bindir); \
|
|
@@ -540,6 +562,9 @@ install: $(LIBNAME) $(DSONAME) \
|
|
$(INSTALL_LIB) libfltk_forms.so.1.1 $(DESTDIR)$(libdir); \
|
|
$(LN) libfltk_forms.so.1.1 $(DESTDIR)$(libdir)/libfltk_forms.so;\
|
|
fi
|
|
+ if test x$(GLDSONAME) = xlibfltk_gl.la; then\
|
|
+ ${LIBTOOL} --mode=install $(INSTALL_LIB) libfltk_gl.la $(DESTDIR)$(libdir); \
|
|
+ fi
|
|
if test x$(FLDSONAME) = xlibfltk_forms.sl.1.1; then\
|
|
$(RM) $(DESTDIR)$(libdir)/libfltk_forms.sl*;\
|
|
$(INSTALL_LIB) libfltk_forms.sl.1.1 $(DESTDIR)$(libdir); \
|
|
@@ -597,6 +622,9 @@ install: $(LIBNAME) $(DSONAME) \
|
|
$(RM) $(DESTDIR)$(libdir)/libfltk_gl.dll.a;\
|
|
$(INSTALL_LIB) libfltk_gl.dll.a $(DESTDIR)$(libdir); \
|
|
fi
|
|
+ if test x$(IMGDSONAME) = xlibfltk_images.la; then\
|
|
+ ${LIBTOOL} --mode=install $(INSTALL_LIB) libfltk_images.la $(DESTDIR)$(libdir); \
|
|
+ fi
|
|
if test x$(IMGDSONAME) = xlibfltk_images.so.1.1; then\
|
|
$(RM) $(DESTDIR)$(libdir)/libfltk_images.so*;\
|
|
$(INSTALL_LIB) libfltk_images.so.1.1 $(DESTDIR)$(libdir); \
|