pkgsrc/sysutils/dbus/patches/patch-aa
jmmv b576e17d25 Update dbus and dbus-glib to 0.23.4:
D-BUS 0.23.4 (11 Mar 2005)
===
- fix a failed assertion when trying to get replies from certain
  pending calls

D-BUS 0.23.3 (9 Mar 2005)
===
- add back dbus_pending_call_get_reply() which was removed accidentally.
- fix a memory leak in return messages
- fix many memory leaks and lifecycle issues in the mono bindings.

D-BUS 0.23.2 (18 Feb 2005)
===
- shuffle some code around in the mono bindings to deterministically
  finalize classes so that delegates are unregistered correctly.
- backport a bunch of thread locking-related fixes from HEAD.

D-BUS 0.23.1 (11 Feb 2005)
===
- fix a bug in which the bus daemon wouldn't recognize that a service
  owner quit
- fix a bug in the mono bindings that would cause unmanaged code to
  call back into a delegate that had been garbage collected and
  crashed.

D-BUS 0.23 (11 Jan 2005)
===

- add setgroups() to drop supplementary groups
- updated SELinux support
- add an "at console" security policy
- fix a bug where org.freedesktop.DBus wasn't recognized as an existing
  service.
- error out if --enable-mono is explicitly set and mono libs can't be found
- set the max_match_rules_per_connection limit from the config file.
- removed dbus_bug_get_with_g_main since it's been replaced by
  dbus_g_bus_get
- fix fd leaks in socket code
- lots and lots of mono binding updates, including fixes to make it
  compatible with Mono 1.1.3
- added --nofork option to override config file setting at runtime
- added support for int64 and uint64 to the python bindings
- lots of python binding updates
- config file DTD updates
- use SerivceOwnerChanges signal instead of ServiceCreated and
  ServiceDeleted
- fixes to the authentication code
- new init script for Slackware
- print out the pid even when --fork is passed
- increase preallocation sizes in DBusMessage to heavily reduce
  reallocs
- lots of performance enhancements
- lots more small bug fixes
2005-03-22 10:55:13 +00:00

28 lines
1.1 KiB
Text

$NetBSD: patch-aa,v 1.2 2005/03/22 10:55:13 jmmv Exp $
--- bus/Makefile.in.orig 2005-01-12 23:21:12.000000000 +0100
+++ bus/Makefile.in
@@ -337,11 +337,11 @@ sbindir = @sbindir@
sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
-configdir = $(sysconfdir)/dbus-1
+configdir = $(datadir)/examples/@PACKAGE@
INCLUDES = -I$(top_srcdir) $(DBUS_BUS_CFLAGS) \
-DDAEMON_NAME=\"dbus-daemon-1\" -DDBUS_COMPILATION \
- -DDBUS_SYSTEM_CONFIG_FILE=\""$(configdir)/system.conf"\" \
- -DDBUS_SESSION_CONFIG_FILE=\""$(configdir)/session.conf"\"
+ -DDBUS_SYSTEM_CONFIG_FILE=\""$(sysconfdir)/system.conf"\" \
+ -DDBUS_SESSION_CONFIG_FILE=\""$(sysconfdir)/session.conf"\"
EFENCE =
CONFIG_IN_FILES = \
@@ -899,8 +899,6 @@ clean-local:
/bin/rm *.bb *.bbg *.da *.gcov || true
install-data-hook:
- $(mkinstalldirs) $(DESTDIR)/$(localstatedir)/run/dbus
- $(mkinstalldirs) $(DESTDIR)/$(configdir)/system.d
$(mkinstalldirs) $(DESTDIR)/$(datadir)/dbus-1/services
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.