db9a921ee0
Changes since previous verion, from the NEWS file 2.8.x: - More scalable directory tree locking - Atomic open(O_TRUNC) support - Support big write requests on kernels 2.6.26 and newer - Out-of-tree fuse module removed - Better NFS exporting support - New ioctl and poll requests - New CUSE (Character Device in Userspace) interface - Allow umask processing in userspace - Added cache invalidation notifications - Bugfixes and small improvements 2.7.x: - Stacking support for the high level API - Add filename charset conversion module - Improved mounting 2.6.x! - Improved read characteristics (asynchronous reads) - Support for aborting filesystem connection - POSIX file locking support - Request interruption support - Building module for Linux kernels earlier than 2.6.9 not supported - Allow block device based filesystems to support swap files - Several bugs fixed, including a rare system hang on SMP
25 lines
681 B
Text
25 lines
681 B
Text
$NetBSD: patch-ak,v 1.1 2010/08/25 08:02:21 manu Exp $
|
|
|
|
Take care of NetBSD so that we can link with -lperfuse in makefile.
|
|
--- configure.in.orig 2010-08-24 09:26:08.000000000 +0200
|
|
+++ configure.in 2010-08-24 09:27:01.000000000 +0200
|
|
@@ -15,8 +15,9 @@
|
|
fi
|
|
|
|
case $target_os in
|
|
*linux*) arch=linux;;
|
|
+ *netbsd*) arch=netbsd;;
|
|
*bsd*) arch=bsd;;
|
|
*) arch=unknown;;
|
|
esac
|
|
|
|
@@ -90,8 +91,9 @@
|
|
|
|
AC_SUBST(subdirs2)
|
|
|
|
AM_CONDITIONAL(LINUX, test "$arch" = linux)
|
|
+AM_CONDITIONAL(NETBSD, test "$arch" = netbsd)
|
|
AM_CONDITIONAL(BSD, test "$arch" = bsd)
|
|
|
|
AC_CONFIG_FILES([fuse.pc Makefile lib/Makefile util/Makefile example/Makefile include/Makefile])
|
|
AC_OUTPUT
|