pkgsrc/net/speedtouch/patches/patch-ad
skrll 66d3c5ee50 Update speedtouch to 1.3.1.
The main changes is to support revision 4 modems (silver cycle
helmet/beetle) and to use the threaded pppo3 if native threads are
available.

Tested on:
	- stringray by David Brownlee (abs@) and me
	- purple cycle helmet/beetle by David Brownlee
	- silver cycle helment/beetle by me
2004-12-23 18:11:18 +00:00

27 lines
675 B
Text

$NetBSD: patch-ad,v 1.3 2004/12/23 18:11:18 skrll Exp $
--- src/Makefile.in.orig 2004-09-29 21:56:31.000000000 +0100
+++ src/Makefile.in
@@ -114,19 +114,19 @@ all: ${make_bindir}
speedtouch-setup: speedtouch-setup.in Makefile
rm -f $@ $@.tmp
- $(edit) < $< > $@.tmp
+ $(edit) speedtouch-setup.in > $@.tmp
chmod a+x $@.tmp
mv $@.tmp $@
speedtouch-start: speedtouch-start.in Makefile
rm -f $@ $@.tmp
- $(edit) < $< > $@.tmp
+ $(edit) speedtouch-start.in > $@.tmp
chmod a+x $@.tmp
mv $@.tmp $@
speedtouch-stop: speedtouch-stop.in Makefile
rm -f $@ $@.tmp
- $(edit) < $< > $@.tmp
+ $(edit) speedtouch-stop.in > $@.tmp
chmod a+x $@.tmp
mv $@.tmp $@