pkgsrc/comms/hylafax/patches/patch-ag
adam 65dc98044e Changes 6.0.6:
These releases are maintenance releases, and do not contain any new
features or functionality, but only contain bugfixes:
 * Re-order library files in fchmod() configure check
 * faxalter: Wire up the nissing page range -Z options
 * man: JobReqError/JobRetryError were missing in hylafax-config.4
 * typerules: adding missing comma to typeNames array
 * Do not warn about one of the Fontpath directories not existing
 * Reworked how faxsetup looks for Fontmap
 * Use a private Fontmap.HylaFAX file of .pfb files
 * Combine all Fontmap files in memory, including new Fontmap.HylaFAX
 * Bug 934: We need to avoid a 0-index in playList
 * hfaxd: Eliminte extraneous debug logging
 * hfaxd: Make source port for active connections be ctrl port - 1
 * hfaxd: Release old accept fd
 * Support libtiff 4.0
 * faxsend: JobRetryOther/JobRequeueOther weren't actually being used
 * Make sure not to cut faxq FIFO messages in two when reaching end of buffer
 * hfaxd: Port is network byte order, correct logging of it
2014-03-14 15:59:29 +00:00

38 lines
1.9 KiB
Text

$NetBSD: patch-ag,v 1.6 2014/03/14 15:59:29 adam Exp $
--- etc/Makefile.in.orig 2012-06-06 00:58:38.000000000 +0000
+++ etc/Makefile.in
@@ -86,25 +86,25 @@ install: default
-src ${SRCDIR}/faxsetup.$$i -O faxsetup.$$i; \
done
${PUTSERVER} -F ${SBIN} -m 755 -src probemodem.sh -O probemodem
- ${PUTSAMPLE} -F ${SPOOL}/etc -m 644 -o xferfaxlog
- ${PUTSAMPLE} -F ${SPOOL}/etc -m 600 -o hosts.hfaxd
+ ${PUTSAMPLE} -F ${PREFIX}/share/examples/hylafax -m 644 -o xferfaxlog
+ ${PUTSAMPLE} -F ${PREFIX}/share/examples/hylafax -m 600 -o hosts.hfaxd
for i in ${DIALRULES}; do \
- ${PUTSERVER} -F ${SPOOL}/etc -m 444 -src ${SRCDIR}/$$i \
+ ${PUTSERVER} -F ${PREFIX}/share/examples/hylafax -m 444 -src ${SRCDIR}/$$i \
-idb "config(update)" -O $$i; \
done
${PUTSERVER} -F ${LIBEXEC} -m 755 -O lockname ondelay
- ${PUTSAMPLE} -F ${SPOOL}/etc -m 644 -idb nostrip \
+ ${PUTSAMPLE} -F ${PREFIX}/share/examples/hylafax -m 644 -idb nostrip \
-src ${SRCDIR}/lutRS18.pcf -O lutRS18.pcf
${INSTALL} -u ${FAXUSER} -g ${FAXGROUP} -m ${DIRMODE} \
- -idb hylafax.sw.server -dir -F ${SPOOL}/etc templates
- ${PUTSAMPLE} -F ${SPOOL}/etc/templates -m 644 \
+ -idb hylafax.sw.server -dir -F ${PREFIX}/share/examples/hylafax templates
+ ${PUTSAMPLE} -F ${PREFIX}/share/examples/hylafax/templates -m 644 \
-src ${SRCDIR}/templates/README -O README
@for d in ${TEMPLATES}; do \
${ECHO} "Installing templates/$$d"; \
${INSTALL} -u ${FAXUSER} -g ${FAXGROUP} -m ${DIRMODE} \
- -idb hylafax.sw.server -dir -F ${SPOOL}/etc/templates $$d; \
+ -idb hylafax.sw.server -dir -F ${PREFIX}/share/examples/hylafax/templates $$d; \
for f in ${SRCDIR}/templates/$$d/*; do \
- ${PUTSAMPLE} -F ${SPOOL}/etc/templates/$$d -m 644 -src $$f `basename $$f`; \
+ ${PUTSAMPLE} -F ${PREFIX}/share/examples/hylafax/templates/$$d -m 644 -src $$f `basename $$f`; \
done; \
done;